mirror of https://github.com/hak5/openwrt.git
28 lines
1.3 KiB
Diff
28 lines
1.3 KiB
Diff
From d36a5a94156ebe7e9906574fa8b01b200a15c11d Mon Sep 17 00:00:00 2001
|
|
From: Kieran Bingham <kieran.bingham@ideasonboard.com>
|
|
Date: Mon, 18 Mar 2019 17:14:51 +0000
|
|
Subject: [PATCH] vcsm: Fix makefile include on out-of-tree builds
|
|
|
|
The vc_sm module tries to include the 'fs' directory from the
|
|
$(srctree). $(srctree) is already provided by the build system, and
|
|
causes the include path to be duplicated.
|
|
|
|
With -Werror this fails to compile.
|
|
|
|
Remove the unnecessary variable.
|
|
|
|
Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
|
|
---
|
|
drivers/char/broadcom/vc_sm/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/drivers/char/broadcom/vc_sm/Makefile
|
|
+++ b/drivers/char/broadcom/vc_sm/Makefile
|
|
@@ -1,5 +1,5 @@
|
|
ccflags-$(CONFIG_BCM_VC_SM) += -Werror -Wall -Wstrict-prototypes -Wno-trigraphs -O2
|
|
-ccflags-$(CONFIG_BCM_VC_SM) += -I"drivers/staging/vc04_services" -I"drivers/staging/vc04_services/interface/vchi" -I"drivers/staging/vc04_services/interface/vchiq_arm" -I"$(srctree)/fs/"
|
|
+ccflags-$(CONFIG_BCM_VC_SM) += -I"drivers/staging/vc04_services" -I"drivers/staging/vc04_services/interface/vchi" -I"drivers/staging/vc04_services/interface/vchiq_arm" -I"fs"
|
|
ccflags-$(CONFIG_BCM_VC_SM) += -DOS_ASSERT_FAILURE -D__STDC_VERSION=199901L -D__STDC_VERSION__=199901L -D__VCCOREVER__=0 -D__KERNEL__ -D__linux__
|
|
|
|
obj-$(CONFIG_BCM_VC_SM) := vc-sm.o
|