mirror of https://github.com/hak5/openwrt.git
28 lines
816 B
Diff
28 lines
816 B
Diff
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -9,6 +9,7 @@ ccflags-$(CONFIG_SPI_DEBUG) := -DDEBUG
|
|
obj-$(CONFIG_SPI_MASTER) += spi.o
|
|
|
|
# SPI master controller drivers (bus)
|
|
+obj-$(CONFIG_SPI_AP83) += ap83_spi.o
|
|
obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
|
|
obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
|
|
obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
|
|
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -53,6 +53,14 @@ if SPI_MASTER
|
|
|
|
comment "SPI Master Controller Drivers"
|
|
|
|
+config SPI_AP83
|
|
+ tristate "Atheros AP83 specific SPI Controller"
|
|
+ depends on SPI_MASTER && AR71XX_MACH_AP83
|
|
+ select SPI_BITBANG
|
|
+ help
|
|
+ This is a specific SPI controller driver for the Atheros AP83
|
|
+ reference board.
|
|
+
|
|
config SPI_AR71XX
|
|
tristate "Atheros AR71xx SPI Controller"
|
|
depends on SPI_MASTER && ATHEROS_AR71XX
|