mirror of https://github.com/hak5/openwrt.git
25 lines
977 B
Diff
25 lines
977 B
Diff
Index: linux-2.6.25.1/drivers/mtd/devices/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.25.1.orig/drivers/mtd/devices/Kconfig
|
|
+++ linux-2.6.25.1/drivers/mtd/devices/Kconfig
|
|
@@ -77,6 +77,10 @@ config MTD_M25P80
|
|
if you want to specify device partitioning or to use a device which
|
|
doesn't support the JEDEC ID instruction.
|
|
|
|
+config MTD_SPIFLASH
|
|
+ tristate "Atheros AR2315/6/7 SPI Flash support"
|
|
+ depends on ATHEROS_AR5315
|
|
+
|
|
config MTD_SLRAM
|
|
tristate "Uncached system RAM"
|
|
help
|
|
Index: linux-2.6.25.1/drivers/mtd/devices/Makefile
|
|
===================================================================
|
|
--- linux-2.6.25.1.orig/drivers/mtd/devices/Makefile
|
|
+++ linux-2.6.25.1/drivers/mtd/devices/Makefile
|
|
@@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART) += lart.o
|
|
obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
|
|
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
|
|
obj-$(CONFIG_MTD_M25P80) += m25p80.o
|
|
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o
|