mirror of https://github.com/hak5/openwrt.git
41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -3054,7 +3054,7 @@ case "${target}" in
|
|
am33_2.0-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
- sh-*-linux*)
|
|
+ sh*-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
@@ -3390,7 +3390,7 @@ case "${target}" in
|
|
romp-*-*)
|
|
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
;;
|
|
- sh-*-* | sh64-*-*)
|
|
+ sh*-*-* | sh64-*-*)
|
|
case "${host}" in
|
|
i[3456789]86-*-vsta) ;; # don't add gprof back in
|
|
i[3456789]86-*-go32*) ;; # don't add gprof back in
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -541,7 +541,7 @@ case "${target}" in
|
|
am33_2.0-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
- sh-*-linux*)
|
|
+ sh*-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
@@ -877,7 +877,7 @@ case "${target}" in
|
|
romp-*-*)
|
|
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
;;
|
|
- sh-*-* | sh64-*-*)
|
|
+ sh*-*-* | sh64-*-*)
|
|
case "${host}" in
|
|
i[[3456789]]86-*-vsta) ;; # don't add gprof back in
|
|
i[[3456789]]86-*-go32*) ;; # don't add gprof back in
|