mirror of https://github.com/hak5/openwrt.git
45 lines
1.2 KiB
Diff
45 lines
1.2 KiB
Diff
--- a/arch/arm/plat-s3c24xx/Kconfig
|
|
+++ b/arch/arm/plat-s3c24xx/Kconfig
|
|
@@ -112,4 +112,20 @@ config MACH_SMDK
|
|
help
|
|
Common machine code for SMDK2410 and SMDK2440
|
|
|
|
+config MACH_NEO1973
|
|
+ bool
|
|
+ select RFKILL
|
|
+ select SERIAL_SAMSUNG
|
|
+ select SERIAL_SAMSUNG_CONSOLE
|
|
+ help
|
|
+ Common machine code for Neo1973 hardware
|
|
+
|
|
+config MACH_NEO1973
|
|
+ bool
|
|
+ select RFKILL
|
|
+ select SERIAL_SAMSUNG
|
|
+ select SERIAL_SAMSUNG_CONSOLE
|
|
+ help
|
|
+ Common machine code for Neo1973 hardware
|
|
+
|
|
endif
|
|
--- a/arch/arm/mach-s3c2442/Makefile
|
|
+++ b/arch/arm/mach-s3c2442/Makefile
|
|
@@ -14,3 +14,9 @@ obj-$(CONFIG_CPU_S3C2442) += clock.o
|
|
|
|
# Machine support
|
|
|
|
+obj-$(CONFIG_MACH_NEO1973) += \
|
|
+ gta02-pm-gsm.o \
|
|
+ gta02-pm-gps.o \
|
|
+ gta02-pm-bt.o \
|
|
+ gta02-pm-wlan.o \
|
|
+ gta02-shadow.o
|
|
--- a/drivers/misc/Makefile
|
|
+++ b/drivers/misc/Makefile
|
|
@@ -21,3 +21,6 @@ obj-$(CONFIG_HP_ILO) += hpilo.o
|
|
obj-$(CONFIG_ISL29003) += isl29003.o
|
|
obj-$(CONFIG_C2PORT) += c2port/
|
|
obj-y += eeprom/
|
|
+obj-$(CONFIG_MACH_NEO1973) += gta02_pm_host.o \
|
|
+ gta02_pm_resume_reason.o
|
|
+
|