mirror of https://github.com/hak5/openwrt.git
17 lines
320 B
Diff
17 lines
320 B
Diff
--- a/scripts/get_arch.mk
|
|
+++ b/scripts/get_arch.mk
|
|
@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
|
|
$(Cannot determine ARCH)
|
|
endif
|
|
|
|
+# Allow ARCH to be x86
|
|
+ifneq (,$(CONFIG_X86))
|
|
+ifeq (x86,$(ARCH))
|
|
+ARCH-y = $(ARCH)
|
|
+endif
|
|
+endif
|
|
+
|
|
# Don't allow ARCH to be overridden by a different value.
|
|
ifeq (,$(ARCH))
|
|
ARCH = $(ARCH-y)
|