mirror of https://github.com/hak5/openwrt.git
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
diff -urN linux-2.6.24.7/drivers/leds/Kconfig linux-2.6.24.7.new/drivers/leds/Kconfig
|
|
--- linux-2.6.24.7/drivers/leds/Kconfig 2008-07-15 15:27:55.000000000 +0200
|
|
+++ linux-2.6.24.7.new/drivers/leds/Kconfig 2008-07-15 15:35:24.000000000 +0200
|
|
@@ -120,6 +120,12 @@
|
|
help
|
|
This option enables support for the CM-X270 LEDs.
|
|
|
|
+config LEDS_RB500
|
|
+ tristate "LED Support for RB5xx boards"
|
|
+ depends on LEDS_CLASS && MIKROTIK_RB500
|
|
+ help
|
|
+ This option enables support for the yellow user LED on RB5xx boards.
|
|
+
|
|
comment "LED Triggers"
|
|
|
|
config LEDS_TRIGGERS
|
|
diff -urN linux-2.6.24.7/drivers/leds/Makefile linux-2.6.24.7.new/drivers/leds/Makefile
|
|
--- linux-2.6.24.7/drivers/leds/Makefile 2008-07-15 15:27:55.000000000 +0200
|
|
+++ linux-2.6.24.7.new/drivers/leds/Makefile 2008-07-15 15:35:38.000000000 +0200
|
|
@@ -20,6 +20,7 @@
|
|
obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o
|
|
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
|
|
obj-$(CONFIG_LEDS_CM_X270) += leds-cm-x270.o
|
|
+obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
|