mirror of https://github.com/hak5/openwrt.git
15 lines
523 B
Diff
15 lines
523 B
Diff
Index: linux-2.6.21.7/Makefile
|
|
===================================================================
|
|
--- linux-2.6.21.7.orig/Makefile
|
|
+++ linux-2.6.21.7/Makefile
|
|
@@ -507,6 +507,9 @@ CFLAGS += $(call cc-option, -fn
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|