mirror of https://github.com/hak5/openwrt.git
25 lines
778 B
Diff
25 lines
778 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -283,6 +283,11 @@ config SPI_TLE62X0
|
|
sysfs interface, with each line presented as a kind of GPIO
|
|
exposing both switch control and diagnostic feedback.
|
|
|
|
+config SPI_VSC7385
|
|
+ tristate "Vitesse VSC7385 ethernet switch driver"
|
|
+ help
|
|
+ SPI driver for the Vitesse VSC7385 ethernet switch.
|
|
+
|
|
#
|
|
# Add new SPI protocol masters in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -38,6 +38,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
|
|
# SPI protocol drivers (device/link on bus)
|
|
obj-$(CONFIG_SPI_AT25) += at25.o
|
|
obj-$(CONFIG_SPI_SPIDEV) += spidev.o
|
|
+obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
|
|
obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
|
|
# ... add above this line ...
|
|
|