dropbear: update to 2014.65

Signed-off-by: Steven Barth <steven@midlink.org>

SVN-Revision: 42131
lede-17.01
Steven Barth 2014-08-11 13:02:43 +00:00
parent ecba34a3ee
commit ff6363dc19
5 changed files with 10 additions and 10 deletions

View File

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear PKG_NAME:=dropbear
PKG_VERSION:=2014.63 PKG_VERSION:=2014.65
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \ PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \ http://matt.ucc.asn.au/dropbear/releases/ \
https://dropbear.nl/mirror/releases/ https://dropbear.nl/mirror/releases/
PKG_MD5SUM:=7066bb9a2da708f3ed06314fdc9c47fd PKG_MD5SUM:=1918604238817385a156840fa2c39490
PKG_LICENSE:=MIT PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE

View File

@ -1,6 +1,6 @@
--- a/svr-chansession.c --- a/svr-chansession.c
+++ b/svr-chansession.c +++ b/svr-chansession.c
@@ -889,12 +889,12 @@ static void execchild(void *user_data) { @@ -902,12 +902,12 @@ static void execchild(void *user_data) {
/* We can only change uid/gid as root ... */ /* We can only change uid/gid as root ... */
if (getuid() == 0) { if (getuid() == 0) {

View File

@ -1,6 +1,6 @@
--- a/cli-runopts.c --- a/cli-runopts.c
+++ b/cli-runopts.c +++ b/cli-runopts.c
@@ -309,6 +309,10 @@ void cli_getopts(int argc, char ** argv) @@ -312,6 +312,10 @@ void cli_getopts(int argc, char ** argv)
debug_trace = 1; debug_trace = 1;
break; break;
#endif #endif
@ -11,10 +11,10 @@
case 'F': case 'F':
case 'e': case 'e':
#ifndef ENABLE_USER_ALGO_LIST #ifndef ENABLE_USER_ALGO_LIST
@@ -322,7 +326,6 @@ void cli_getopts(int argc, char ** argv) @@ -329,7 +333,6 @@ void cli_getopts(int argc, char ** argv)
#ifndef ENABLE_CLI_LOCALTCPFWD print_version();
case 'L': exit(EXIT_SUCCESS);
#endif break;
- case 'o': - case 'o':
case 'b': case 'b':
next = &dummy; next = &dummy;

View File

@ -1,6 +1,6 @@
--- a/dbutil.h --- a/dbutil.h
+++ b/dbutil.h +++ b/dbutil.h
@@ -92,7 +92,11 @@ int m_str_to_uint(const char* str, unsig @@ -101,7 +101,11 @@ int m_str_to_uint(const char* str, unsig
#define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL} #define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
/* Dropbear assertion */ /* Dropbear assertion */

View File

@ -1,6 +1,6 @@
--- a/options.h --- a/options.h
+++ b/options.h +++ b/options.h
@@ -318,7 +318,7 @@ be overridden at runtime with -I. 0 disa @@ -323,7 +323,7 @@ be overridden at runtime with -I. 0 disa
#define DEFAULT_IDLE_TIMEOUT 0 #define DEFAULT_IDLE_TIMEOUT 0
/* The default path. This will often get replaced by the shell */ /* The default path. This will often get replaced by the shell */