mirror of https://github.com/hak5/openwrt.git
package/busybox: add upstream udhcp hostname truncation fix, bump release number
SVN-Revision: 21510lede-17.01
parent
cc84e0672b
commit
f7d97234e2
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=busybox
|
PKG_NAME:=busybox
|
||||||
PKG_VERSION:=1.16.1
|
PKG_VERSION:=1.16.1
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
|
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/networking/udhcp/leases.c
|
||||||
|
+++ b/networking/udhcp/leases.c
|
||||||
|
@@ -64,6 +64,8 @@ struct dyn_lease* FAST_FUNC add_lease(
|
||||||
|
oldest->hostname[0] = '\0';
|
||||||
|
if (hostname) {
|
||||||
|
char *p;
|
||||||
|
+
|
||||||
|
+ hostname_len++; /* include NUL */
|
||||||
|
if (hostname_len > sizeof(oldest->hostname))
|
||||||
|
hostname_len = sizeof(oldest->hostname);
|
||||||
|
p = safe_strncpy(oldest->hostname, hostname, hostname_len);
|
Loading…
Reference in New Issue