mirror of https://github.com/hak5/openwrt.git
parent
9887dc6100
commit
f5ad888a7c
|
@ -24,8 +24,6 @@
|
||||||
#include <plat/regs-timer.h>
|
#include <plat/regs-timer.h>
|
||||||
#include <linux/gta02-vibrator.h>
|
#include <linux/gta02-vibrator.h>
|
||||||
|
|
||||||
#include <linux/gta02-shadow.h>
|
|
||||||
|
|
||||||
#define COUNTER 64
|
#define COUNTER 64
|
||||||
|
|
||||||
static struct gta02_vib_priv {
|
static struct gta02_vib_priv {
|
||||||
|
|
|
@ -36,8 +36,6 @@
|
||||||
#include <linux/spinlock.h>
|
#include <linux/spinlock.h>
|
||||||
#include <linux/mfd/core.h>
|
#include <linux/mfd/core.h>
|
||||||
#include <linux/mfd/glamo.h>
|
#include <linux/mfd/glamo.h>
|
||||||
#include <linux/spi/glamo.h>
|
|
||||||
#include <linux/glamo-gpio.h>
|
|
||||||
#include <linux/glamofb.h>
|
#include <linux/glamofb.h>
|
||||||
#include <linux/io.h>
|
#include <linux/io.h>
|
||||||
|
|
||||||
|
@ -129,6 +127,15 @@ static void reg_set_bit_mask(struct glamo_core *glamo,
|
||||||
spin_unlock(&glamo->lock);
|
spin_unlock(&glamo->lock);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
static int __reg_write_batch(struct glamo_core *glamo,
|
||||||
|
uint16_t start, size_t num, uint16_t *regs)
|
||||||
|
{
|
||||||
|
int end = start + num * 2
|
||||||
|
for(end = start + num * 2; start < end; start += 2, ++regs) {
|
||||||
|
*regs = __reg_read(glamo, start);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
static inline void __reg_set_bit(struct glamo_core *glamo,
|
static inline void __reg_set_bit(struct glamo_core *glamo,
|
||||||
u_int16_t reg, u_int16_t bit)
|
u_int16_t reg, u_int16_t bit)
|
||||||
{
|
{
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/leds/Kconfig
|
--- a/drivers/leds/Kconfig
|
||||||
+++ b/drivers/leds/Kconfig
|
+++ b/drivers/leds/Kconfig
|
||||||
@@ -227,6 +227,19 @@ config LEDS_BD2802
|
@@ -227,6 +227,12 @@ config LEDS_BD2802
|
||||||
This option enables support for BD2802GU RGB LED driver chips
|
This option enables support for BD2802GU RGB LED driver chips
|
||||||
accessed via the I2C bus.
|
accessed via the I2C bus.
|
||||||
|
|
||||||
|
@ -9,25 +9,17 @@
|
||||||
+ depends on LEDS_CLASS && MACH_NEO1973_GTA02
|
+ depends on LEDS_CLASS && MACH_NEO1973_GTA02
|
||||||
+ help
|
+ help
|
||||||
+ This option enables support for the vibrator on the Openmoko Freerunner.
|
+ This option enables support for the vibrator on the Openmoko Freerunner.
|
||||||
+
|
|
||||||
+config LEDS_GTA02
|
|
||||||
+ tristate "LED Support for the Openmoko Freerunner GSM phone"
|
|
||||||
+ depends on LEDS_CLASS && MACH_NEO1973_GTA02
|
|
||||||
+ help
|
|
||||||
+ This option enables support for the LEDs on the Openmoko Freerunner.
|
|
||||||
+
|
|
||||||
+
|
+
|
||||||
comment "LED Triggers"
|
comment "LED Triggers"
|
||||||
|
|
||||||
config LEDS_TRIGGERS
|
config LEDS_TRIGGERS
|
||||||
--- a/drivers/leds/Makefile
|
--- a/drivers/leds/Makefile
|
||||||
+++ b/drivers/leds/Makefile
|
+++ b/drivers/leds/Makefile
|
||||||
@@ -30,6 +30,8 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
@@ -30,6 +30,7 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
||||||
|
|
||||||
# LED SPI Drivers
|
# LED SPI Drivers
|
||||||
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
||||||
+obj-$(CONFIG_LEDS_GTA02_VIBRATOR) += leds-gta02-vibrator.o
|
+obj-$(CONFIG_LEDS_GTA02_VIBRATOR) += leds-gta02-vibrator.o
|
||||||
+obj-$(CONFIG_LEDS_GTA02) += leds-gta02.o
|
|
||||||
|
|
||||||
# LED Triggers
|
# LED Triggers
|
||||||
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
|
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
|
||||||
|
|
Loading…
Reference in New Issue