mirror of https://github.com/hak5/openwrt.git
kernel: bump 4.9 to 4.9.181
Refreshed all patches. Compile-tested on: ar7 Runtime-tested on: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>master
parent
04b45d3a31
commit
f2f7cc67e5
|
@ -6,11 +6,11 @@ ifdef CONFIG_TESTING_KERNEL
|
|||
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
|
||||
endif
|
||||
|
||||
LINUX_VERSION-4.9 = .180
|
||||
LINUX_VERSION-4.9 = .181
|
||||
LINUX_VERSION-4.14 = .123
|
||||
LINUX_VERSION-4.19 = .48
|
||||
|
||||
LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
|
||||
LINUX_KERNEL_HASH-4.9.181 = 8fcd223e11cba322801bc38cdb8b581d64c0115f585dcb6604de8561b574fced
|
||||
LINUX_KERNEL_HASH-4.14.123 = 25f58cb56bde388ac9bcee984f5f2d0ca094b0a8af6b92ad1f5b2fd0e6725b85
|
||||
LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
|
||||
|
||||
|
|
|
@ -399,7 +399,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
/* bnx2x_has_rx_work() reads the status block,
|
||||
--- a/drivers/net/ethernet/broadcom/bnxt/bnxt.c
|
||||
+++ b/drivers/net/ethernet/broadcom/bnxt/bnxt.c
|
||||
@@ -1797,7 +1797,7 @@ static int bnxt_poll_nitroa0(struct napi
|
||||
@@ -1799,7 +1799,7 @@ static int bnxt_poll_nitroa0(struct napi
|
||||
}
|
||||
|
||||
if (!bnxt_has_work(bp, cpr) && rx_pkts < budget) {
|
||||
|
@ -819,7 +819,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
|
||||
--- a/drivers/net/ethernet/marvell/mvpp2.c
|
||||
+++ b/drivers/net/ethernet/marvell/mvpp2.c
|
||||
@@ -5406,7 +5406,7 @@ static int mvpp2_poll(struct napi_struct
|
||||
@@ -5404,7 +5404,7 @@ static int mvpp2_poll(struct napi_struct
|
||||
|
||||
if (budget > 0) {
|
||||
cause_rx = 0;
|
||||
|
|
|
@ -22,7 +22,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -401,6 +401,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
|
||||
KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
|
||||
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||
GCC_PLUGINS_CFLAGS :=
|
||||
|
||||
+ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
|
||||
|
|
|
@ -18,7 +18,7 @@
|
|||
uart->capabilities = up->capabilities;
|
||||
--- a/drivers/tty/serial/serial_core.c
|
||||
+++ b/drivers/tty/serial/serial_core.c
|
||||
@@ -2260,6 +2260,7 @@ uart_report_port(struct uart_driver *drv
|
||||
@@ -2254,6 +2254,7 @@ uart_report_port(struct uart_driver *drv
|
||||
snprintf(address, sizeof(address),
|
||||
"I/O 0x%lx offset 0x%x", port->iobase, port->hub6);
|
||||
break;
|
||||
|
@ -26,7 +26,7 @@
|
|||
case UPIO_MEM:
|
||||
case UPIO_MEM16:
|
||||
case UPIO_MEM32:
|
||||
@@ -2924,6 +2925,7 @@ int uart_match_port(struct uart_port *po
|
||||
@@ -2926,6 +2927,7 @@ int uart_match_port(struct uart_port *po
|
||||
case UPIO_HUB6:
|
||||
return (port1->iobase == port2->iobase) &&
|
||||
(port1->hub6 == port2->hub6);
|
||||
|
|
Loading…
Reference in New Issue