mirror of https://github.com/hak5/openwrt.git
Add the 93cx6 patch to generic-2.6, correctly fix dependencies on the rt2x00 drivers (thanks to Daniel Gimpelevich)
SVN-Revision: 8200lede-17.01
parent
a9ffbd94e7
commit
f1b2dbceb2
|
@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/rt2x00/Default
|
define Package/rt2x00/Default
|
||||||
SUBMENU:=Wireless Drivers
|
SUBMENU:=Wireless Drivers
|
||||||
DEPENDS:=@LINUX_2_6 +kmod-mac80211 @LINUX_2_6_X86||@LINUX_2_6_RDC
|
DEPENDS:=+kmod-mac80211
|
||||||
TITLE:=Ralink GPL Drivers
|
TITLE:=Ralink GPL Drivers
|
||||||
DESCRIPTION:=Ralink GPL Drivers for rt2x00 cards
|
DESCRIPTION:=Ralink GPL Drivers for rt2x00 cards
|
||||||
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(LINUX_RELEASE)
|
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(LINUX_RELEASE)
|
||||||
|
@ -32,6 +32,7 @@ endef
|
||||||
|
|
||||||
define KernelPackage/rt2x00-pci
|
define KernelPackage/rt2x00-pci
|
||||||
$(call Package/rt2x00/Default)
|
$(call Package/rt2x00/Default)
|
||||||
|
DEPENDS+= @PCI_SUPPORT +kmod-rt2x00-lib
|
||||||
TITLE+= (PCI)
|
TITLE+= (PCI)
|
||||||
DESCRIPTION+= (PCI)
|
DESCRIPTION+= (PCI)
|
||||||
FILES:=$(PKG_BUILD_DIR)/rt2x00pci.$(LINUX_KMOD_SUFFIX)
|
FILES:=$(PKG_BUILD_DIR)/rt2x00pci.$(LINUX_KMOD_SUFFIX)
|
||||||
|
@ -40,15 +41,62 @@ endef
|
||||||
|
|
||||||
define KernelPackage/rt2x00-usb
|
define KernelPackage/rt2x00-usb
|
||||||
$(call Package/rt2x00/Default)
|
$(call Package/rt2x00/Default)
|
||||||
|
DEPENDS+= @USB_SUPPORT +kmod-rt2x00-lib
|
||||||
TITLE+= (USB)
|
TITLE+= (USB)
|
||||||
DESCRIPTION+= (USB)
|
DESCRIPTION+= (USB)
|
||||||
FILES:=$(PKG_BUILD_DIR)/rt2x00usb.$(LINUX_KMOD_SUFFIX)
|
FILES:=$(PKG_BUILD_DIR)/rt2x00usb.$(LINUX_KMOD_SUFFIX)
|
||||||
AUTOLOAD:=$(call AutoLoad,26,rt2x00usb)
|
AUTOLOAD:=$(call AutoLoad,26,rt2x00usb)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/rt2400-pci
|
||||||
|
$(call Package/rt2x00/Default)
|
||||||
|
DEPENDS+= +kmod-rt2x00-pci
|
||||||
|
TITLE+= (RT2400 PCI)
|
||||||
|
DESCRIPTION+= (RT2400 PCI)
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/rt2400pci.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,27,rt2400pci)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/rt2500-pci
|
||||||
|
$(call Package/rt2x00/Default)
|
||||||
|
DEPENDS+= +kmod-rt2x00-pci
|
||||||
|
TITLE+= (RT2500 PCI)
|
||||||
|
DESCRIPTION+= (RT2500 PCI)
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/rt2500pci.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,27,rt2500pci)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/rt2500-usb
|
||||||
|
$(call Package/rt2x00/Default)
|
||||||
|
DEPENDS+= +kmod-rt2x00-usb
|
||||||
|
TITLE+= (RT2500 USB)
|
||||||
|
DESCRIPTION+= (RT2500 USB)
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/rt2500usb.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,27,rt2500usb)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/rt61-pci
|
||||||
|
$(call Package/rt2x00/Default)
|
||||||
|
DEPENDS+= +kmod-rt2x00-pci
|
||||||
|
TITLE+= (RT2x61 PCI)
|
||||||
|
DESCRIPTION+= (RT2x61 PCI)
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/rt61pci.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,27,rt61pci)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/rt73-usb
|
||||||
|
$(call Package/rt2x00/Default)
|
||||||
|
DEPENDS+= +kmod-rt2x00-usb
|
||||||
|
TITLE+= (RT73 USB)
|
||||||
|
DESCRIPTION+= (RT73 USB)
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/rt73usb.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,27,rt73usb)
|
||||||
|
endef
|
||||||
|
|
||||||
define Build/Prepare
|
define Build/Prepare
|
||||||
$(call Build/Prepare/Default)
|
$(call Build/Prepare/Default)
|
||||||
$(CP) -r src/* $(PKG_BUILD_DIR)/
|
$(CP) -r src/* $(PKG_BUILD_DIR)/
|
||||||
|
sed 's/\$$$$(CONFIG_RT.*)/m\t\t/g' src/Makefile > $(PKG_BUILD_DIR)/Makefile
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
@ -65,3 +113,8 @@ endef
|
||||||
$(eval $(call KernelPackage,rt2x00-lib))
|
$(eval $(call KernelPackage,rt2x00-lib))
|
||||||
$(eval $(call KernelPackage,rt2x00-pci))
|
$(eval $(call KernelPackage,rt2x00-pci))
|
||||||
$(eval $(call KernelPackage,rt2x00-usb))
|
$(eval $(call KernelPackage,rt2x00-usb))
|
||||||
|
$(eval $(call KernelPackage,rt2400-pci))
|
||||||
|
$(eval $(call KernelPackage,rt2500-pci))
|
||||||
|
$(eval $(call KernelPackage,rt2500-usb))
|
||||||
|
$(eval $(call KernelPackage,rt61-pci))
|
||||||
|
$(eval $(call KernelPackage,rt73-usb))
|
||||||
|
|
|
@ -22,9 +22,9 @@ include $(INCLUDE_DIR)/package.mk
|
||||||
define KernelPackage/rt61
|
define KernelPackage/rt61
|
||||||
SUBMENU:=Wireless Drivers
|
SUBMENU:=Wireless Drivers
|
||||||
TITLE:=Driver for ralink MiMo pci chipsets
|
TITLE:=Driver for ralink MiMo pci chipsets
|
||||||
DEPENDS:=@LINUX_2_6_RDC +wireless-tools
|
DEPENDS:=@PCI_SUPPORT +wireless-tools
|
||||||
DESCRIPTION:=\
|
DESCRIPTION:=\
|
||||||
This package contains a driver for ralink rt61xx pci chipsets.
|
This package contains a driver for ralink rt2x61 pci chipsets.
|
||||||
URL:=http://rt2x00.serialmonkey.com/
|
URL:=http://rt2x00.serialmonkey.com/
|
||||||
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
|
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
|
||||||
FILES:= \
|
FILES:= \
|
||||||
|
@ -32,6 +32,11 @@ define KernelPackage/rt61
|
||||||
AUTOLOAD:=$(call AutoLoad,50,rt61)
|
AUTOLOAD:=$(call AutoLoad,50,rt61)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/rt61/install
|
||||||
|
mkdir $(1)/lib/firmware
|
||||||
|
$(CP) -L $(PKG_BUILD_DIR)/Module/rt2*.bin $(1)/lib/firmware
|
||||||
|
endef
|
||||||
|
|
||||||
LINUX_PATCHLEVEL:=$(shell echo "$(LINUX_VERSION)" | cut -d. -f2)
|
LINUX_PATCHLEVEL:=$(shell echo "$(LINUX_VERSION)" | cut -d. -f2)
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
|
|
@ -286,6 +286,7 @@ CONFIG_E100=m
|
||||||
# CONFIG_E1000 is not set
|
# CONFIG_E1000 is not set
|
||||||
# CONFIG_ECONET is not set
|
# CONFIG_ECONET is not set
|
||||||
# CONFIG_EEPRO100 is not set
|
# CONFIG_EEPRO100 is not set
|
||||||
|
CONFIG_EEPROM_93CX6=y
|
||||||
# CONFIG_EFI_PARTITION is not set
|
# CONFIG_EFI_PARTITION is not set
|
||||||
# CONFIG_EFS_FS is not set
|
# CONFIG_EFS_FS is not set
|
||||||
# CONFIG_ELF_CORE is not set
|
# CONFIG_ELF_CORE is not set
|
||||||
|
|
|
@ -0,0 +1,358 @@
|
||||||
|
From: Ivo van Doorn <ivdoorn@gmail.com>
|
||||||
|
Date: Fri, 11 May 2007 19:59:40 +0000 (-0400)
|
||||||
|
Subject: [PATCH] Add 93cx6 eeprom library
|
||||||
|
X-Git-Tag: v2.6.23-rc1~1201^2~74
|
||||||
|
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=9467d64b0e88763914c01f71ddf591b166c4f526
|
||||||
|
|
||||||
|
[PATCH] Add 93cx6 eeprom library
|
||||||
|
|
||||||
|
This patch adds a library for reading from 93cx6 eeproms.
|
||||||
|
|
||||||
|
Signed-off-by: Michael Wu <flamingice@sourmilk.net>
|
||||||
|
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
||||||
|
---
|
||||||
|
|
||||||
|
diff --git a/drivers/misc/Kconfig b/drivers/misc/Kconfig
|
||||||
|
index 616eee9..bd601ef 100644
|
||||||
|
--- a/drivers/misc/Kconfig
|
||||||
|
+++ b/drivers/misc/Kconfig
|
||||||
|
@@ -34,6 +34,11 @@ config PHANTOM
|
||||||
|
If you choose to build module, its name will be phantom. If unsure,
|
||||||
|
say N here.
|
||||||
|
|
||||||
|
+config EEPROM_93CX6
|
||||||
|
+ tristate "EEPROM 93CX6 support"
|
||||||
|
+ ---help---
|
||||||
|
+ This is a driver for the EEPROM chipsets 93c46 and 93c66.
|
||||||
|
+ The driver supports both read as well as write commands.
|
||||||
|
|
||||||
|
If unsure, say N.
|
||||||
|
|
||||||
|
@@ -187,5 +192,4 @@ config THINKPAD_ACPI_BAY
|
||||||
|
|
||||||
|
If you are not sure, say Y here.
|
||||||
|
|
||||||
|
-
|
||||||
|
endmenu
|
||||||
|
diff --git a/drivers/misc/Makefile b/drivers/misc/Makefile
|
||||||
|
index 8abbf2f..b5ce0e3 100644
|
||||||
|
--- a/drivers/misc/Makefile
|
||||||
|
+++ b/drivers/misc/Makefile
|
||||||
|
@@ -14,3 +14,4 @@ obj-$(CONFIG_PHANTOM) += phantom.o
|
||||||
|
obj-$(CONFIG_SGI_IOC4) += ioc4.o
|
||||||
|
obj-$(CONFIG_SONY_LAPTOP) += sony-laptop.o
|
||||||
|
obj-$(CONFIG_THINKPAD_ACPI) += thinkpad_acpi.o
|
||||||
|
+obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
|
||||||
|
diff --git a/drivers/misc/eeprom_93cx6.c b/drivers/misc/eeprom_93cx6.c
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..bfcb434
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/drivers/misc/eeprom_93cx6.c
|
||||||
|
@@ -0,0 +1,229 @@
|
||||||
|
+/*
|
||||||
|
+ Copyright (C) 2004 - 2006 rt2x00 SourceForge Project
|
||||||
|
+ <http://rt2x00.serialmonkey.com>
|
||||||
|
+
|
||||||
|
+ This program is free software; you can redistribute it and/or modify
|
||||||
|
+ it under the terms of the GNU General Public License as published by
|
||||||
|
+ the Free Software Foundation; either version 2 of the License, or
|
||||||
|
+ (at your option) any later version.
|
||||||
|
+
|
||||||
|
+ This program is distributed in the hope that it will be useful,
|
||||||
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+ GNU General Public License for more details.
|
||||||
|
+
|
||||||
|
+ You should have received a copy of the GNU General Public License
|
||||||
|
+ along with this program; if not, write to the
|
||||||
|
+ Free Software Foundation, Inc.,
|
||||||
|
+ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ Module: eeprom_93cx6
|
||||||
|
+ Abstract: EEPROM reader routines for 93cx6 chipsets.
|
||||||
|
+ Supported chipsets: 93c46 & 93c66.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#include <linux/kernel.h>
|
||||||
|
+#include <linux/module.h>
|
||||||
|
+#include <linux/version.h>
|
||||||
|
+#include <linux/delay.h>
|
||||||
|
+#include <linux/eeprom_93cx6.h>
|
||||||
|
+
|
||||||
|
+MODULE_AUTHOR("http://rt2x00.serialmonkey.com");
|
||||||
|
+MODULE_VERSION("1.0");
|
||||||
|
+MODULE_DESCRIPTION("EEPROM 93cx6 chip driver");
|
||||||
|
+MODULE_LICENSE("GPL");
|
||||||
|
+
|
||||||
|
+static inline void eeprom_93cx6_pulse_high(struct eeprom_93cx6 *eeprom)
|
||||||
|
+{
|
||||||
|
+ eeprom->reg_data_clock = 1;
|
||||||
|
+ eeprom->register_write(eeprom);
|
||||||
|
+ udelay(1);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static inline void eeprom_93cx6_pulse_low(struct eeprom_93cx6 *eeprom)
|
||||||
|
+{
|
||||||
|
+ eeprom->reg_data_clock = 0;
|
||||||
|
+ eeprom->register_write(eeprom);
|
||||||
|
+ udelay(1);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static void eeprom_93cx6_startup(struct eeprom_93cx6 *eeprom)
|
||||||
|
+{
|
||||||
|
+ /*
|
||||||
|
+ * Clear all flags, and enable chip select.
|
||||||
|
+ */
|
||||||
|
+ eeprom->register_read(eeprom);
|
||||||
|
+ eeprom->reg_data_in = 0;
|
||||||
|
+ eeprom->reg_data_out = 0;
|
||||||
|
+ eeprom->reg_data_clock = 0;
|
||||||
|
+ eeprom->reg_chip_select = 1;
|
||||||
|
+ eeprom->register_write(eeprom);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * kick a pulse.
|
||||||
|
+ */
|
||||||
|
+ eeprom_93cx6_pulse_high(eeprom);
|
||||||
|
+ eeprom_93cx6_pulse_low(eeprom);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static void eeprom_93cx6_cleanup(struct eeprom_93cx6 *eeprom)
|
||||||
|
+{
|
||||||
|
+ /*
|
||||||
|
+ * Clear chip_select and data_in flags.
|
||||||
|
+ */
|
||||||
|
+ eeprom->register_read(eeprom);
|
||||||
|
+ eeprom->reg_data_in = 0;
|
||||||
|
+ eeprom->reg_chip_select = 0;
|
||||||
|
+ eeprom->register_write(eeprom);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * kick a pulse.
|
||||||
|
+ */
|
||||||
|
+ eeprom_93cx6_pulse_high(eeprom);
|
||||||
|
+ eeprom_93cx6_pulse_low(eeprom);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static void eeprom_93cx6_write_bits(struct eeprom_93cx6 *eeprom,
|
||||||
|
+ const u16 data, const u16 count)
|
||||||
|
+{
|
||||||
|
+ unsigned int i;
|
||||||
|
+
|
||||||
|
+ eeprom->register_read(eeprom);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Clear data flags.
|
||||||
|
+ */
|
||||||
|
+ eeprom->reg_data_in = 0;
|
||||||
|
+ eeprom->reg_data_out = 0;
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Start writing all bits.
|
||||||
|
+ */
|
||||||
|
+ for (i = count; i > 0; i--) {
|
||||||
|
+ /*
|
||||||
|
+ * Check if this bit needs to be set.
|
||||||
|
+ */
|
||||||
|
+ eeprom->reg_data_in = !!(data & (1 << (i - 1)));
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Write the bit to the eeprom register.
|
||||||
|
+ */
|
||||||
|
+ eeprom->register_write(eeprom);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Kick a pulse.
|
||||||
|
+ */
|
||||||
|
+ eeprom_93cx6_pulse_high(eeprom);
|
||||||
|
+ eeprom_93cx6_pulse_low(eeprom);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ eeprom->reg_data_in = 0;
|
||||||
|
+ eeprom->register_write(eeprom);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static void eeprom_93cx6_read_bits(struct eeprom_93cx6 *eeprom,
|
||||||
|
+ u16 *data, const u16 count)
|
||||||
|
+{
|
||||||
|
+ unsigned int i;
|
||||||
|
+ u16 buf = 0;
|
||||||
|
+
|
||||||
|
+ eeprom->register_read(eeprom);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Clear data flags.
|
||||||
|
+ */
|
||||||
|
+ eeprom->reg_data_in = 0;
|
||||||
|
+ eeprom->reg_data_out = 0;
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Start reading all bits.
|
||||||
|
+ */
|
||||||
|
+ for (i = count; i > 0; i--) {
|
||||||
|
+ eeprom_93cx6_pulse_high(eeprom);
|
||||||
|
+
|
||||||
|
+ eeprom->register_read(eeprom);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Clear data_in flag.
|
||||||
|
+ */
|
||||||
|
+ eeprom->reg_data_in = 0;
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Read if the bit has been set.
|
||||||
|
+ */
|
||||||
|
+ if (eeprom->reg_data_out)
|
||||||
|
+ buf |= (1 << (i - 1));
|
||||||
|
+
|
||||||
|
+ eeprom_93cx6_pulse_low(eeprom);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ *data = buf;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+/**
|
||||||
|
+ * eeprom_93cx6_read - Read multiple words from eeprom
|
||||||
|
+ * @eeprom: Pointer to eeprom structure
|
||||||
|
+ * @word: Word index from where we should start reading
|
||||||
|
+ * @data: target pointer where the information will have to be stored
|
||||||
|
+ *
|
||||||
|
+ * This function will read the eeprom data as host-endian word
|
||||||
|
+ * into the given data pointer.
|
||||||
|
+ */
|
||||||
|
+void eeprom_93cx6_read(struct eeprom_93cx6 *eeprom, const u8 word,
|
||||||
|
+ u16 *data)
|
||||||
|
+{
|
||||||
|
+ u16 command;
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Initialize the eeprom register
|
||||||
|
+ */
|
||||||
|
+ eeprom_93cx6_startup(eeprom);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Select the read opcode and the word to be read.
|
||||||
|
+ */
|
||||||
|
+ command = (PCI_EEPROM_READ_OPCODE << eeprom->width) | word;
|
||||||
|
+ eeprom_93cx6_write_bits(eeprom, command,
|
||||||
|
+ PCI_EEPROM_WIDTH_OPCODE + eeprom->width);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Read the requested 16 bits.
|
||||||
|
+ */
|
||||||
|
+ eeprom_93cx6_read_bits(eeprom, data, 16);
|
||||||
|
+
|
||||||
|
+ /*
|
||||||
|
+ * Cleanup eeprom register.
|
||||||
|
+ */
|
||||||
|
+ eeprom_93cx6_cleanup(eeprom);
|
||||||
|
+}
|
||||||
|
+EXPORT_SYMBOL_GPL(eeprom_93cx6_read);
|
||||||
|
+
|
||||||
|
+/**
|
||||||
|
+ * eeprom_93cx6_multiread - Read multiple words from eeprom
|
||||||
|
+ * @eeprom: Pointer to eeprom structure
|
||||||
|
+ * @word: Word index from where we should start reading
|
||||||
|
+ * @data: target pointer where the information will have to be stored
|
||||||
|
+ * @words: Number of words that should be read.
|
||||||
|
+ *
|
||||||
|
+ * This function will read all requested words from the eeprom,
|
||||||
|
+ * this is done by calling eeprom_93cx6_read() multiple times.
|
||||||
|
+ * But with the additional change that while the eeprom_93cx6_read
|
||||||
|
+ * will return host ordered bytes, this method will return little
|
||||||
|
+ * endian words.
|
||||||
|
+ */
|
||||||
|
+void eeprom_93cx6_multiread(struct eeprom_93cx6 *eeprom, const u8 word,
|
||||||
|
+ __le16 *data, const u16 words)
|
||||||
|
+{
|
||||||
|
+ unsigned int i;
|
||||||
|
+ u16 tmp;
|
||||||
|
+
|
||||||
|
+ for (i = 0; i < words; i++) {
|
||||||
|
+ tmp = 0;
|
||||||
|
+ eeprom_93cx6_read(eeprom, word + i, &tmp);
|
||||||
|
+ data[i] = cpu_to_le16(tmp);
|
||||||
|
+ }
|
||||||
|
+}
|
||||||
|
+EXPORT_SYMBOL_GPL(eeprom_93cx6_multiread);
|
||||||
|
+
|
||||||
|
diff --git a/include/linux/eeprom_93cx6.h b/include/linux/eeprom_93cx6.h
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..d774b77
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/include/linux/eeprom_93cx6.h
|
||||||
|
@@ -0,0 +1,72 @@
|
||||||
|
+/*
|
||||||
|
+ Copyright (C) 2004 - 2006 rt2x00 SourceForge Project
|
||||||
|
+ <http://rt2x00.serialmonkey.com>
|
||||||
|
+
|
||||||
|
+ This program is free software; you can redistribute it and/or modify
|
||||||
|
+ it under the terms of the GNU General Public License as published by
|
||||||
|
+ the Free Software Foundation; either version 2 of the License, or
|
||||||
|
+ (at your option) any later version.
|
||||||
|
+
|
||||||
|
+ This program is distributed in the hope that it will be useful,
|
||||||
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+ GNU General Public License for more details.
|
||||||
|
+
|
||||||
|
+ You should have received a copy of the GNU General Public License
|
||||||
|
+ along with this program; if not, write to the
|
||||||
|
+ Free Software Foundation, Inc.,
|
||||||
|
+ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ Module: eeprom_93cx6
|
||||||
|
+ Abstract: EEPROM reader datastructures for 93cx6 chipsets.
|
||||||
|
+ Supported chipsets: 93c46 & 93c66.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * EEPROM operation defines.
|
||||||
|
+ */
|
||||||
|
+#define PCI_EEPROM_WIDTH_93C46 6
|
||||||
|
+#define PCI_EEPROM_WIDTH_93C66 8
|
||||||
|
+#define PCI_EEPROM_WIDTH_OPCODE 3
|
||||||
|
+#define PCI_EEPROM_WRITE_OPCODE 0x05
|
||||||
|
+#define PCI_EEPROM_READ_OPCODE 0x06
|
||||||
|
+#define PCI_EEPROM_EWDS_OPCODE 0x10
|
||||||
|
+#define PCI_EEPROM_EWEN_OPCODE 0x13
|
||||||
|
+
|
||||||
|
+/**
|
||||||
|
+ * struct eeprom_93cx6 - control structure for setting the commands
|
||||||
|
+ * for reading the eeprom data.
|
||||||
|
+ * @data: private pointer for the driver.
|
||||||
|
+ * @register_read(struct eeprom_93cx6 *eeprom): handler to
|
||||||
|
+ * read the eeprom register, this function should set all reg_* fields.
|
||||||
|
+ * @register_write(struct eeprom_93cx6 *eeprom): handler to
|
||||||
|
+ * write to the eeprom register by using all reg_* fields.
|
||||||
|
+ * @width: eeprom width, should be one of the PCI_EEPROM_WIDTH_* defines
|
||||||
|
+ * @reg_data_in: register field to indicate data input
|
||||||
|
+ * @reg_data_out: register field to indicate data output
|
||||||
|
+ * @reg_data_clock: register field to set the data clock
|
||||||
|
+ * @reg_chip_select: register field to set the chip select
|
||||||
|
+ *
|
||||||
|
+ * This structure is used for the communication between the driver
|
||||||
|
+ * and the eeprom_93cx6 handlers for reading the eeprom.
|
||||||
|
+ */
|
||||||
|
+struct eeprom_93cx6 {
|
||||||
|
+ void *data;
|
||||||
|
+
|
||||||
|
+ void (*register_read)(struct eeprom_93cx6 *eeprom);
|
||||||
|
+ void (*register_write)(struct eeprom_93cx6 *eeprom);
|
||||||
|
+
|
||||||
|
+ int width;
|
||||||
|
+
|
||||||
|
+ char reg_data_in;
|
||||||
|
+ char reg_data_out;
|
||||||
|
+ char reg_data_clock;
|
||||||
|
+ char reg_chip_select;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+extern void eeprom_93cx6_read(struct eeprom_93cx6 *eeprom,
|
||||||
|
+ const u8 word, u16 *data);
|
||||||
|
+extern void eeprom_93cx6_multiread(struct eeprom_93cx6 *eeprom,
|
||||||
|
+ const u8 word, __le16 *data, const u16 words);
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
ARCH:=i386
|
ARCH:=i386
|
||||||
BOARD:=rdc
|
BOARD:=rdc
|
||||||
BOARDNAME:=RDC x86
|
BOARDNAME:=RDC x86
|
||||||
FEATURES:=squashfs jffs2 pci broken
|
FEATURES:=squashfs jffs2 broken
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.22.1
|
LINUX_VERSION:=2.6.22.1
|
||||||
|
|
||||||
|
|
|
@ -228,7 +228,7 @@ CONFIG_PHYSICAL_START=0x100000
|
||||||
# CONFIG_PNPACPI is not set
|
# CONFIG_PNPACPI is not set
|
||||||
CONFIG_QUICKLIST=y
|
CONFIG_QUICKLIST=y
|
||||||
CONFIG_R6040=m
|
CONFIG_R6040=m
|
||||||
CONFIG_R6040_NAPI=y
|
# CONFIG_R6040_NAPI is not set
|
||||||
# CONFIG_RELOCATABLE is not set
|
# CONFIG_RELOCATABLE is not set
|
||||||
# CONFIG_RTC is not set
|
# CONFIG_RTC is not set
|
||||||
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
|
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
|
||||||
|
|
Loading…
Reference in New Issue