mirror of https://github.com/hak5/openwrt.git
opkg: work around a gcc warning bug related to array bounds checking
SVN-Revision: 14506lede-17.01
parent
152887e424
commit
f10075e5b6
|
@ -0,0 +1,10 @@
|
|||
--- a/libopkg/Makefile.am
|
||||
+++ b/libopkg/Makefile.am
|
||||
@@ -1,6 +1,6 @@
|
||||
|
||||
HOST_CPU=@host_cpu@
|
||||
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
|
||||
+AM_CFLAGS=-Wall -Werror -Wno-array-bounds -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
|
||||
|
||||
libopkg_includedir=$(includedir)/libopkg
|
||||
libopkg_include_HEADERS= opkg.h
|
Loading…
Reference in New Issue