mirror of https://github.com/hak5/openwrt.git
kernel: bump 4.14 to 4.14.130
Refreshed all patches. Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>openwrt-19.07
parent
dbe5730bf9
commit
eee336ee4a
|
@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
|
|||
endif
|
||||
|
||||
LINUX_VERSION-4.9 = .180
|
||||
LINUX_VERSION-4.14 = .129
|
||||
LINUX_VERSION-4.14 = .130
|
||||
LINUX_VERSION-4.19 = .48
|
||||
|
||||
LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
|
||||
LINUX_KERNEL_HASH-4.14.129 = 7548482b03aea1784e728e4d29fe75a2abc61c9dbf9851ec925a7fbecf9336e4
|
||||
LINUX_KERNEL_HASH-4.14.130 = 29ca9050ff9a60b7ab3b23d4b7da008df8b0f7329492a7bc84c1685481745259
|
||||
LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -653,12 +653,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
||||
@@ -654,12 +654,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
||||
KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
|
||||
|
||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||
|
|
|
@ -22,7 +22,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||
|
||||
mapped_addr = dma_map_single(eth->dev, skb->data,
|
||||
skb_headlen(skb), DMA_TO_DEVICE);
|
||||
@@ -1980,7 +1980,10 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
@@ -1981,7 +1981,10 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
mtk_w32(eth, val | MTK_CDMQ_STAG_EN, MTK_CDMQ_IG_CTRL);
|
||||
|
||||
/* Enable RX VLan Offloading */
|
||||
|
|
|
@ -17,7 +17,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||
|
||||
--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
@@ -1984,6 +1984,8 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
@@ -1985,6 +1985,8 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
*/
|
||||
val = mtk_r32(eth, MTK_CDMQ_IG_CTRL);
|
||||
mtk_w32(eth, val | MTK_CDMQ_STAG_EN, MTK_CDMQ_IG_CTRL);
|
||||
|
|
|
@ -11,7 +11,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||
|
||||
--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
@@ -1995,6 +1995,7 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
@@ -1996,6 +1996,7 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
|
||||
/* enable interrupt delay for RX */
|
||||
mtk_w32(eth, MTK_PDMA_DELAY_RX_DELAY, MTK_PDMA_DELAY_INT);
|
||||
|
|
|
@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||
|
||||
--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
@@ -2454,7 +2454,7 @@ static int mtk_add_mac(struct mtk_eth *e
|
||||
@@ -2455,7 +2455,7 @@ static int mtk_add_mac(struct mtk_eth *e
|
||||
mac->hw_stats->reg_offset = id * MTK_STAT_OFFSET;
|
||||
|
||||
SET_NETDEV_DEV(eth->netdev[id], eth->dev);
|
||||
|
|
|
@ -20,7 +20,7 @@
|
|||
continue;
|
||||
}
|
||||
break;
|
||||
@@ -1868,7 +1872,10 @@ static void mtk_stop_dma(struct mtk_eth
|
||||
@@ -1869,7 +1873,10 @@ static void mtk_stop_dma(struct mtk_eth
|
||||
for (i = 0; i < 10; i++) {
|
||||
val = mtk_r32(eth, glo_cfg);
|
||||
if (val & (MTK_TX_DMA_BUSY | MTK_RX_DMA_BUSY)) {
|
||||
|
@ -32,7 +32,7 @@
|
|||
continue;
|
||||
}
|
||||
break;
|
||||
@@ -1906,7 +1913,10 @@ static void ethsys_reset(struct mtk_eth
|
||||
@@ -1907,7 +1914,10 @@ static void ethsys_reset(struct mtk_eth
|
||||
reset_bits,
|
||||
reset_bits);
|
||||
|
||||
|
|
|
@ -18,7 +18,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
|
||||
--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
|
||||
@@ -1976,14 +1976,16 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
@@ -1977,14 +1977,16 @@ static int mtk_hw_init(struct mtk_eth *e
|
||||
}
|
||||
regmap_write(eth->ethsys, ETHSYS_SYSCFG0, val);
|
||||
|
||||
|
@ -41,7 +41,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
|
||||
/* Set linkdown as the default for each GMAC. Its own MCR would be set
|
||||
* up with the more appropriate value when mtk_phy_link_adjust call is
|
||||
@@ -2568,11 +2570,13 @@ static int mtk_probe(struct platform_dev
|
||||
@@ -2569,11 +2571,13 @@ static int mtk_probe(struct platform_dev
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -60,7 +60,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
}
|
||||
|
||||
for (i = 0; i < 3; i++) {
|
||||
@@ -2698,17 +2702,20 @@ static int mtk_remove(struct platform_de
|
||||
@@ -2699,17 +2703,20 @@ static int mtk_remove(struct platform_de
|
||||
|
||||
static const struct mtk_soc_data mt2701_data = {
|
||||
.caps = MTK_GMAC1_TRGMII,
|
||||
|
|
Loading…
Reference in New Issue