mirror of https://github.com/hak5/openwrt.git
parent
4f0b1a6602
commit
ed2c8bdc92
|
@ -1,23 +0,0 @@
|
||||||
From 2f22c9d80acceb853f94ca90989655d88e8bb964 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Imre Kaloz <kaloz@openwrt.org>
|
|
||||||
Date: Thu, 7 Jul 2011 11:39:37 +0200
|
|
||||||
Subject: [PATCH] ARM: make CNS3XXX select CPU_V6K
|
|
||||||
|
|
||||||
CNS3XXX is based on MPCore, so select the right CPU option for it.
|
|
||||||
|
|
||||||
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|
||||||
---
|
|
||||||
arch/arm/Kconfig | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
--- a/arch/arm/Kconfig
|
|
||||||
+++ b/arch/arm/Kconfig
|
|
||||||
@@ -322,7 +322,7 @@ config ARCH_CLPS711X
|
|
||||||
|
|
||||||
config ARCH_CNS3XXX
|
|
||||||
bool "Cavium Networks CNS3XXX family"
|
|
||||||
- select CPU_V6
|
|
||||||
+ select CPU_V6K
|
|
||||||
select GENERIC_CLOCKEVENTS
|
|
||||||
select ARM_GIC
|
|
||||||
select MIGHT_HAVE_PCI
|
|
|
@ -1,108 +0,0 @@
|
||||||
CNS3xxx SOCs have L310-compatible cache controller, so let's use it.
|
|
||||||
|
|
||||||
With this patch benchmarking with 'gzip' shows that performance is
|
|
||||||
doubled, and I'm still able to boot full-fledged userland over NFS
|
|
||||||
(using PCIe NIC), so the support should be pretty robust.
|
|
||||||
|
|
||||||
Signed-off-by: Anton Vorontsov <avorontsov@mvista.com>
|
|
||||||
---
|
|
||||||
|
|
||||||
arch/arm/mach-cns3xxx/cns3420vb.c | 2 +
|
|
||||||
arch/arm/mach-cns3xxx/core.c | 43 +++++++++++++++++++++++++++++++++++++
|
|
||||||
arch/arm/mach-cns3xxx/core.h | 6 +++++
|
|
||||||
arch/arm/mm/Kconfig | 2 +-
|
|
||||||
4 files changed, 52 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
--- a/arch/arm/mach-cns3xxx/cns3420vb.c
|
|
||||||
+++ b/arch/arm/mach-cns3xxx/cns3420vb.c
|
|
||||||
@@ -192,6 +192,8 @@ static struct platform_device *cns3420_p
|
|
||||||
|
|
||||||
static void __init cns3420_init(void)
|
|
||||||
{
|
|
||||||
+ cns3xxx_l2x0_init();
|
|
||||||
+
|
|
||||||
platform_add_devices(cns3420_pdevs, ARRAY_SIZE(cns3420_pdevs));
|
|
||||||
|
|
||||||
cns3xxx_ahci_init();
|
|
||||||
--- a/arch/arm/mach-cns3xxx/core.c
|
|
||||||
+++ b/arch/arm/mach-cns3xxx/core.c
|
|
||||||
@@ -16,6 +16,7 @@
|
|
||||||
#include <asm/mach/time.h>
|
|
||||||
#include <asm/mach/irq.h>
|
|
||||||
#include <asm/hardware/gic.h>
|
|
||||||
+#include <asm/hardware/cache-l2x0.h>
|
|
||||||
#include <mach/cns3xxx.h>
|
|
||||||
#include "core.h"
|
|
||||||
|
|
||||||
@@ -244,3 +245,45 @@ static void __init cns3xxx_timer_init(vo
|
|
||||||
struct sys_timer cns3xxx_timer = {
|
|
||||||
.init = cns3xxx_timer_init,
|
|
||||||
};
|
|
||||||
+
|
|
||||||
+#ifdef CONFIG_CACHE_L2X0
|
|
||||||
+
|
|
||||||
+void __init cns3xxx_l2x0_init(void)
|
|
||||||
+{
|
|
||||||
+ void __iomem *base = ioremap(CNS3XXX_L2C_BASE, SZ_4K);
|
|
||||||
+ u32 val;
|
|
||||||
+
|
|
||||||
+ if (WARN_ON(!base))
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
+ /*
|
|
||||||
+ * Tag RAM Control register
|
|
||||||
+ *
|
|
||||||
+ * bit[10:8] - 1 cycle of write accesses latency
|
|
||||||
+ * bit[6:4] - 1 cycle of read accesses latency
|
|
||||||
+ * bit[3:0] - 1 cycle of setup latency
|
|
||||||
+ *
|
|
||||||
+ * 1 cycle of latency for setup, read and write accesses
|
|
||||||
+ */
|
|
||||||
+ val = readl(base + L2X0_TAG_LATENCY_CTRL);
|
|
||||||
+ val &= 0xfffff888;
|
|
||||||
+ writel(val, base + L2X0_TAG_LATENCY_CTRL);
|
|
||||||
+
|
|
||||||
+ /*
|
|
||||||
+ * Data RAM Control register
|
|
||||||
+ *
|
|
||||||
+ * bit[10:8] - 1 cycles of write accesses latency
|
|
||||||
+ * bit[6:4] - 1 cycles of read accesses latency
|
|
||||||
+ * bit[3:0] - 1 cycle of setup latency
|
|
||||||
+ *
|
|
||||||
+ * 1 cycle of latency for setup, read and write accesses
|
|
||||||
+ */
|
|
||||||
+ val = readl(base + L2X0_DATA_LATENCY_CTRL);
|
|
||||||
+ val &= 0xfffff888;
|
|
||||||
+ writel(val, base + L2X0_DATA_LATENCY_CTRL);
|
|
||||||
+
|
|
||||||
+ /* 32 KiB, 8-way, parity disable */
|
|
||||||
+ l2x0_init(base, 0x00540000, 0xfe000fff);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+#endif /* CONFIG_CACHE_L2X0 */
|
|
||||||
--- a/arch/arm/mach-cns3xxx/core.h
|
|
||||||
+++ b/arch/arm/mach-cns3xxx/core.h
|
|
||||||
@@ -13,6 +13,12 @@
|
|
||||||
|
|
||||||
extern struct sys_timer cns3xxx_timer;
|
|
||||||
|
|
||||||
+#ifdef CONFIG_CACHE_L2X0
|
|
||||||
+void __init cns3xxx_l2x0_init(void);
|
|
||||||
+#else
|
|
||||||
+static inline void cns3xxx_l2x0_init(void) {}
|
|
||||||
+#endif /* CONFIG_CACHE_L2X0 */
|
|
||||||
+
|
|
||||||
void __init cns3xxx_map_io(void);
|
|
||||||
void __init cns3xxx_init_irq(void);
|
|
||||||
void cns3xxx_power_off(void);
|
|
||||||
--- a/arch/arm/mm/Kconfig
|
|
||||||
+++ b/arch/arm/mm/Kconfig
|
|
||||||
@@ -821,7 +821,7 @@ config CACHE_L2X0
|
|
||||||
depends on REALVIEW_EB_ARM11MP || MACH_REALVIEW_PB11MP || MACH_REALVIEW_PB1176 || \
|
|
||||||
REALVIEW_EB_A9MP || SOC_IMX35 || SOC_IMX31 || MACH_REALVIEW_PBX || \
|
|
||||||
ARCH_NOMADIK || ARCH_OMAP4 || ARCH_EXYNOS4 || ARCH_TEGRA || \
|
|
||||||
- ARCH_U8500 || ARCH_VEXPRESS_CA9X4 || ARCH_SHMOBILE
|
|
||||||
+ ARCH_U8500 || ARCH_VEXPRESS_CA9X4 || ARCH_SHMOBILE || ARCH_CNS3XXX
|
|
||||||
default y
|
|
||||||
select OUTER_CACHE
|
|
||||||
select OUTER_CACHE_SYNC
|
|
|
@ -0,0 +1,45 @@
|
||||||
|
From b1bd6bd7c230e00b40b0b859f3c23eb56ef39f0c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
Date: Fri, 2 Sep 2011 08:07:00 +0200
|
||||||
|
Subject: [PATCH] ARM: remove missing cns3xxx includes
|
||||||
|
|
||||||
|
Commit c9d95fbe59e426eed7f16e7cac812e46ac4772d0 deleted cns3xxx' hardware.h,
|
||||||
|
but didn't remove references for it, breaking the build.
|
||||||
|
|
||||||
|
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
---
|
||||||
|
arch/arm/mach-cns3xxx/include/mach/entry-macro.S | 1 -
|
||||||
|
arch/arm/mach-cns3xxx/include/mach/system.h | 1 -
|
||||||
|
arch/arm/mach-cns3xxx/include/mach/uncompress.h | 1 -
|
||||||
|
3 files changed, 0 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
--- a/arch/arm/mach-cns3xxx/include/mach/entry-macro.S
|
||||||
|
+++ b/arch/arm/mach-cns3xxx/include/mach/entry-macro.S
|
||||||
|
@@ -8,7 +8,6 @@
|
||||||
|
* published by the Free Software Foundation.
|
||||||
|
*/
|
||||||
|
|
||||||
|
-#include <mach/hardware.h>
|
||||||
|
#include <asm/hardware/entry-macro-gic.S>
|
||||||
|
|
||||||
|
.macro disable_fiq
|
||||||
|
--- a/arch/arm/mach-cns3xxx/include/mach/system.h
|
||||||
|
+++ b/arch/arm/mach-cns3xxx/include/mach/system.h
|
||||||
|
@@ -13,7 +13,6 @@
|
||||||
|
|
||||||
|
#include <linux/io.h>
|
||||||
|
#include <asm/proc-fns.h>
|
||||||
|
-#include <mach/hardware.h>
|
||||||
|
|
||||||
|
static inline void arch_idle(void)
|
||||||
|
{
|
||||||
|
--- a/arch/arm/mach-cns3xxx/include/mach/uncompress.h
|
||||||
|
+++ b/arch/arm/mach-cns3xxx/include/mach/uncompress.h
|
||||||
|
@@ -8,7 +8,6 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <asm/mach-types.h>
|
||||||
|
-#include <mach/hardware.h>
|
||||||
|
#include <mach/cns3xxx.h>
|
||||||
|
|
||||||
|
#define AMBA_UART_DR(base) (*(volatile unsigned char *)((base) + 0x00))
|
|
@ -13,7 +13,7 @@ arch/arm/Kconfig | 1 +
|
||||||
|
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -327,6 +327,7 @@ config ARCH_CNS3XXX
|
@@ -333,6 +333,7 @@ config ARCH_CNS3XXX
|
||||||
select ARM_GIC
|
select ARM_GIC
|
||||||
select MIGHT_HAVE_PCI
|
select MIGHT_HAVE_PCI
|
||||||
select PCI_DOMAINS if PCI
|
select PCI_DOMAINS if PCI
|
||||||
|
@ -34,7 +34,7 @@ arch/arm/Kconfig | 1 +
|
||||||
CONFIG_MMC=y
|
CONFIG_MMC=y
|
||||||
--- a/arch/arm/mach-cns3xxx/cns3420vb.c
|
--- a/arch/arm/mach-cns3xxx/cns3420vb.c
|
||||||
+++ b/arch/arm/mach-cns3xxx/cns3420vb.c
|
+++ b/arch/arm/mach-cns3xxx/cns3420vb.c
|
||||||
@@ -159,10 +159,32 @@ static struct platform_device cns3xxx_us
|
@@ -158,10 +158,32 @@ static struct platform_device cns3xxx_us
|
||||||
},
|
},
|
||||||
};
|
};
|
||||||
|
|
|
@ -231,6 +231,7 @@
|
||||||
+ *
|
+ *
|
||||||
+ * Copyright 2011 Gateworks Corporation
|
+ * Copyright 2011 Gateworks Corporation
|
||||||
+ * Chris Lang <clang@gateworks.com>
|
+ * Chris Lang <clang@gateworks.com>
|
||||||
|
+ *
|
||||||
+ * Cloned from linux/arch/arm/mach-vexpress/platsmp.c
|
+ * Cloned from linux/arch/arm/mach-vexpress/platsmp.c
|
||||||
+ *
|
+ *
|
||||||
+ * Copyright (C) 2002 ARM Ltd.
|
+ * Copyright (C) 2002 ARM Ltd.
|
||||||
|
@ -254,7 +255,6 @@
|
||||||
+#include <asm/smp_scu.h>
|
+#include <asm/smp_scu.h>
|
||||||
+#include <asm/unified.h>
|
+#include <asm/unified.h>
|
||||||
+
|
+
|
||||||
+#include <mach/hardware.h>
|
|
||||||
+#include <mach/cns3xxx.h>
|
+#include <mach/cns3xxx.h>
|
||||||
+
|
+
|
||||||
+extern void cns3xxx_secondary_startup(void);
|
+extern void cns3xxx_secondary_startup(void);
|
||||||
|
@ -404,7 +404,7 @@
|
||||||
+}
|
+}
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -1313,7 +1313,7 @@ config SMP
|
@@ -1350,7 +1350,7 @@ config SMP
|
||||||
depends on REALVIEW_EB_ARM11MP || REALVIEW_EB_A9MP || \
|
depends on REALVIEW_EB_ARM11MP || REALVIEW_EB_A9MP || \
|
||||||
MACH_REALVIEW_PB11MP || MACH_REALVIEW_PBX || ARCH_OMAP4 || \
|
MACH_REALVIEW_PB11MP || MACH_REALVIEW_PBX || ARCH_OMAP4 || \
|
||||||
ARCH_EXYNOS4 || ARCH_TEGRA || ARCH_U8500 || ARCH_VEXPRESS_CA9X4 || \
|
ARCH_EXYNOS4 || ARCH_TEGRA || ARCH_U8500 || ARCH_VEXPRESS_CA9X4 || \
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/net/Kconfig
|
--- a/drivers/net/Kconfig
|
||||||
+++ b/drivers/net/Kconfig
|
+++ b/drivers/net/Kconfig
|
||||||
@@ -2078,6 +2078,14 @@ config ACENIC_OMIT_TIGON_I
|
@@ -2071,6 +2071,14 @@ config ACENIC_OMIT_TIGON_I
|
||||||
|
|
||||||
The safe and default value for this is N.
|
The safe and default value for this is N.
|
||||||
|
|
||||||
|
@ -17,7 +17,7 @@
|
||||||
depends on PCI
|
depends on PCI
|
||||||
--- a/drivers/net/Makefile
|
--- a/drivers/net/Makefile
|
||||||
+++ b/drivers/net/Makefile
|
+++ b/drivers/net/Makefile
|
||||||
@@ -241,6 +241,7 @@ obj-$(CONFIG_MAC89x0) += mac89x0.o
|
@@ -240,6 +240,7 @@ obj-$(CONFIG_MAC89x0) += mac89x0.o
|
||||||
obj-$(CONFIG_TUN) += tun.o
|
obj-$(CONFIG_TUN) += tun.o
|
||||||
obj-$(CONFIG_VETH) += veth.o
|
obj-$(CONFIG_VETH) += veth.o
|
||||||
obj-$(CONFIG_NET_NETX) += netx-eth.o
|
obj-$(CONFIG_NET_NETX) += netx-eth.o
|
||||||
|
@ -44,12 +44,14 @@
|
||||||
+#include <linux/dma-mapping.h>
|
+#include <linux/dma-mapping.h>
|
||||||
+#include <linux/dmapool.h>
|
+#include <linux/dmapool.h>
|
||||||
+#include <linux/etherdevice.h>
|
+#include <linux/etherdevice.h>
|
||||||
|
+#include <linux/interrupt.h>
|
||||||
+#include <linux/io.h>
|
+#include <linux/io.h>
|
||||||
+#include <linux/kernel.h>
|
+#include <linux/kernel.h>
|
||||||
+#include <linux/phy.h>
|
+#include <linux/phy.h>
|
||||||
+#include <linux/platform_device.h>
|
+#include <linux/platform_device.h>
|
||||||
+#include <linux/skbuff.h>
|
+#include <linux/skbuff.h>
|
||||||
+#include <mach/hardware.h>
|
+#include <mach/irqs.h>
|
||||||
|
+#include <mach/platform.h>
|
||||||
+
|
+
|
||||||
+#define DRV_NAME "cns3xxx_eth"
|
+#define DRV_NAME "cns3xxx_eth"
|
||||||
+
|
+
|
||||||
|
@ -212,7 +214,6 @@
|
||||||
+ u8 alignment[16]; /* for 32 byte alignment */
|
+ u8 alignment[16]; /* for 32 byte alignment */
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
+
|
|
||||||
+struct switch_regs {
|
+struct switch_regs {
|
||||||
+ u32 phy_control;
|
+ u32 phy_control;
|
||||||
+ u32 phy_auto_addr;
|
+ u32 phy_auto_addr;
|
||||||
|
@ -439,7 +440,6 @@
|
||||||
+ return (IRQ_HANDLED);
|
+ return (IRQ_HANDLED);
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+
|
|
||||||
+static void cns3xxx_alloc_rx_buf(struct sw *sw, int received)
|
+static void cns3xxx_alloc_rx_buf(struct sw *sw, int received)
|
||||||
+{
|
+{
|
||||||
+ struct _rx_ring *rx_ring = sw->rx_ring;
|
+ struct _rx_ring *rx_ring = sw->rx_ring;
|
||||||
|
@ -1297,15 +1297,6 @@
|
||||||
+MODULE_DESCRIPTION("Cavium CNS3xxx Ethernet driver");
|
+MODULE_DESCRIPTION("Cavium CNS3xxx Ethernet driver");
|
||||||
+MODULE_LICENSE("GPL v2");
|
+MODULE_LICENSE("GPL v2");
|
||||||
+MODULE_ALIAS("platform:cns3xxx_eth");
|
+MODULE_ALIAS("platform:cns3xxx_eth");
|
||||||
--- a/arch/arm/mach-cns3xxx/include/mach/hardware.h
|
|
||||||
+++ b/arch/arm/mach-cns3xxx/include/mach/hardware.h
|
|
||||||
@@ -19,4 +19,6 @@
|
|
||||||
#define PCIBIOS_MIN_MEM 0x00000000
|
|
||||||
#define pcibios_assign_all_busses() 1
|
|
||||||
|
|
||||||
+#include "platform.h"
|
|
||||||
+
|
|
||||||
#endif
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/arm/mach-cns3xxx/include/mach/platform.h
|
+++ b/arch/arm/mach-cns3xxx/include/mach/platform.h
|
||||||
@@ -0,0 +1,26 @@
|
@@ -0,0 +1,26 @@
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/spi/Kconfig
|
--- a/drivers/spi/Kconfig
|
||||||
+++ b/drivers/spi/Kconfig
|
+++ b/drivers/spi/Kconfig
|
||||||
@@ -123,6 +123,13 @@ config SPI_BUTTERFLY
|
@@ -117,6 +117,13 @@ config SPI_BUTTERFLY
|
||||||
inexpensive battery powered microcontroller evaluation board.
|
inexpensive battery powered microcontroller evaluation board.
|
||||||
This same cable can be used to flash new firmware.
|
This same cable can be used to flash new firmware.
|
||||||
|
|
||||||
|
@ -16,14 +16,14 @@
|
||||||
depends on (M520x || M523x || M5249 || M527x || M528x || M532x)
|
depends on (M520x || M523x || M5249 || M527x || M528x || M532x)
|
||||||
--- a/drivers/spi/Makefile
|
--- a/drivers/spi/Makefile
|
||||||
+++ b/drivers/spi/Makefile
|
+++ b/drivers/spi/Makefile
|
||||||
@@ -56,6 +56,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_SPI_BFIN) += spi-bfin5xx.
|
||||||
obj-$(CONFIG_SPI_SH_MSIOF) += spi_sh_msiof.o
|
obj-$(CONFIG_SPI_BFIN_SPORT) += spi-bfin-sport.o
|
||||||
obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
|
obj-$(CONFIG_SPI_BITBANG) += spi-bitbang.o
|
||||||
obj-$(CONFIG_SPI_NUC900) += spi_nuc900.o
|
obj-$(CONFIG_SPI_BUTTERFLY) += spi-butterfly.o
|
||||||
+obj-$(CONFIG_SPI_CNS3XXX) += spi_cns3xxx.o
|
+obj-$(CONFIG_SPI_CNS3XXX) += spi_cns3xxx.o
|
||||||
|
obj-$(CONFIG_SPI_COLDFIRE_QSPI) += spi-coldfire-qspi.o
|
||||||
# special build for s3c24xx spi driver with fiq support
|
obj-$(CONFIG_SPI_DAVINCI) += spi-davinci.o
|
||||||
spi_s3c24xx_hw-y := spi_s3c24xx.o
|
obj-$(CONFIG_SPI_DESIGNWARE) += spi-dw.o
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/spi/spi_cns3xxx.c
|
+++ b/drivers/spi/spi_cns3xxx.c
|
||||||
@@ -0,0 +1,449 @@
|
@@ -0,0 +1,449 @@
|
||||||
|
@ -492,8 +492,8 @@
|
||||||
};
|
};
|
||||||
|
|
||||||
/**
|
/**
|
||||||
--- a/drivers/spi/spi_bitbang.c
|
--- a/drivers/spi/spi-bitbang.c
|
||||||
+++ b/drivers/spi/spi_bitbang.c
|
+++ b/drivers/spi/spi-bitbang.c
|
||||||
@@ -329,6 +329,12 @@ static void bitbang_work(struct work_str
|
@@ -329,6 +329,12 @@ static void bitbang_work(struct work_str
|
||||||
*/
|
*/
|
||||||
if (!m->is_dma_mapped)
|
if (!m->is_dma_mapped)
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/arch/arm/mach-cns3xxx/pcie.c
|
--- a/arch/arm/mach-cns3xxx/pcie.c
|
||||||
+++ b/arch/arm/mach-cns3xxx/pcie.c
|
+++ b/arch/arm/mach-cns3xxx/pcie.c
|
||||||
@@ -375,8 +375,6 @@ static int __init cns3xxx_pcie_init(void
|
@@ -378,8 +378,6 @@ static int __init cns3xxx_pcie_init(void
|
||||||
for (i = 0; i < ARRAY_SIZE(cns3xxx_pcie); i++) {
|
for (i = 0; i < ARRAY_SIZE(cns3xxx_pcie); i++) {
|
||||||
iotable_init(cns3xxx_pcie[i].cfg_bases,
|
iotable_init(cns3xxx_pcie[i].cfg_bases,
|
||||||
ARRAY_SIZE(cns3xxx_pcie[i].cfg_bases));
|
ARRAY_SIZE(cns3xxx_pcie[i].cfg_bases));
|
|
@ -41,9 +41,9 @@
|
||||||
+#include <asm/mach/arch.h>
|
+#include <asm/mach/arch.h>
|
||||||
+#include <asm/mach/map.h>
|
+#include <asm/mach/map.h>
|
||||||
+#include <asm/mach/time.h>
|
+#include <asm/mach/time.h>
|
||||||
+#include <mach/hardware.h>
|
|
||||||
+#include <mach/cns3xxx.h>
|
+#include <mach/cns3xxx.h>
|
||||||
+#include <mach/irqs.h>
|
+#include <mach/irqs.h>
|
||||||
|
+#include <mach/platform.h>
|
||||||
+#include <mach/pm.h>
|
+#include <mach/pm.h>
|
||||||
+#include "core.h"
|
+#include "core.h"
|
||||||
+#include "devices.h"
|
+#include "devices.h"
|
||||||
|
@ -816,7 +816,7 @@
|
||||||
|
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -323,6 +323,7 @@ config ARCH_CLPS711X
|
@@ -329,6 +329,7 @@ config ARCH_CLPS711X
|
||||||
config ARCH_CNS3XXX
|
config ARCH_CNS3XXX
|
||||||
bool "Cavium Networks CNS3XXX family"
|
bool "Cavium Networks CNS3XXX family"
|
||||||
select CPU_V6K
|
select CPU_V6K
|
||||||
|
@ -859,7 +859,7 @@
|
||||||
+
|
+
|
||||||
+#include <linux/kernel.h>
|
+#include <linux/kernel.h>
|
||||||
+#include <linux/io.h>
|
+#include <linux/io.h>
|
||||||
+#include <mach/hardware.h>
|
+#include <mach/platform.h>
|
||||||
+#include <asm-generic/gpio.h> /* cansleep wrappers */
|
+#include <asm-generic/gpio.h> /* cansleep wrappers */
|
||||||
+
|
+
|
||||||
+#define NR_BUILTIN_GPIO 64
|
+#define NR_BUILTIN_GPIO 64
|
||||||
|
@ -946,7 +946,7 @@
|
||||||
{
|
{
|
||||||
int i;
|
int i;
|
||||||
|
|
||||||
@@ -373,6 +373,9 @@ static int __init cns3xxx_pcie_init(void
|
@@ -376,6 +376,9 @@ static int __init cns3xxx_pcie_init(void
|
||||||
"imprecise external abort");
|
"imprecise external abort");
|
||||||
|
|
||||||
for (i = 0; i < ARRAY_SIZE(cns3xxx_pcie); i++) {
|
for (i = 0; i < ARRAY_SIZE(cns3xxx_pcie); i++) {
|
||||||
|
@ -956,14 +956,22 @@
|
||||||
iotable_init(cns3xxx_pcie[i].cfg_bases,
|
iotable_init(cns3xxx_pcie[i].cfg_bases,
|
||||||
ARRAY_SIZE(cns3xxx_pcie[i].cfg_bases));
|
ARRAY_SIZE(cns3xxx_pcie[i].cfg_bases));
|
||||||
cns3xxx_pcie_check_link(&cns3xxx_pcie[i]);
|
cns3xxx_pcie_check_link(&cns3xxx_pcie[i]);
|
||||||
@@ -384,4 +387,3 @@ static int __init cns3xxx_pcie_init(void
|
@@ -387,4 +390,3 @@ static int __init cns3xxx_pcie_init(void
|
||||||
|
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
-device_initcall(cns3xxx_pcie_init);
|
-device_initcall(cns3xxx_pcie_init);
|
||||||
--- a/arch/arm/mach-cns3xxx/cns3420vb.c
|
--- a/arch/arm/mach-cns3xxx/cns3420vb.c
|
||||||
+++ b/arch/arm/mach-cns3xxx/cns3420vb.c
|
+++ b/arch/arm/mach-cns3xxx/cns3420vb.c
|
||||||
@@ -199,6 +199,8 @@ static void __init cns3420_init(void)
|
@@ -31,6 +31,7 @@
|
||||||
|
#include <asm/mach/time.h>
|
||||||
|
#include <mach/cns3xxx.h>
|
||||||
|
#include <mach/irqs.h>
|
||||||
|
+#include <mach/platform.h>
|
||||||
|
#include "core.h"
|
||||||
|
#include "devices.h"
|
||||||
|
|
||||||
|
@@ -198,6 +199,8 @@ static void __init cns3420_init(void)
|
||||||
cns3xxx_ahci_init();
|
cns3xxx_ahci_init();
|
||||||
cns3xxx_sdhci_init();
|
cns3xxx_sdhci_init();
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/mmc/host/sdhci-cns3xxx.c
|
--- a/drivers/mmc/host/sdhci-cns3xxx.c
|
||||||
+++ b/drivers/mmc/host/sdhci-cns3xxx.c
|
+++ b/drivers/mmc/host/sdhci-cns3xxx.c
|
||||||
@@ -90,8 +90,9 @@ struct sdhci_pltfm_data sdhci_cns3xxx_pd
|
@@ -88,10 +88,11 @@ static struct sdhci_pltfm_data sdhci_cns
|
||||||
.ops = &sdhci_cns3xxx_ops,
|
.ops = &sdhci_cns3xxx_ops,
|
||||||
.quirks = SDHCI_QUIRK_BROKEN_DMA |
|
.quirks = SDHCI_QUIRK_BROKEN_DMA |
|
||||||
SDHCI_QUIRK_DATA_TIMEOUT_USES_SDCLK |
|
SDHCI_QUIRK_DATA_TIMEOUT_USES_SDCLK |
|
||||||
|
@ -12,3 +12,5 @@
|
||||||
+ SDHCI_QUIRK_NONSTANDARD_CLOCK |
|
+ SDHCI_QUIRK_NONSTANDARD_CLOCK |
|
||||||
+ SDHCI_QUIRK_BROKEN_CARD_DETECTION,
|
+ SDHCI_QUIRK_BROKEN_CARD_DETECTION,
|
||||||
};
|
};
|
||||||
|
|
||||||
|
static int __devinit sdhci_cns3xxx_probe(struct platform_device *pdev)
|
|
@ -18,14 +18,14 @@
|
||||||
depends on GENERIC_GPIO
|
depends on GENERIC_GPIO
|
||||||
--- a/drivers/hwmon/Makefile
|
--- a/drivers/hwmon/Makefile
|
||||||
+++ b/drivers/hwmon/Makefile
|
+++ b/drivers/hwmon/Makefile
|
||||||
@@ -118,6 +118,7 @@ obj-$(CONFIG_SENSORS_W83L785TS) += w83l7
|
@@ -123,6 +123,7 @@ obj-$(CONFIG_SENSORS_W83L785TS) += w83l7
|
||||||
obj-$(CONFIG_SENSORS_W83L786NG) += w83l786ng.o
|
obj-$(CONFIG_SENSORS_W83L786NG) += w83l786ng.o
|
||||||
obj-$(CONFIG_SENSORS_WM831X) += wm831x-hwmon.o
|
obj-$(CONFIG_SENSORS_WM831X) += wm831x-hwmon.o
|
||||||
obj-$(CONFIG_SENSORS_WM8350) += wm8350-hwmon.o
|
obj-$(CONFIG_SENSORS_WM8350) += wm8350-hwmon.o
|
||||||
+obj-$(CONFIG_SENSORS_GSP) += gsp.o
|
+obj-$(CONFIG_SENSORS_GSP) += gsp.o
|
||||||
|
|
||||||
# PMBus drivers
|
obj-$(CONFIG_PMBUS) += pmbus/
|
||||||
obj-$(CONFIG_PMBUS) += pmbus_core.o
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/hwmon/gsp.c
|
+++ b/drivers/hwmon/gsp.c
|
||||||
@@ -0,0 +1,308 @@
|
@@ -0,0 +1,308 @@
|
|
@ -22658,7 +22658,7 @@
|
||||||
u32 transfer_buffer_length; /* (in) data buffer length */
|
u32 transfer_buffer_length; /* (in) data buffer length */
|
||||||
--- a/drivers/usb/gadget/Kconfig
|
--- a/drivers/usb/gadget/Kconfig
|
||||||
+++ b/drivers/usb/gadget/Kconfig
|
+++ b/drivers/usb/gadget/Kconfig
|
||||||
@@ -111,7 +111,7 @@ config USB_GADGET_SELECTED
|
@@ -108,7 +108,7 @@ config USB_GADGET_VBUS_DRAW
|
||||||
#
|
#
|
||||||
choice
|
choice
|
||||||
prompt "USB Peripheral Controller"
|
prompt "USB Peripheral Controller"
|
||||||
|
@ -22667,3 +22667,14 @@
|
||||||
help
|
help
|
||||||
A USB device uses a controller to talk to its host.
|
A USB device uses a controller to talk to its host.
|
||||||
Systems should have only one such upstream link.
|
Systems should have only one such upstream link.
|
||||||
|
--- a/drivers/usb/gadget/Makefile
|
||||||
|
+++ b/drivers/usb/gadget/Makefile
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
#
|
||||||
|
ccflags-$(CONFIG_USB_GADGET_DEBUG) := -DDEBUG
|
||||||
|
|
||||||
|
-obj-$(CONFIG_USB_GADGET) += udc-core.o
|
||||||
|
+#obj-$(CONFIG_USB_GADGET) += udc-core.o
|
||||||
|
obj-$(CONFIG_USB_DUMMY_HCD) += dummy_hcd.o
|
||||||
|
obj-$(CONFIG_USB_NET2272) += net2272.o
|
||||||
|
obj-$(CONFIG_USB_NET2280) += net2280.o
|
Loading…
Reference in New Issue