mirror of https://github.com/hak5/openwrt.git
nat46: fix translation of ICMP protocol unreachable
Refresh patch 1182f30 nat46-core: Fix translation of ICMP protocol unreachable Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>master
parent
3caad5150c
commit
ebddd0b327
|
@ -3,11 +3,11 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=nat46
|
||||
|
||||
PKG_MIRROR_HASH:=3f5ef0a56e9b02c3ec10ec95f3f81c0ed04b983b2d857c16304c379106d6beb6
|
||||
PKG_MIRROR_HASH:=0627c7122ff7432aadb443e92e11a9ad7710add0ff512eebe17d7e3c041e0d2a
|
||||
PKG_SOURCE_URL:=https://github.com/ayourtch/nat46.git
|
||||
PKG_SOURCE_DATE:=2017-05-12
|
||||
PKG_SOURCE_DATE:=2020-06-26
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=683fbd2b765506332a1af141545652bf58f03166
|
||||
PKG_SOURCE_VERSION:=1182f30785e4274913f01a8c3d7e1b5437ae3819
|
||||
|
||||
PKG_MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
#include "nat46-glue.h"
|
||||
#include "nat46-core.h"
|
||||
@@ -1598,7 +1599,11 @@ void nat46_ipv6_input(struct sk_buff *ol
|
||||
@@ -1601,7 +1602,11 @@ void nat46_ipv6_input(struct sk_buff *ol
|
||||
/* Remove any debris in the socket control block */
|
||||
memset(IPCB(new_skb), 0, sizeof(struct inet_skb_parm));
|
||||
/* Remove netfilter references to IPv6 packet, new netfilter references will be created based on IPv4 packet */
|
||||
|
@ -20,7 +20,7 @@
|
|||
|
||||
/* modify packet: actual IPv6->IPv4 transformation */
|
||||
truncSize = v6packet_l3size - sizeof(struct iphdr); /* chop first 20 bytes */
|
||||
@@ -1803,7 +1808,11 @@ void nat46_ipv4_input(struct sk_buff *ol
|
||||
@@ -1806,7 +1811,11 @@ void nat46_ipv4_input(struct sk_buff *ol
|
||||
/* Remove any debris in the socket control block */
|
||||
memset(IPCB(new_skb), 0, sizeof(struct inet_skb_parm));
|
||||
/* Remove netfilter references to IPv4 packet, new netfilter references will be created based on IPv6 packet */
|
||||
|
|
Loading…
Reference in New Issue