mirror of https://github.com/hak5/openwrt.git
opkg: apparently array bounds checking is gcc 4.3 specific, move -Wno-array-bounds into TARGET_CFLAGS instead of a patch and make it conditional
SVN-Revision: 14508lede-17.01
parent
18441c327a
commit
df0643a408
|
@ -40,7 +40,7 @@ define Package/opkg/conffiles
|
||||||
/etc/opkg.conf
|
/etc/opkg.conf
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3),-Wno-array-bounds)
|
||||||
EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
|
EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
|
||||||
EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
|
EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
|
||||||
|
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- a/libopkg/Makefile.am
|
|
||||||
+++ b/libopkg/Makefile.am
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
|
|
||||||
HOST_CPU=@host_cpu@
|
|
||||||
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
|
|
||||||
+AM_CFLAGS=-Wall -Werror -Wno-array-bounds -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
|
|
||||||
|
|
||||||
libopkg_includedir=$(includedir)/libopkg
|
|
||||||
libopkg_include_HEADERS= opkg.h
|
|
Loading…
Reference in New Issue