mirror of https://github.com/hak5/openwrt.git
curl: Update to 7.64.1
Update curl to 7.64.1 Remove deprecated patch Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>openwrt-19.07
parent
f483274422
commit
de3eb0d8a0
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=curl
|
||||
PKG_VERSION:=7.64.0
|
||||
PKG_VERSION:=7.64.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
|
@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
|||
https://curl.mirror.anstey.ca/ \
|
||||
https://curl.askapache.com/download/ \
|
||||
https://curl.haxx.se/download/
|
||||
PKG_HASH:=2f2f13fa34d44aa29cb444077ad7dc4dc6d189584ad552e0aaeb06e608af6001
|
||||
PKG_HASH:=9252332a7f871ce37bfa7f78bdd0a0e3924d8187cc27cb57c76c9474a7168fb3
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/lib/vtls/mbedtls.c
|
||||
+++ b/lib/vtls/mbedtls.c
|
||||
@@ -813,7 +813,7 @@ static void Curl_mbedtls_session_free(vo
|
||||
|
||||
static size_t Curl_mbedtls_version(char *buffer, size_t size)
|
||||
{
|
||||
- unsigned int version = mbedtls_version_get_number();
|
||||
+ unsigned int version = MBEDTLS_VERSION_NUMBER;
|
||||
return msnprintf(buffer, size, "mbedTLS/%u.%u.%u", version>>24,
|
||||
(version>>16)&0xff, (version>>8)&0xff);
|
||||
}
|
Loading…
Reference in New Issue