mirror of https://github.com/hak5/openwrt.git
uboot-kirkwood: update to 2019.01
Update U-Boot to current 2019.01 release for kirkwood platform Signed-off-by: Paul Wassi <p.wassi@gmx.at>openwrt-19.07
parent
d42c9ce326
commit
dc08514e6d
|
@ -7,10 +7,10 @@
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_VERSION:=2018.03
|
PKG_VERSION:=2019.01
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
|
PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/u-boot.mk
|
include $(INCLUDE_DIR)/u-boot.mk
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
|
@ -35,14 +35,14 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
|
||||||
config TARGET_NSA310S
|
config TARGET_NSA310S
|
||||||
bool "Zyxel NSA310S"
|
bool "Zyxel NSA310S"
|
||||||
|
|
||||||
@@ -80,6 +83,7 @@ source "board/raidsonic/ib62x0/Kconfig"
|
@@ -86,6 +89,7 @@ source "board/raidsonic/ib62x0/Kconfig"
|
||||||
source "board/Seagate/dockstar/Kconfig"
|
source "board/Seagate/dockstar/Kconfig"
|
||||||
source "board/Seagate/goflexhome/Kconfig"
|
source "board/Seagate/goflexhome/Kconfig"
|
||||||
source "board/Seagate/nas220/Kconfig"
|
source "board/Seagate/nas220/Kconfig"
|
||||||
+source "board/zyxel/nsa310/Kconfig"
|
+source "board/zyxel/nsa310/Kconfig"
|
||||||
source "board/zyxel/nsa310s/Kconfig"
|
source "board/zyxel/nsa310s/Kconfig"
|
||||||
|
source "board/alliedtelesis/SBx81LIFKW/Kconfig"
|
||||||
endif
|
source "board/alliedtelesis/SBx81LIFXCAT/Kconfig"
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/board/zyxel/nsa310/Kconfig
|
+++ b/board/zyxel/nsa310/Kconfig
|
||||||
@@ -0,0 +1,12 @@
|
@@ -0,0 +1,12 @@
|
||||||
|
@ -505,16 +505,19 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
|
||||||
+#endif /* __NSA310_H */
|
+#endif /* __NSA310_H */
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/configs/nsa310_defconfig
|
+++ b/configs/nsa310_defconfig
|
||||||
@@ -0,0 +1,37 @@
|
@@ -0,0 +1,40 @@
|
||||||
+CONFIG_ARM=y
|
+CONFIG_ARM=y
|
||||||
+CONFIG_KIRKWOOD=y
|
+CONFIG_KIRKWOOD=y
|
||||||
+CONFIG_SYS_TEXT_BASE=0x600000
|
+CONFIG_SYS_TEXT_BASE=0x600000
|
||||||
+CONFIG_TARGET_NSA310=y
|
+CONFIG_TARGET_NSA310=y
|
||||||
+CONFIG_IDENT_STRING="\nZyXEL NSA310 1-Bay Power Media Server"
|
+CONFIG_IDENT_STRING="\nZyXEL NSA310 1-Bay Power Media Server"
|
||||||
|
+CONFIG_NR_DRAM_BANKS=2
|
||||||
+CONFIG_BOOTDELAY=3
|
+CONFIG_BOOTDELAY=3
|
||||||
+CONFIG_SYS_PROMPT="NSA310> "
|
+CONFIG_SYS_PROMPT="NSA310> "
|
||||||
+# CONFIG_CMD_IMLS is not set
|
+# CONFIG_CMD_IMLS is not set
|
||||||
+# CONFIG_CMD_FLASH is not set
|
+# CONFIG_CMD_FLASH is not set
|
||||||
|
+CONFIG_MVGBE=y
|
||||||
|
+CONFIG_MII=y
|
||||||
+CONFIG_SYS_NS16550=y
|
+CONFIG_SYS_NS16550=y
|
||||||
+CONFIG_CMD_FDT=y
|
+CONFIG_CMD_FDT=y
|
||||||
+CONFIG_OF_LIBFDT=y
|
+CONFIG_OF_LIBFDT=y
|
||||||
|
@ -545,7 +548,7 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
|
||||||
+CONFIG_SYS_LONGHELP=y
|
+CONFIG_SYS_LONGHELP=y
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/include/configs/nsa310.h
|
+++ b/include/configs/nsa310.h
|
||||||
@@ -0,0 +1,119 @@
|
@@ -0,0 +1,117 @@
|
||||||
+/* Copyright (C) 2015-2016 bodhi <mibodhi@gmail.com>
|
+/* Copyright (C) 2015-2016 bodhi <mibodhi@gmail.com>
|
||||||
+ *
|
+ *
|
||||||
+ * Based on
|
+ * Based on
|
||||||
|
@ -654,8 +657,6 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
|
||||||
+ */
|
+ */
|
||||||
+#define CONFIG_JFFS2_NAND
|
+#define CONFIG_JFFS2_NAND
|
||||||
+#define CONFIG_JFFS2_LZO
|
+#define CONFIG_JFFS2_LZO
|
||||||
+#define CONFIG_MTD_DEVICE /* needed for mtdparts commands */
|
|
||||||
+#define CONFIG_MTD_PARTITIONS
|
|
||||||
+
|
+
|
||||||
+/*
|
+/*
|
||||||
+ * Date Time
|
+ * Date Time
|
||||||
|
|
|
@ -1,22 +1,23 @@
|
||||||
--- a/arch/arm/mach-kirkwood/Kconfig
|
--- a/arch/arm/mach-kirkwood/Kconfig
|
||||||
+++ b/arch/arm/mach-kirkwood/Kconfig
|
+++ b/arch/arm/mach-kirkwood/Kconfig
|
||||||
@@ -62,6 +62,9 @@ config TARGET_NSA310
|
@@ -68,6 +68,9 @@ config TARGET_SBx81LIFKW
|
||||||
config TARGET_NSA310S
|
config TARGET_SBx81LIFXCAT
|
||||||
bool "Zyxel NSA310S"
|
bool "Allied Telesis SBx81GP24/SBx81GT24"
|
||||||
|
|
||||||
+config TARGET_NSA325
|
+config TARGET_NSA325
|
||||||
+ bool "Zyxel NSA325 board"
|
+ bool "Zyxel NSA325 board"
|
||||||
+
|
+
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
config SYS_SOC
|
config SYS_SOC
|
||||||
@@ -85,5 +88,6 @@ source "board/Seagate/goflexhome/Kconfig
|
@@ -91,6 +94,7 @@ source "board/Seagate/goflexhome/Kconfig
|
||||||
source "board/Seagate/nas220/Kconfig"
|
source "board/Seagate/nas220/Kconfig"
|
||||||
source "board/zyxel/nsa310/Kconfig"
|
source "board/zyxel/nsa310/Kconfig"
|
||||||
source "board/zyxel/nsa310s/Kconfig"
|
source "board/zyxel/nsa310s/Kconfig"
|
||||||
+source "board/zyxel/nsa325/Kconfig"
|
+source "board/zyxel/nsa325/Kconfig"
|
||||||
|
source "board/alliedtelesis/SBx81LIFKW/Kconfig"
|
||||||
endif
|
source "board/alliedtelesis/SBx81LIFXCAT/Kconfig"
|
||||||
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/board/zyxel/nsa325/Kconfig
|
+++ b/board/zyxel/nsa325/Kconfig
|
||||||
@@ -0,0 +1,12 @@
|
@@ -0,0 +1,12 @@
|
||||||
|
@ -488,16 +489,19 @@
|
||||||
+#endif /* __NSA325_H */
|
+#endif /* __NSA325_H */
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/configs/nsa325_defconfig
|
+++ b/configs/nsa325_defconfig
|
||||||
@@ -0,0 +1,37 @@
|
@@ -0,0 +1,40 @@
|
||||||
+CONFIG_ARM=y
|
+CONFIG_ARM=y
|
||||||
+CONFIG_KIRKWOOD=y
|
+CONFIG_KIRKWOOD=y
|
||||||
+CONFIG_SYS_TEXT_BASE=0x600000
|
+CONFIG_SYS_TEXT_BASE=0x600000
|
||||||
+CONFIG_TARGET_NSA325=y
|
+CONFIG_TARGET_NSA325=y
|
||||||
+CONFIG_IDENT_STRING="\nZyXEL NSA325 2-Bay Power Media Server"
|
+CONFIG_IDENT_STRING="\nZyXEL NSA325 2-Bay Power Media Server"
|
||||||
|
+CONFIG_NR_DRAM_BANKS=2
|
||||||
+CONFIG_BOOTDELAY=3
|
+CONFIG_BOOTDELAY=3
|
||||||
+CONFIG_SYS_PROMPT="NSA325> "
|
+CONFIG_SYS_PROMPT="NSA325> "
|
||||||
+# CONFIG_CMD_IMLS is not set
|
+# CONFIG_CMD_IMLS is not set
|
||||||
+# CONFIG_CMD_FLASH is not set
|
+# CONFIG_CMD_FLASH is not set
|
||||||
|
+CONFIG_MVGBE=y
|
||||||
|
+CONFIG_MII=y
|
||||||
+CONFIG_SYS_NS16550=y
|
+CONFIG_SYS_NS16550=y
|
||||||
+CONFIG_CMD_FDT=y
|
+CONFIG_CMD_FDT=y
|
||||||
+CONFIG_OF_LIBFDT=y
|
+CONFIG_OF_LIBFDT=y
|
||||||
|
@ -528,7 +532,7 @@
|
||||||
+CONFIG_SYS_LONGHELP=y
|
+CONFIG_SYS_LONGHELP=y
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/include/configs/nsa325.h
|
+++ b/include/configs/nsa325.h
|
||||||
@@ -0,0 +1,122 @@
|
@@ -0,0 +1,120 @@
|
||||||
+/*
|
+/*
|
||||||
+ * (C) Copyright 2016 bodhi <mibodhi@gmail.com>
|
+ * (C) Copyright 2016 bodhi <mibodhi@gmail.com>
|
||||||
+ *
|
+ *
|
||||||
|
@ -638,8 +642,6 @@
|
||||||
+ */
|
+ */
|
||||||
+#define CONFIG_JFFS2_NAND
|
+#define CONFIG_JFFS2_NAND
|
||||||
+#define CONFIG_JFFS2_LZO
|
+#define CONFIG_JFFS2_LZO
|
||||||
+#define CONFIG_MTD_DEVICE /* needed for mtdparts commands */
|
|
||||||
+#define CONFIG_MTD_PARTITIONS
|
|
||||||
+
|
+
|
||||||
+/*
|
+/*
|
||||||
+ * Date Time
|
+ * Date Time
|
||||||
|
|
|
@ -10,7 +10,7 @@
|
||||||
config TARGET_DNS325
|
config TARGET_DNS325
|
||||||
bool "dns325 Board"
|
bool "dns325 Board"
|
||||||
|
|
||||||
@@ -77,6 +80,7 @@ source "board/Marvell/guruplug/Kconfig"
|
@@ -83,6 +86,7 @@ source "board/Marvell/guruplug/Kconfig"
|
||||||
source "board/Marvell/sheevaplug/Kconfig"
|
source "board/Marvell/sheevaplug/Kconfig"
|
||||||
source "board/buffalo/lsxl/Kconfig"
|
source "board/buffalo/lsxl/Kconfig"
|
||||||
source "board/cloudengines/pogo_e02/Kconfig"
|
source "board/cloudengines/pogo_e02/Kconfig"
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
source "board/keymile/km_arm/Kconfig"
|
source "board/keymile/km_arm/Kconfig"
|
||||||
--- a/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
|
--- a/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
|
||||||
+++ b/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
|
+++ b/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
|
||||||
@@ -16,6 +16,6 @@
|
@@ -15,6 +15,6 @@
|
||||||
#define KW_REGS_PHY_BASE KW88F6192_REGS_PHYS_BASE
|
#define KW_REGS_PHY_BASE KW88F6192_REGS_PHYS_BASE
|
||||||
|
|
||||||
/* TCLK Core Clock defination */
|
/* TCLK Core Clock defination */
|
||||||
|
@ -30,7 +30,7 @@
|
||||||
#endif /* _CONFIG_KW88F6192_H */
|
#endif /* _CONFIG_KW88F6192_H */
|
||||||
--- a/arch/arm/mach-kirkwood/include/mach/mpp.h
|
--- a/arch/arm/mach-kirkwood/include/mach/mpp.h
|
||||||
+++ b/arch/arm/mach-kirkwood/include/mach/mpp.h
|
+++ b/arch/arm/mach-kirkwood/include/mach/mpp.h
|
||||||
@@ -217,10 +217,12 @@
|
@@ -216,10 +216,12 @@
|
||||||
#define MPP33_GPIO MPP( 33, 0x0, 1, 1, 0, 1, 1, 1 )
|
#define MPP33_GPIO MPP( 33, 0x0, 1, 1, 0, 1, 1, 1 )
|
||||||
#define MPP33_TDM_DTX MPP( 33, 0x2, 0, 1, 0, 0, 1, 1 )
|
#define MPP33_TDM_DTX MPP( 33, 0x2, 0, 1, 0, 0, 1, 1 )
|
||||||
#define MPP33_GE1_13 MPP( 33, 0x3, 0, 0, 0, 1, 1, 1 )
|
#define MPP33_GE1_13 MPP( 33, 0x3, 0, 0, 0, 1, 1, 1 )
|
||||||
|
@ -532,16 +532,19 @@
|
||||||
+#endif /* __POGOPLUGV4_H */
|
+#endif /* __POGOPLUGV4_H */
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/configs/pogoplugv4_defconfig
|
+++ b/configs/pogoplugv4_defconfig
|
||||||
@@ -0,0 +1,40 @@
|
@@ -0,0 +1,43 @@
|
||||||
+CONFIG_ARM=y
|
+CONFIG_ARM=y
|
||||||
+CONFIG_KIRKWOOD=y
|
+CONFIG_KIRKWOOD=y
|
||||||
+CONFIG_SYS_TEXT_BASE=0x600000
|
+CONFIG_SYS_TEXT_BASE=0x600000
|
||||||
+CONFIG_TARGET_POGOPLUGV4=y
|
+CONFIG_TARGET_POGOPLUGV4=y
|
||||||
+CONFIG_SYS_PROMPT="pogoplugv4> "
|
+CONFIG_SYS_PROMPT="pogoplugv4> "
|
||||||
+CONFIG_IDENT_STRING="\nPogoplug V4"
|
+CONFIG_IDENT_STRING="\nPogoplug V4"
|
||||||
|
+CONFIG_NR_DRAM_BANKS=2
|
||||||
+CONFIG_BOOTDELAY=3
|
+CONFIG_BOOTDELAY=3
|
||||||
+# CONFIG_CMD_IMLS is not set
|
+# CONFIG_CMD_IMLS is not set
|
||||||
+# CONFIG_CMD_FLASH is not set
|
+# CONFIG_CMD_FLASH is not set
|
||||||
|
+CONFIG_MVGBE=y
|
||||||
|
+CONFIG_MII=y
|
||||||
+CONFIG_SYS_NS16550=y
|
+CONFIG_SYS_NS16550=y
|
||||||
+CONFIG_CMD_FDT=y
|
+CONFIG_CMD_FDT=y
|
||||||
+CONFIG_OF_LIBFDT=y
|
+CONFIG_OF_LIBFDT=y
|
||||||
|
@ -575,7 +578,7 @@
|
||||||
+CONFIG_SYS_LONGHELP=y
|
+CONFIG_SYS_LONGHELP=y
|
||||||
--- a/drivers/gpio/kw_gpio.c
|
--- a/drivers/gpio/kw_gpio.c
|
||||||
+++ b/drivers/gpio/kw_gpio.c
|
+++ b/drivers/gpio/kw_gpio.c
|
||||||
@@ -148,3 +148,36 @@ void kw_gpio_set_blink(unsigned pin, int
|
@@ -147,3 +147,36 @@ void kw_gpio_set_blink(unsigned pin, int
|
||||||
/* Set blinking. */
|
/* Set blinking. */
|
||||||
__set_blinking(pin, blink);
|
__set_blinking(pin, blink);
|
||||||
}
|
}
|
||||||
|
@ -621,7 +624,7 @@
|
||||||
+obj-$(CONFIG_KIRKWOOD_MMC) += kirkwood_mmc.o
|
+obj-$(CONFIG_KIRKWOOD_MMC) += kirkwood_mmc.o
|
||||||
|
|
||||||
obj-$(CONFIG_MMC_SUNXI) += sunxi_mmc.o
|
obj-$(CONFIG_MMC_SUNXI) += sunxi_mmc.o
|
||||||
obj-$(CONFIG_MMC_UNIPHIER) += uniphier-sd.o
|
obj-$(CONFIG_MMC_UNIPHIER) += tmio-common.o uniphier-sd.o
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/mmc/kirkwood_mmc.c
|
+++ b/drivers/mmc/kirkwood_mmc.c
|
||||||
@@ -0,0 +1,482 @@
|
@@ -0,0 +1,482 @@
|
||||||
|
@ -1109,8 +1112,8 @@
|
||||||
+}
|
+}
|
||||||
--- a/include/configs/mv-common.h
|
--- a/include/configs/mv-common.h
|
||||||
+++ b/include/configs/mv-common.h
|
+++ b/include/configs/mv-common.h
|
||||||
@@ -117,4 +117,10 @@
|
@@ -77,4 +77,10 @@
|
||||||
#define CONFIG_MTD_PARTITIONS
|
#define CONFIG_SYS_MAX_NAND_DEVICE 1
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
+/*
|
+/*
|
||||||
|
@ -1122,7 +1125,7 @@
|
||||||
#endif /* _MV_COMMON_H */
|
#endif /* _MV_COMMON_H */
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/include/configs/pogoplugv4.h
|
+++ b/include/configs/pogoplugv4.h
|
||||||
@@ -0,0 +1,129 @@
|
@@ -0,0 +1,127 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Copyright (C) 2014-2016 bodhi <mibodhi@gmail.com>
|
+ * Copyright (C) 2014-2016 bodhi <mibodhi@gmail.com>
|
||||||
+ * Based on
|
+ * Based on
|
||||||
|
@ -1229,8 +1232,6 @@
|
||||||
+ */
|
+ */
|
||||||
+#define CONFIG_JFFS2_NAND
|
+#define CONFIG_JFFS2_NAND
|
||||||
+#define CONFIG_JFFS2_LZO
|
+#define CONFIG_JFFS2_LZO
|
||||||
+#define CONFIG_MTD_DEVICE /* needed for mtdparts commands */
|
|
||||||
+#define CONFIG_MTD_PARTITIONS
|
|
||||||
+
|
+
|
||||||
+/*
|
+/*
|
||||||
+ * SATA
|
+ * SATA
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/include/configs/dockstar.h
|
--- a/include/configs/dockstar.h
|
||||||
+++ b/include/configs/dockstar.h
|
+++ b/include/configs/dockstar.h
|
||||||
@@ -18,6 +18,7 @@
|
@@ -17,6 +17,7 @@
|
||||||
#define CONFIG_FEROCEON_88FR131 1 /* CPU Core subversion */
|
#define CONFIG_FEROCEON_88FR131 1 /* CPU Core subversion */
|
||||||
#define CONFIG_KW88F6281 1 /* SOC Name */
|
#define CONFIG_KW88F6281 1 /* SOC Name */
|
||||||
#define CONFIG_SKIP_LOWLEVEL_INIT /* disable board lowlevel_init */
|
#define CONFIG_SKIP_LOWLEVEL_INIT /* disable board lowlevel_init */
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
|
|
||||||
/*
|
/*
|
||||||
* mv-common.h should be defined after CMD configs since it used them
|
* mv-common.h should be defined after CMD configs since it used them
|
||||||
@@ -36,27 +37,22 @@
|
@@ -35,27 +36,22 @@
|
||||||
* it has to be rounded to sector size
|
* it has to be rounded to sector size
|
||||||
*/
|
*/
|
||||||
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
||||||
|
@ -46,12 +46,12 @@
|
||||||
* Ethernet Driver configuration
|
* Ethernet Driver configuration
|
||||||
--- a/configs/dockstar_defconfig
|
--- a/configs/dockstar_defconfig
|
||||||
+++ b/configs/dockstar_defconfig
|
+++ b/configs/dockstar_defconfig
|
||||||
@@ -16,7 +16,7 @@ CONFIG_CMD_PING=y
|
@@ -18,7 +18,7 @@ CONFIG_CMD_PING=y
|
||||||
CONFIG_CMD_EXT2=y
|
|
||||||
CONFIG_CMD_FAT=y
|
CONFIG_CMD_FAT=y
|
||||||
CONFIG_CMD_JFFS2=y
|
CONFIG_CMD_JFFS2=y
|
||||||
|
CONFIG_CMD_MTDPARTS=y
|
||||||
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),-(root)"
|
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),-(root)"
|
||||||
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
||||||
CONFIG_CMD_UBI=y
|
CONFIG_CMD_UBI=y
|
||||||
CONFIG_ISO_PARTITION=y
|
CONFIG_ISO_PARTITION=y
|
||||||
CONFIG_ENV_IS_IN_NAND=y
|
CONFIG_OF_CONTROL=y
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/include/configs/iconnect.h
|
--- a/include/configs/iconnect.h
|
||||||
+++ b/include/configs/iconnect.h
|
+++ b/include/configs/iconnect.h
|
||||||
@@ -44,24 +44,22 @@
|
@@ -42,24 +42,22 @@
|
||||||
#define CONFIG_ENV_SECT_SIZE 0x20000
|
#define CONFIG_ENV_SECT_SIZE 0x20000
|
||||||
#endif
|
#endif
|
||||||
#define CONFIG_ENV_SIZE 0x20000
|
#define CONFIG_ENV_SIZE 0x20000
|
||||||
|
@ -32,7 +32,7 @@
|
||||||
* Ethernet driver configuration
|
* Ethernet driver configuration
|
||||||
--- a/configs/iconnect_defconfig
|
--- a/configs/iconnect_defconfig
|
||||||
+++ b/configs/iconnect_defconfig
|
+++ b/configs/iconnect_defconfig
|
||||||
@@ -10,12 +10,13 @@ CONFIG_SYS_PROMPT="iconnect => "
|
@@ -11,13 +11,14 @@ CONFIG_SYS_PROMPT="iconnect => "
|
||||||
CONFIG_CMD_NAND=y
|
CONFIG_CMD_NAND=y
|
||||||
CONFIG_CMD_USB=y
|
CONFIG_CMD_USB=y
|
||||||
# CONFIG_CMD_SETEXPR is not set
|
# CONFIG_CMD_SETEXPR is not set
|
||||||
|
@ -42,8 +42,9 @@
|
||||||
CONFIG_CMD_EXT2=y
|
CONFIG_CMD_EXT2=y
|
||||||
CONFIG_CMD_FAT=y
|
CONFIG_CMD_FAT=y
|
||||||
CONFIG_CMD_JFFS2=y
|
CONFIG_CMD_JFFS2=y
|
||||||
|
CONFIG_CMD_MTDPARTS=y
|
||||||
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x80000@0x0(uboot),0x20000@0x80000(uboot_env),-@0xa0000(rootfs)"
|
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x80000@0x0(uboot),0x20000@0x80000(uboot_env),-@0xa0000(rootfs)"
|
||||||
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
||||||
CONFIG_CMD_UBI=y
|
CONFIG_CMD_UBI=y
|
||||||
CONFIG_ISO_PARTITION=y
|
CONFIG_ISO_PARTITION=y
|
||||||
CONFIG_ENV_IS_IN_NAND=y
|
CONFIG_OF_CONTROL=y
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/include/configs/ib62x0.h
|
--- a/include/configs/ib62x0.h
|
||||||
+++ b/include/configs/ib62x0.h
|
+++ b/include/configs/ib62x0.h
|
||||||
@@ -49,21 +49,15 @@
|
@@ -47,21 +47,15 @@
|
||||||
*/
|
*/
|
||||||
#define CONFIG_BOOTCOMMAND \
|
#define CONFIG_BOOTCOMMAND \
|
||||||
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
||||||
|
@ -29,12 +29,12 @@
|
||||||
* Ethernet driver configuration
|
* Ethernet driver configuration
|
||||||
--- a/configs/ib62x0_defconfig
|
--- a/configs/ib62x0_defconfig
|
||||||
+++ b/configs/ib62x0_defconfig
|
+++ b/configs/ib62x0_defconfig
|
||||||
@@ -19,7 +19,7 @@ CONFIG_CMD_PING=y
|
@@ -21,7 +21,7 @@ CONFIG_CMD_PING=y
|
||||||
CONFIG_CMD_EXT2=y
|
|
||||||
CONFIG_CMD_FAT=y
|
CONFIG_CMD_FAT=y
|
||||||
CONFIG_CMD_JFFS2=y
|
CONFIG_CMD_JFFS2=y
|
||||||
|
CONFIG_CMD_MTDPARTS=y
|
||||||
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),-@0x100000(root)"
|
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),-@0x100000(root)"
|
||||||
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
||||||
CONFIG_CMD_UBI=y
|
CONFIG_CMD_UBI=y
|
||||||
CONFIG_ISO_PARTITION=y
|
CONFIG_ISO_PARTITION=y
|
||||||
CONFIG_ENV_IS_IN_NAND=y
|
CONFIG_OF_CONTROL=y
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/include/configs/pogo_e02.h
|
--- a/include/configs/pogo_e02.h
|
||||||
+++ b/include/configs/pogo_e02.h
|
+++ b/include/configs/pogo_e02.h
|
||||||
@@ -44,23 +44,23 @@
|
@@ -42,23 +42,23 @@
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
||||||
|
@ -36,11 +36,11 @@
|
||||||
* Ethernet Driver configuration
|
* Ethernet Driver configuration
|
||||||
--- a/configs/pogo_e02_defconfig
|
--- a/configs/pogo_e02_defconfig
|
||||||
+++ b/configs/pogo_e02_defconfig
|
+++ b/configs/pogo_e02_defconfig
|
||||||
@@ -16,6 +16,7 @@ CONFIG_CMD_PING=y
|
@@ -18,6 +18,7 @@ CONFIG_CMD_PING=y
|
||||||
CONFIG_CMD_EXT2=y
|
|
||||||
CONFIG_CMD_FAT=y
|
CONFIG_CMD_FAT=y
|
||||||
CONFIG_CMD_JFFS2=y
|
CONFIG_CMD_JFFS2=y
|
||||||
|
CONFIG_CMD_MTDPARTS=y
|
||||||
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
|
||||||
CONFIG_CMD_UBI=y
|
CONFIG_CMD_UBI=y
|
||||||
CONFIG_ISO_PARTITION=y
|
CONFIG_ISO_PARTITION=y
|
||||||
CONFIG_ENV_IS_IN_NAND=y
|
CONFIG_OF_CONTROL=y
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/include/configs/goflexhome.h
|
--- a/include/configs/goflexhome.h
|
||||||
+++ b/include/configs/goflexhome.h
|
+++ b/include/configs/goflexhome.h
|
||||||
@@ -69,17 +69,15 @@
|
@@ -66,17 +66,15 @@
|
||||||
*/
|
*/
|
||||||
#define CONFIG_BOOTCOMMAND \
|
#define CONFIG_BOOTCOMMAND \
|
||||||
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
||||||
|
@ -24,12 +24,12 @@
|
||||||
* Ethernet Driver configuration
|
* Ethernet Driver configuration
|
||||||
--- a/configs/goflexhome_defconfig
|
--- a/configs/goflexhome_defconfig
|
||||||
+++ b/configs/goflexhome_defconfig
|
+++ b/configs/goflexhome_defconfig
|
||||||
@@ -21,7 +21,7 @@ CONFIG_CMD_EXT4=y
|
@@ -23,7 +23,7 @@ CONFIG_CMD_EXT4=y
|
||||||
CONFIG_CMD_FAT=y
|
|
||||||
CONFIG_CMD_JFFS2=y
|
CONFIG_CMD_JFFS2=y
|
||||||
|
CONFIG_CMD_MTDPARTS=y
|
||||||
CONFIG_MTDIDS_DEFAULT="nand0=orion_nand"
|
CONFIG_MTDIDS_DEFAULT="nand0=orion_nand"
|
||||||
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),6M(uImage),-(root)"
|
-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),6M(uImage),-(root)"
|
||||||
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),255m(ubi)"
|
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),255m(ubi)"
|
||||||
CONFIG_CMD_UBI=y
|
CONFIG_CMD_UBI=y
|
||||||
CONFIG_ISO_PARTITION=y
|
CONFIG_ISO_PARTITION=y
|
||||||
CONFIG_ENV_IS_IN_NAND=y
|
CONFIG_OF_CONTROL=y
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
--- a/arch/arm/mach-kirkwood/Kconfig
|
--- a/arch/arm/mach-kirkwood/Kconfig
|
||||||
+++ b/arch/arm/mach-kirkwood/Kconfig
|
+++ b/arch/arm/mach-kirkwood/Kconfig
|
||||||
@@ -94,4 +94,7 @@ source "board/zyxel/nsa310/Kconfig"
|
@@ -102,4 +102,7 @@ source "board/zyxel/nsa310/Kconfig"
|
||||||
source "board/zyxel/nsa310s/Kconfig"
|
source "board/alliedtelesis/SBx81LIFKW/Kconfig"
|
||||||
source "board/zyxel/nsa325/Kconfig"
|
source "board/alliedtelesis/SBx81LIFXCAT/Kconfig"
|
||||||
|
|
||||||
+config SECOND_STAGE
|
+config SECOND_STAGE
|
||||||
+ bool "OpenWrt second stage hack"
|
+ bool "OpenWrt second stage hack"
|
||||||
|
@ -10,16 +10,16 @@
|
||||||
endif
|
endif
|
||||||
--- a/include/configs/dockstar.h
|
--- a/include/configs/dockstar.h
|
||||||
+++ b/include/configs/dockstar.h
|
+++ b/include/configs/dockstar.h
|
||||||
@@ -68,4 +68,6 @@
|
@@ -65,4 +65,6 @@
|
||||||
#define CONFIG_MTD_DEVICE /* needed for mtdparts commands */
|
* File system
|
||||||
#define CONFIG_MTD_PARTITIONS
|
*/
|
||||||
|
|
||||||
+#include "openwrt-kirkwood-common.h"
|
+#include "openwrt-kirkwood-common.h"
|
||||||
+
|
+
|
||||||
#endif /* _CONFIG_DOCKSTAR_H */
|
#endif /* _CONFIG_DOCKSTAR_H */
|
||||||
--- a/include/configs/ib62x0.h
|
--- a/include/configs/ib62x0.h
|
||||||
+++ b/include/configs/ib62x0.h
|
+++ b/include/configs/ib62x0.h
|
||||||
@@ -87,4 +87,6 @@
|
@@ -85,4 +85,6 @@
|
||||||
#define CONFIG_RTC_MV
|
#define CONFIG_RTC_MV
|
||||||
#endif /* CONFIG_CMD_DATE */
|
#endif /* CONFIG_CMD_DATE */
|
||||||
|
|
||||||
|
@ -28,9 +28,9 @@
|
||||||
#endif /* _CONFIG_IB62x0_H */
|
#endif /* _CONFIG_IB62x0_H */
|
||||||
--- a/include/configs/iconnect.h
|
--- a/include/configs/iconnect.h
|
||||||
+++ b/include/configs/iconnect.h
|
+++ b/include/configs/iconnect.h
|
||||||
@@ -76,4 +76,6 @@
|
@@ -72,4 +72,6 @@
|
||||||
#define CONFIG_MTD_DEVICE
|
* File system
|
||||||
#define CONFIG_MTD_PARTITIONS
|
*/
|
||||||
|
|
||||||
+#include "openwrt-kirkwood-common.h"
|
+#include "openwrt-kirkwood-common.h"
|
||||||
+
|
+
|
||||||
|
@ -71,25 +71,25 @@
|
||||||
+#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
|
+#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
|
||||||
--- a/include/configs/pogo_e02.h
|
--- a/include/configs/pogo_e02.h
|
||||||
+++ b/include/configs/pogo_e02.h
|
+++ b/include/configs/pogo_e02.h
|
||||||
@@ -76,4 +76,6 @@
|
@@ -72,4 +72,6 @@
|
||||||
#define CONFIG_MTD_DEVICE /* needed for mtdparts commands */
|
* File system
|
||||||
#define CONFIG_MTD_PARTITIONS
|
*/
|
||||||
|
|
||||||
+#include "openwrt-kirkwood-common.h"
|
+#include "openwrt-kirkwood-common.h"
|
||||||
+
|
+
|
||||||
#endif /* _CONFIG_POGO_E02_H */
|
#endif /* _CONFIG_POGO_E02_H */
|
||||||
--- a/include/configs/goflexhome.h
|
--- a/include/configs/goflexhome.h
|
||||||
+++ b/include/configs/goflexhome.h
|
+++ b/include/configs/goflexhome.h
|
||||||
@@ -101,4 +101,6 @@
|
@@ -91,4 +91,6 @@
|
||||||
#define CONFIG_RTC_MV
|
#define CONFIG_SYS_ATA_IDE0_OFFSET MV_SATA_PORT0_OFFSET
|
||||||
#endif /* CONFIG_CMD_DATE */
|
#endif /*CONFIG_MVSATA_IDE*/
|
||||||
|
|
||||||
+#include "openwrt-kirkwood-common.h"
|
+#include "openwrt-kirkwood-common.h"
|
||||||
+
|
+
|
||||||
#endif /* _CONFIG_GOFLEXHOME_H */
|
#endif /* _CONFIG_GOFLEXHOME_H */
|
||||||
--- a/include/configs/nsa310.h
|
--- a/include/configs/nsa310.h
|
||||||
+++ b/include/configs/nsa310.h
|
+++ b/include/configs/nsa310.h
|
||||||
@@ -116,4 +116,6 @@
|
@@ -114,4 +114,6 @@
|
||||||
#define CONFIG_RTC_MV
|
#define CONFIG_RTC_MV
|
||||||
#endif /* CONFIG_CMD_DATE */
|
#endif /* CONFIG_CMD_DATE */
|
||||||
|
|
||||||
|
@ -98,10 +98,10 @@
|
||||||
#endif /* _CONFIG_NSA310_H */
|
#endif /* _CONFIG_NSA310_H */
|
||||||
--- a/configs/dockstar_defconfig
|
--- a/configs/dockstar_defconfig
|
||||||
+++ b/configs/dockstar_defconfig
|
+++ b/configs/dockstar_defconfig
|
||||||
@@ -26,3 +26,8 @@ CONFIG_USB=y
|
@@ -31,3 +31,8 @@ CONFIG_USB=y
|
||||||
|
CONFIG_USB=y
|
||||||
CONFIG_USB_EHCI_HCD=y
|
CONFIG_USB_EHCI_HCD=y
|
||||||
CONFIG_USB_STORAGE=y
|
CONFIG_USB_STORAGE=y
|
||||||
CONFIG_OF_LIBFDT=y
|
|
||||||
+CONFIG_CMD_BOOTZ=y
|
+CONFIG_CMD_BOOTZ=y
|
||||||
+CONFIG_FIT=y
|
+CONFIG_FIT=y
|
||||||
+CONFIG_FIT_VERBOSE=y
|
+CONFIG_FIT_VERBOSE=y
|
||||||
|
@ -109,10 +109,10 @@
|
||||||
+CONFIG_LZO=y
|
+CONFIG_LZO=y
|
||||||
--- a/configs/goflexhome_defconfig
|
--- a/configs/goflexhome_defconfig
|
||||||
+++ b/configs/goflexhome_defconfig
|
+++ b/configs/goflexhome_defconfig
|
||||||
@@ -32,3 +32,8 @@ CONFIG_USB=y
|
@@ -40,3 +40,8 @@ CONFIG_USB=y
|
||||||
|
CONFIG_USB=y
|
||||||
CONFIG_USB_EHCI_HCD=y
|
CONFIG_USB_EHCI_HCD=y
|
||||||
CONFIG_USB_STORAGE=y
|
CONFIG_USB_STORAGE=y
|
||||||
CONFIG_OF_LIBFDT=y
|
|
||||||
+CONFIG_CMD_BOOTZ=y
|
+CONFIG_CMD_BOOTZ=y
|
||||||
+CONFIG_FIT=y
|
+CONFIG_FIT=y
|
||||||
+CONFIG_FIT_VERBOSE=y
|
+CONFIG_FIT_VERBOSE=y
|
||||||
|
@ -120,24 +120,22 @@
|
||||||
+CONFIG_LZO=y
|
+CONFIG_LZO=y
|
||||||
--- a/configs/ib62x0_defconfig
|
--- a/configs/ib62x0_defconfig
|
||||||
+++ b/configs/ib62x0_defconfig
|
+++ b/configs/ib62x0_defconfig
|
||||||
@@ -29,5 +29,8 @@ CONFIG_SYS_NS16550=y
|
@@ -35,4 +35,7 @@ CONFIG_SYS_NS16550=y
|
||||||
CONFIG_USB=y
|
CONFIG_USB=y
|
||||||
CONFIG_USB_EHCI_HCD=y
|
CONFIG_USB_EHCI_HCD=y
|
||||||
CONFIG_USB_STORAGE=y
|
CONFIG_USB_STORAGE=y
|
||||||
-CONFIG_LZMA=y
|
-CONFIG_LZMA=y
|
||||||
CONFIG_OF_LIBFDT=y
|
|
||||||
+CONFIG_FIT=y
|
+CONFIG_FIT=y
|
||||||
+CONFIG_FIT_VERBOSE=y
|
+CONFIG_FIT_VERBOSE=y
|
||||||
+CONFIG_LZMA=y
|
+CONFIG_LZMA=y
|
||||||
+CONFIG_LZO=y
|
+CONFIG_LZO=y
|
||||||
--- a/configs/iconnect_defconfig
|
--- a/configs/iconnect_defconfig
|
||||||
+++ b/configs/iconnect_defconfig
|
+++ b/configs/iconnect_defconfig
|
||||||
@@ -25,5 +25,9 @@ CONFIG_SYS_NS16550=y
|
@@ -31,4 +31,8 @@ CONFIG_SYS_NS16550=y
|
||||||
CONFIG_USB=y
|
CONFIG_USB=y
|
||||||
CONFIG_USB_EHCI_HCD=y
|
CONFIG_USB_EHCI_HCD=y
|
||||||
CONFIG_USB_STORAGE=y
|
CONFIG_USB_STORAGE=y
|
||||||
-CONFIG_LZMA=y
|
-CONFIG_LZMA=y
|
||||||
CONFIG_OF_LIBFDT=y
|
|
||||||
+CONFIG_CMD_BOOTZ=y
|
+CONFIG_CMD_BOOTZ=y
|
||||||
+CONFIG_FIT=y
|
+CONFIG_FIT=y
|
||||||
+CONFIG_FIT_VERBOSE=y
|
+CONFIG_FIT_VERBOSE=y
|
||||||
|
@ -145,7 +143,7 @@
|
||||||
+CONFIG_LZO=y
|
+CONFIG_LZO=y
|
||||||
--- a/configs/nsa310_defconfig
|
--- a/configs/nsa310_defconfig
|
||||||
+++ b/configs/nsa310_defconfig
|
+++ b/configs/nsa310_defconfig
|
||||||
@@ -32,6 +32,9 @@ CONFIG_CMD_UBI=y
|
@@ -35,6 +35,9 @@ CONFIG_CMD_UBI=y
|
||||||
CONFIG_USB=y
|
CONFIG_USB=y
|
||||||
CONFIG_USB_EHCI_HCD=y
|
CONFIG_USB_EHCI_HCD=y
|
||||||
CONFIG_USB_STORAGE=y
|
CONFIG_USB_STORAGE=y
|
||||||
|
@ -157,10 +155,10 @@
|
||||||
CONFIG_SYS_LONGHELP=y
|
CONFIG_SYS_LONGHELP=y
|
||||||
--- a/configs/pogo_e02_defconfig
|
--- a/configs/pogo_e02_defconfig
|
||||||
+++ b/configs/pogo_e02_defconfig
|
+++ b/configs/pogo_e02_defconfig
|
||||||
@@ -26,3 +26,8 @@ CONFIG_USB=y
|
@@ -31,3 +31,8 @@ CONFIG_USB=y
|
||||||
|
CONFIG_USB=y
|
||||||
CONFIG_USB_EHCI_HCD=y
|
CONFIG_USB_EHCI_HCD=y
|
||||||
CONFIG_USB_STORAGE=y
|
CONFIG_USB_STORAGE=y
|
||||||
CONFIG_OF_LIBFDT=y
|
|
||||||
+CONFIG_CMD_BOOTZ=y
|
+CONFIG_CMD_BOOTZ=y
|
||||||
+CONFIG_FIT=y
|
+CONFIG_FIT=y
|
||||||
+CONFIG_FIT_VERBOSE=y
|
+CONFIG_FIT_VERBOSE=y
|
||||||
|
|
Loading…
Reference in New Issue