mirror of https://github.com/hak5/openwrt.git
parent
65edd13209
commit
d2c338cd52
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
||||||
BOARDNAME:=Atheros
|
BOARDNAME:=Atheros
|
||||||
FEATURES:=squashfs jffs2
|
FEATURES:=squashfs jffs2
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.21.5
|
LINUX_VERSION:=2.6.22.1
|
||||||
|
|
||||||
define Target/Description
|
define Target/Description
|
||||||
Build firmware images for Atheros SoC boards
|
Build firmware images for Atheros SoC boards
|
||||||
|
|
|
@ -146,14 +146,14 @@ static irqreturn_t ar5312_ahb_proc_handler(int cpl, void *dev_id)
|
||||||
|
|
||||||
static struct irqaction ar5312_ahb_proc_interrupt = {
|
static struct irqaction ar5312_ahb_proc_interrupt = {
|
||||||
.handler = ar5312_ahb_proc_handler,
|
.handler = ar5312_ahb_proc_handler,
|
||||||
.flags = SA_INTERRUPT,
|
.flags = IRQF_DISABLED,
|
||||||
.name = "ar5312_ahb_proc_interrupt",
|
.name = "ar5312_ahb_proc_interrupt",
|
||||||
};
|
};
|
||||||
|
|
||||||
|
|
||||||
static struct irqaction cascade = {
|
static struct irqaction cascade = {
|
||||||
.handler = no_action,
|
.handler = no_action,
|
||||||
.flags = SA_INTERRUPT,
|
.flags = IRQF_DISABLED,
|
||||||
.name = "cascade",
|
.name = "cascade",
|
||||||
};
|
};
|
||||||
|
|
||||||
|
|
|
@ -288,14 +288,14 @@ static irqreturn_t ar5315_ahb_proc_handler(int cpl, void *dev_id)
|
||||||
|
|
||||||
static struct irqaction ar5315_ahb_proc_interrupt = {
|
static struct irqaction ar5315_ahb_proc_interrupt = {
|
||||||
.handler = ar5315_ahb_proc_handler,
|
.handler = ar5315_ahb_proc_handler,
|
||||||
.flags = SA_INTERRUPT,
|
.flags = IRQF_DISABLED,
|
||||||
.name = "ar5315_ahb_proc_interrupt",
|
.name = "ar5315_ahb_proc_interrupt",
|
||||||
};
|
};
|
||||||
|
|
||||||
|
|
||||||
static struct irqaction cascade = {
|
static struct irqaction cascade = {
|
||||||
.handler = no_action,
|
.handler = no_action,
|
||||||
.flags = SA_INTERRUPT,
|
.flags = IRQF_DISABLED,
|
||||||
.name = "cascade",
|
.name = "cascade",
|
||||||
};
|
};
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
|
diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
|
||||||
--- linux.old/arch/mips/Kconfig 2007-02-02 23:55:52.912446784 +0100
|
--- linux.old/arch/mips/Kconfig 2007-02-02 23:55:52.912446784 +0100
|
||||||
+++ linux.dev/arch/mips/Kconfig 2007-02-03 21:50:25.262027104 +0100
|
+++ linux.dev/arch/mips/Kconfig 2007-02-03 21:50:25.262027104 +0100
|
||||||
@@ -145,6 +145,16 @@
|
@@ -45,6 +45,16 @@
|
||||||
note that a kernel built with this option selected will not be
|
note that a kernel built with this option selected will not be
|
||||||
able to run on normal units.
|
able to run on normal units.
|
||||||
|
|
||||||
|
@ -18,14 +18,14 @@ diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
|
||||||
config MIPS_COBALT
|
config MIPS_COBALT
|
||||||
bool "Cobalt Server"
|
bool "Cobalt Server"
|
||||||
select DMA_NONCOHERENT
|
select DMA_NONCOHERENT
|
||||||
@@ -766,6 +776,7 @@
|
@@ -658,6 +668,7 @@
|
||||||
|
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
+source "arch/mips/atheros/Kconfig"
|
+source "arch/mips/atheros/Kconfig"
|
||||||
|
source "arch/mips/au1000/Kconfig"
|
||||||
source "arch/mips/ddb5xxx/Kconfig"
|
source "arch/mips/ddb5xxx/Kconfig"
|
||||||
source "arch/mips/gt64120/ev64120/Kconfig"
|
source "arch/mips/gt64120/ev64120/Kconfig"
|
||||||
source "arch/mips/jazz/Kconfig"
|
|
||||||
diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
|
diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
|
||||||
--- linux.old/arch/mips/Makefile 2007-02-02 23:55:52.913446632 +0100
|
--- linux.old/arch/mips/Makefile 2007-02-02 23:55:52.913446632 +0100
|
||||||
+++ linux.dev/arch/mips/Makefile 2007-02-03 17:40:29.193776000 +0100
|
+++ linux.dev/arch/mips/Makefile 2007-02-03 17:40:29.193776000 +0100
|
||||||
|
@ -46,7 +46,7 @@ diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
|
||||||
diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/bootinfo.h
|
diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/bootinfo.h
|
||||||
--- linux.old/include/asm-mips/bootinfo.h 2007-02-02 23:55:52.913446632 +0100
|
--- linux.old/include/asm-mips/bootinfo.h 2007-02-02 23:55:52.913446632 +0100
|
||||||
+++ linux.dev/include/asm-mips/bootinfo.h 2007-02-03 17:51:02.531494032 +0100
|
+++ linux.dev/include/asm-mips/bootinfo.h 2007-02-03 17:51:02.531494032 +0100
|
||||||
@@ -212,6 +212,18 @@
|
@@ -213,6 +213,18 @@
|
||||||
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
|
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
|
||||||
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
|
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
|
||||||
|
|
||||||
|
|
|
@ -1,23 +1,22 @@
|
||||||
diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kconfig
|
diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kconfig
|
||||||
--- linux.old/drivers/mtd/devices/Kconfig 2007-02-04 04:30:26.145338240 +0100
|
--- linux.old/drivers/mtd/devices/Kconfig 2007-02-04 04:30:26.145338240 +0100
|
||||||
+++ linux.dev/drivers/mtd/devices/Kconfig 2007-02-02 23:48:28.748969000 +0100
|
+++ linux.dev/drivers/mtd/devices/Kconfig 2007-02-02 23:48:28.748969000 +0100
|
||||||
@@ -68,6 +68,10 @@
|
@@ -76,6 +76,10 @@
|
||||||
used for program and data storage. Set up your spi devices
|
used for program and data storage. Set up your spi devices
|
||||||
with the right board-specific platform data.
|
with the right board-specific platform data.
|
||||||
|
|
||||||
+config MTD_SPIFLASH
|
+config MTD_SPIFLASH
|
||||||
+ tristate "Atheros AR2315/6/7 SPI Flash support"
|
+ tristate "Atheros AR2315/6/7 SPI Flash support"
|
||||||
+ depends on MTD && ATHEROS_AR5315
|
+ depends on ATHEROS_AR5315
|
||||||
+
|
+
|
||||||
config MTD_SLRAM
|
config MTD_SLRAM
|
||||||
tristate "Uncached system RAM"
|
tristate "Uncached system RAM"
|
||||||
depends on MTD
|
help
|
||||||
diff -urN linux.old/drivers/mtd/devices/Makefile linux.dev/drivers/mtd/devices/Makefile
|
diff -urN linux.old/drivers/mtd/devices/Makefile linux.dev/drivers/mtd/devices/Makefile
|
||||||
--- linux.old/drivers/mtd/devices/Makefile 2007-02-04 04:30:26.146338088 +0100
|
--- linux.old/drivers/mtd/devices/Makefile 2007-02-04 04:30:26.146338088 +0100
|
||||||
+++ linux.dev/drivers/mtd/devices/Makefile 2007-02-02 23:48:28.749969000 +0100
|
+++ linux.dev/drivers/mtd/devices/Makefile 2007-02-02 23:48:28.749969000 +0100
|
||||||
@@ -17,3 +17,4 @@
|
@@ -18,3 +18,4 @@
|
||||||
obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
|
|
||||||
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
|
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
|
||||||
|
obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o
|
||||||
obj-$(CONFIG_MTD_M25P80) += m25p80.o
|
obj-$(CONFIG_MTD_M25P80) += m25p80.o
|
||||||
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o
|
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o
|
||||||
|
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
diff -urN linux.old/drivers/net/wireless/Kconfig linux.dev/drivers/net/wireless/Kconfig
|
|
||||||
--- linux.old/drivers/net/wireless/Kconfig 2006-11-29 22:57:37.000000000 +0100
|
|
||||||
+++ linux.dev/drivers/net/wireless/Kconfig 2006-12-15 00:03:15.000000000 +0100
|
|
||||||
@@ -545,7 +545,7 @@
|
|
||||||
# yes, this works even when no drivers are selected
|
|
||||||
config NET_WIRELESS
|
|
||||||
bool
|
|
||||||
- depends on NET_RADIO && (ISA || PCI || PPC_PMAC || PCMCIA)
|
|
||||||
+ depends on NET_RADIO && (ISA || PCI || PPC_PMAC || PCMCIA || ATHEROS)
|
|
||||||
default y
|
|
||||||
|
|
||||||
endmenu
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
diff -urN linux.old/drivers/net/Kconfig linux.eth/drivers/net/Kconfig
|
diff -urN linux.old/drivers/net/Kconfig linux.eth/drivers/net/Kconfig
|
||||||
--- linux.old/drivers/net/Kconfig 2006-12-14 23:53:29.000000000 +0100
|
--- linux.old/drivers/net/Kconfig 2006-12-14 23:53:29.000000000 +0100
|
||||||
+++ linux.eth/drivers/net/Kconfig 2006-12-16 04:30:11.000000000 +0100
|
+++ linux.eth/drivers/net/Kconfig 2006-12-16 04:30:11.000000000 +0100
|
||||||
@@ -313,6 +313,12 @@
|
@@ -324,6 +324,12 @@
|
||||||
|
|
||||||
source "drivers/net/arm/Kconfig"
|
source "drivers/net/arm/Kconfig"
|
||||||
|
|
||||||
|
@ -17,9 +17,9 @@ diff -urN linux.old/drivers/net/Kconfig linux.eth/drivers/net/Kconfig
|
||||||
diff -urN linux.old/drivers/net/Makefile linux.eth/drivers/net/Makefile
|
diff -urN linux.old/drivers/net/Makefile linux.eth/drivers/net/Makefile
|
||||||
--- linux.old/drivers/net/Makefile 2006-12-14 23:53:29.000000000 +0100
|
--- linux.old/drivers/net/Makefile 2006-12-14 23:53:29.000000000 +0100
|
||||||
+++ linux.eth/drivers/net/Makefile 2006-12-16 04:30:11.000000000 +0100
|
+++ linux.eth/drivers/net/Makefile 2006-12-16 04:30:11.000000000 +0100
|
||||||
@@ -9,6 +9,7 @@
|
@@ -11,6 +11,7 @@
|
||||||
obj-$(CONFIG_EHEA) += ehea/
|
|
||||||
obj-$(CONFIG_BONDING) += bonding/
|
obj-$(CONFIG_BONDING) += bonding/
|
||||||
|
obj-$(CONFIG_ATL1) += atl1/
|
||||||
obj-$(CONFIG_GIANFAR) += gianfar_driver.o
|
obj-$(CONFIG_GIANFAR) += gianfar_driver.o
|
||||||
+obj-$(CONFIG_AR2313) += ar2313/
|
+obj-$(CONFIG_AR2313) += ar2313/
|
||||||
|
|
||||||
|
|
|
@ -9,7 +9,7 @@ diff -urN linux.old/drivers/mtd/redboot.c linux.dev/drivers/mtd/redboot.c
|
||||||
if ( directory < 0 )
|
if ( directory < 0 )
|
||||||
offset = master->size + directory*master->erasesize;
|
offset = master->size + directory*master->erasesize;
|
||||||
else
|
else
|
||||||
@@ -139,6 +140,11 @@
|
@@ -140,6 +141,11 @@
|
||||||
}
|
}
|
||||||
if (i == numslots) {
|
if (i == numslots) {
|
||||||
/* Didn't find it */
|
/* Didn't find it */
|
||||||
|
|
Loading…
Reference in New Issue