package/busybox: add upstream hush patch, bump release number

SVN-Revision: 21545
lede-17.01
Nicolas Thill 2010-05-23 14:00:43 +00:00
parent 7800ac4e58
commit cbdb520895
2 changed files with 12 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox PKG_NAME:=busybox
PKG_VERSION:=1.16.1 PKG_VERSION:=1.16.1
PKG_RELEASE:=6 PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \ PKG_SOURCE_URL:=http://www.busybox.net/downloads \

View File

@ -0,0 +1,11 @@
--- a/shell/hush.c
+++ b/shell/hush.c
@@ -6944,7 +6944,7 @@ int hush_main(int argc, char **argv)
/* -c 'script' (no params): prevent empty $0 */
G.global_argv--; /* points to argv[i] of 'script' */
G.global_argv[0] = argv[0];
- G.global_argc--;
+ G.global_argc++;
} /* else -c 'script' ARG0 [ARG1...]: $0 is ARG0 */
init_sigmasks();
parse_and_run_string(optarg);