mirror of https://github.com/hak5/openwrt.git
parent
557a3b5dd4
commit
cb9db16e2f
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zlib
|
PKG_NAME:=zlib
|
||||||
PKG_VERSION:=1.2.5
|
PKG_VERSION:=1.2.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://www.zlib.net @SF/libpng
|
PKG_SOURCE_URL:=http://www.zlib.net @SF/libpng
|
||||||
PKG_MD5SUM:=be1e89810e66150f5b0327984d8625a0
|
PKG_MD5SUM:=2ab442d169156f34c379c968f3f482dd
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -36,7 +36,7 @@ SHAREDLIBV=libz.so.1.2.5
|
|
||||||
SHAREDLIBM=libz.so.1
|
|
||||||
LIBS=$(STATICLIB) $(SHAREDLIBV)
|
|
||||||
|
|
||||||
-AR=ar rc
|
|
||||||
+AR=ar
|
|
||||||
RANLIB=ranlib
|
|
||||||
LDCONFIG=ldconfig
|
|
||||||
LDSHAREDLIBC=-lc
|
|
||||||
@@ -44,6 +44,8 @@ TAR=tar
|
|
||||||
SHELL=/bin/sh
|
|
||||||
EXE=
|
|
||||||
|
|
||||||
+DESTDIR =
|
|
||||||
+
|
|
||||||
prefix = /usr/local
|
|
||||||
exec_prefix = ${prefix}
|
|
||||||
libdir = ${exec_prefix}/lib
|
|
||||||
@@ -108,7 +110,7 @@ test64: all64
|
|
||||||
-@rm -f foo.gz
|
|
||||||
|
|
||||||
libz.a: $(OBJS)
|
|
||||||
- $(AR) $@ $(OBJS)
|
|
||||||
+ $(AR) rc $@ $(OBJS)
|
|
||||||
-@ ($(RANLIB) $@ || true) >/dev/null 2>&1
|
|
||||||
|
|
||||||
match.o: match.S
|
|
|
@ -1,48 +0,0 @@
|
||||||
--- a/zlib.h
|
|
||||||
+++ b/zlib.h
|
|
||||||
@@ -1563,12 +1563,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
|
|
||||||
* without large file support, _LFS64_LARGEFILE must also be true
|
|
||||||
*/
|
|
||||||
#if defined(_LARGEFILE64_SOURCE) && _LFS64_LARGEFILE-0
|
|
||||||
- ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
|
|
||||||
- ZEXTERN z_off64_t ZEXPORT gzseek64 OF((gzFile, z_off64_t, int));
|
|
||||||
- ZEXTERN z_off64_t ZEXPORT gztell64 OF((gzFile));
|
|
||||||
- ZEXTERN z_off64_t ZEXPORT gzoffset64 OF((gzFile));
|
|
||||||
- ZEXTERN uLong ZEXPORT adler32_combine64 OF((uLong, uLong, z_off64_t));
|
|
||||||
- ZEXTERN uLong ZEXPORT crc32_combine64 OF((uLong, uLong, z_off64_t));
|
|
||||||
+ #define __zlib_largefile64
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if !defined(ZLIB_INTERNAL) && _FILE_OFFSET_BITS-0 == 64 && _LFS64_LARGEFILE-0
|
|
||||||
@@ -1578,13 +1573,8 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
|
|
||||||
# define gzoffset gzoffset64
|
|
||||||
# define adler32_combine adler32_combine64
|
|
||||||
# define crc32_combine crc32_combine64
|
|
||||||
-# ifdef _LARGEFILE64_SOURCE
|
|
||||||
- ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
|
|
||||||
- ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
|
|
||||||
- ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));
|
|
||||||
- ZEXTERN z_off_t ZEXPORT gzoffset64 OF((gzFile));
|
|
||||||
- ZEXTERN uLong ZEXPORT adler32_combine64 OF((uLong, uLong, z_off_t));
|
|
||||||
- ZEXTERN uLong ZEXPORT crc32_combine64 OF((uLong, uLong, z_off_t));
|
|
||||||
+# ifndef __zlib_largefile64
|
|
||||||
+# define __zlib_largefile64
|
|
||||||
# endif
|
|
||||||
#else
|
|
||||||
ZEXTERN gzFile ZEXPORT gzopen OF((const char *, const char *));
|
|
||||||
@@ -1595,6 +1585,15 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
|
|
||||||
ZEXTERN uLong ZEXPORT crc32_combine OF((uLong, uLong, z_off_t));
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#ifdef __zlib_largefile64
|
|
||||||
+ ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
|
|
||||||
+ ZEXTERN z_off64_t ZEXPORT gzseek64 OF((gzFile, z_off64_t, int));
|
|
||||||
+ ZEXTERN z_off64_t ZEXPORT gztell64 OF((gzFile));
|
|
||||||
+ ZEXTERN z_off64_t ZEXPORT gzoffset64 OF((gzFile));
|
|
||||||
+ ZEXTERN uLong ZEXPORT adler32_combine64 OF((uLong, uLong, z_off64_t));
|
|
||||||
+ ZEXTERN uLong ZEXPORT crc32_combine64 OF((uLong, uLong, z_off64_t));
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/* hack for buggy compilers */
|
|
||||||
#if !defined(ZUTIL_H) && !defined(NO_DUMMY_DECL)
|
|
||||||
struct internal_state {int dummy;};
|
|
Loading…
Reference in New Issue