mirror of https://github.com/hak5/openwrt.git
kernel: bump 4.9 to 4.9.110 for 18.06
Compile-tested on ar71xx. Signed-off-by: Stijn Segers <foss@volatilesystems.org>openwrt-18.06
parent
1961cdfb57
commit
c96b344466
|
@ -4,12 +4,12 @@ LINUX_RELEASE?=1
|
|||
|
||||
LINUX_VERSION-3.18 = .71
|
||||
LINUX_VERSION-4.4 = .121
|
||||
LINUX_VERSION-4.9 = .109
|
||||
LINUX_VERSION-4.9 = .110
|
||||
LINUX_VERSION-4.14 = .50
|
||||
|
||||
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
|
||||
LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
|
||||
LINUX_KERNEL_HASH-4.9.109 = 3dcd5654a553432119492b69e649c4ed117781bfd571edcb02346c945be359b0
|
||||
LINUX_KERNEL_HASH-4.9.110 = 379a143a70a79f0eea6c9f6638942b65e6043abdde17ad23264c0abd93c4ea7a
|
||||
LINUX_KERNEL_HASH-4.14.50 = 703a8d013b25dc428d936f72858fa0c702c22cb3114a040fb9bb47562e4ea2ac
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Makefile
|
||||
+++ b/arch/mips/Makefile
|
||||
@@ -213,6 +213,7 @@ cflags-$(toolchain-virt) += -DTOOLCHAIN
|
||||
@@ -218,6 +218,7 @@ cflags-$(toolchain-virt) += -DTOOLCHAIN
|
||||
#
|
||||
libs-$(CONFIG_FW_ARC) += arch/mips/fw/arc/
|
||||
libs-$(CONFIG_FW_CFE) += arch/mips/fw/cfe/
|
||||
|
|
|
@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/arch/mips/Makefile
|
||||
+++ b/arch/mips/Makefile
|
||||
@@ -148,7 +148,7 @@ cflags-$(CONFIG_CPU_R4X00) += -march=r46
|
||||
@@ -153,7 +153,7 @@ cflags-$(CONFIG_CPU_R4X00) += -march=r46
|
||||
cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap
|
||||
cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
|
||||
-Wa,-mips32 -Wa,--trap
|
||||
|
|
|
@ -141,7 +141,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
static const struct rt6_info ip6_blk_hole_entry_template = {
|
||||
.dst = {
|
||||
.__refcnt = ATOMIC_INIT(1),
|
||||
@@ -1970,6 +1987,11 @@ static struct rt6_info *ip6_route_info_c
|
||||
@@ -1967,6 +1984,11 @@ static struct rt6_info *ip6_route_info_c
|
||||
rt->dst.output = ip6_pkt_prohibit_out;
|
||||
rt->dst.input = ip6_pkt_prohibit;
|
||||
break;
|
||||
|
@ -153,7 +153,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
case RTN_THROW:
|
||||
case RTN_UNREACHABLE:
|
||||
default:
|
||||
@@ -2613,6 +2635,17 @@ static int ip6_pkt_prohibit_out(struct n
|
||||
@@ -2610,6 +2632,17 @@ static int ip6_pkt_prohibit_out(struct n
|
||||
return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
|
||||
}
|
||||
|
||||
|
@ -171,7 +171,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
/*
|
||||
* Allocate a dst for local (unicast / anycast) address.
|
||||
*/
|
||||
@@ -2850,7 +2883,8 @@ static int rtm_to_fib6_config(struct sk_
|
||||
@@ -2847,7 +2880,8 @@ static int rtm_to_fib6_config(struct sk_
|
||||
if (rtm->rtm_type == RTN_UNREACHABLE ||
|
||||
rtm->rtm_type == RTN_BLACKHOLE ||
|
||||
rtm->rtm_type == RTN_PROHIBIT ||
|
||||
|
@ -181,7 +181,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
cfg->fc_flags |= RTF_REJECT;
|
||||
|
||||
if (rtm->rtm_type == RTN_LOCAL)
|
||||
@@ -3222,6 +3256,9 @@ static int rt6_fill_node(struct net *net
|
||||
@@ -3219,6 +3253,9 @@ static int rt6_fill_node(struct net *net
|
||||
case -EACCES:
|
||||
rtm->rtm_type = RTN_PROHIBIT;
|
||||
break;
|
||||
|
@ -191,7 +191,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
case -EAGAIN:
|
||||
rtm->rtm_type = RTN_THROW;
|
||||
break;
|
||||
@@ -3498,6 +3535,8 @@ static int ip6_route_dev_notify(struct n
|
||||
@@ -3495,6 +3532,8 @@ static int ip6_route_dev_notify(struct n
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
net->ipv6.ip6_prohibit_entry->dst.dev = dev;
|
||||
net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
|
||||
|
@ -200,7 +200,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
|
||||
net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
|
||||
#endif
|
||||
@@ -3509,6 +3548,7 @@ static int ip6_route_dev_notify(struct n
|
||||
@@ -3506,6 +3545,7 @@ static int ip6_route_dev_notify(struct n
|
||||
in6_dev_put(net->ipv6.ip6_null_entry->rt6i_idev);
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
in6_dev_put(net->ipv6.ip6_prohibit_entry->rt6i_idev);
|
||||
|
@ -208,7 +208,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
in6_dev_put(net->ipv6.ip6_blk_hole_entry->rt6i_idev);
|
||||
#endif
|
||||
}
|
||||
@@ -3724,6 +3764,17 @@ static int __net_init ip6_route_net_init
|
||||
@@ -3721,6 +3761,17 @@ static int __net_init ip6_route_net_init
|
||||
net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
|
||||
dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
|
||||
ip6_template_metrics, true);
|
||||
|
@ -226,7 +226,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
#endif
|
||||
|
||||
net->ipv6.sysctl.flush_delay = 0;
|
||||
@@ -3742,6 +3793,8 @@ out:
|
||||
@@ -3739,6 +3790,8 @@ out:
|
||||
return ret;
|
||||
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
|
@ -235,7 +235,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
out_ip6_prohibit_entry:
|
||||
kfree(net->ipv6.ip6_prohibit_entry);
|
||||
out_ip6_null_entry:
|
||||
@@ -3759,6 +3812,7 @@ static void __net_exit ip6_route_net_exi
|
||||
@@ -3756,6 +3809,7 @@ static void __net_exit ip6_route_net_exi
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
kfree(net->ipv6.ip6_prohibit_entry);
|
||||
kfree(net->ipv6.ip6_blk_hole_entry);
|
||||
|
@ -243,7 +243,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
#endif
|
||||
dst_entries_destroy(&net->ipv6.ip6_dst_ops);
|
||||
}
|
||||
@@ -3832,6 +3886,9 @@ void __init ip6_route_init_special_entri
|
||||
@@ -3829,6 +3883,9 @@ void __init ip6_route_init_special_entri
|
||||
init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
||||
init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
|
||||
init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
||||
|
|
|
@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|||
/**
|
||||
* ata_build_rw_tf - Build ATA taskfile for given read/write request
|
||||
* @tf: Target ATA taskfile
|
||||
@@ -4994,6 +5007,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||
@@ -4991,6 +5004,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||
if (tag < 0)
|
||||
return NULL;
|
||||
}
|
||||
|
@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|||
|
||||
qc = __ata_qc_from_tag(ap, tag);
|
||||
qc->tag = tag;
|
||||
@@ -5895,6 +5911,9 @@ struct ata_port *ata_port_alloc(struct a
|
||||
@@ -5892,6 +5908,9 @@ struct ata_port *ata_port_alloc(struct a
|
||||
ap->stats.unhandled_irq = 1;
|
||||
ap->stats.idle_irq = 1;
|
||||
#endif
|
||||
|
@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|||
ata_sff_port_init(ap);
|
||||
|
||||
return ap;
|
||||
@@ -5916,6 +5935,12 @@ static void ata_host_release(struct devi
|
||||
@@ -5913,6 +5932,12 @@ static void ata_host_release(struct devi
|
||||
|
||||
kfree(ap->pmp_link);
|
||||
kfree(ap->slave_link);
|
||||
|
@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|||
kfree(ap);
|
||||
host->ports[i] = NULL;
|
||||
}
|
||||
@@ -6362,7 +6387,23 @@ int ata_host_register(struct ata_host *h
|
||||
@@ -6359,7 +6384,23 @@ int ata_host_register(struct ata_host *h
|
||||
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
|
||||
host->ports[i]->local_port_no = i + 1;
|
||||
}
|
||||
|
|
|
@ -3095,7 +3095,7 @@
|
|||
|
||||
if (priv->hw->mode->set_16kib_bfsize)
|
||||
bfsize = priv->hw->mode->set_16kib_bfsize(dev->mtu);
|
||||
@@ -1033,257 +1234,516 @@ static int init_dma_desc_rings(struct ne
|
||||
@@ -1033,235 +1234,409 @@ static int init_dma_desc_rings(struct ne
|
||||
|
||||
priv->dma_buf_sz = bfsize;
|
||||
|
||||
|
@ -3351,10 +3351,17 @@
|
|||
- priv->tx_skbuff_dma[i].buf,
|
||||
- priv->tx_skbuff_dma[i].len,
|
||||
- DMA_TO_DEVICE);
|
||||
- }
|
||||
+ for (i = 0; i < DMA_TX_SIZE; i++)
|
||||
+ stmmac_free_tx_buffer(priv, queue, i);
|
||||
+}
|
||||
+
|
||||
|
||||
- if (priv->tx_skbuff[i]) {
|
||||
- dev_kfree_skb_any(priv->tx_skbuff[i]);
|
||||
- priv->tx_skbuff[i] = NULL;
|
||||
- priv->tx_skbuff_dma[i].buf = 0;
|
||||
- priv->tx_skbuff_dma[i].map_as_page = false;
|
||||
- }
|
||||
+/**
|
||||
+ * free_dma_rx_desc_resources - free RX dma desc resources
|
||||
+ * @priv: private structure
|
||||
|
@ -3383,10 +3390,11 @@
|
|||
+
|
||||
+ kfree(rx_q->rx_skbuff_dma);
|
||||
+ kfree(rx_q->rx_skbuff);
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
}
|
||||
}
|
||||
|
||||
/**
|
||||
- * alloc_dma_desc_resources - alloc TX/RX resources.
|
||||
+ * free_dma_tx_desc_resources - free TX dma desc resources
|
||||
+ * @priv: private structure
|
||||
+ */
|
||||
|
@ -3419,36 +3427,90 @@
|
|||
+
|
||||
+/**
|
||||
+ * alloc_dma_rx_desc_resources - alloc RX resources.
|
||||
+ * @priv: private structure
|
||||
+ * Description: according to which descriptor can be used (extend or basic)
|
||||
+ * this function allocates the resources for TX and RX paths. In case of
|
||||
+ * reception, for example, it pre-allocated the RX socket buffer in order to
|
||||
+ * allow zero-copy mechanism.
|
||||
+ */
|
||||
* @priv: private structure
|
||||
* Description: according to which descriptor can be used (extend or basic)
|
||||
* this function allocates the resources for TX and RX paths. In case of
|
||||
* reception, for example, it pre-allocated the RX socket buffer in order to
|
||||
* allow zero-copy mechanism.
|
||||
*/
|
||||
-static int alloc_dma_desc_resources(struct stmmac_priv *priv)
|
||||
+static int alloc_dma_rx_desc_resources(struct stmmac_priv *priv)
|
||||
+{
|
||||
{
|
||||
+ u32 rx_count = priv->plat->rx_queues_to_use;
|
||||
+ int ret = -ENOMEM;
|
||||
int ret = -ENOMEM;
|
||||
+ u32 queue;
|
||||
+
|
||||
|
||||
- priv->rx_skbuff_dma = kmalloc_array(DMA_RX_SIZE, sizeof(dma_addr_t),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->rx_skbuff_dma)
|
||||
- return -ENOMEM;
|
||||
+ /* RX queues buffers and DMA */
|
||||
+ for (queue = 0; queue < rx_count; queue++) {
|
||||
+ struct stmmac_rx_queue *rx_q = &priv->rx_queue[queue];
|
||||
+
|
||||
|
||||
- priv->rx_skbuff = kmalloc_array(DMA_RX_SIZE, sizeof(struct sk_buff *),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->rx_skbuff)
|
||||
- goto err_rx_skbuff;
|
||||
-
|
||||
- priv->tx_skbuff_dma = kmalloc_array(DMA_TX_SIZE,
|
||||
- sizeof(*priv->tx_skbuff_dma),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->tx_skbuff_dma)
|
||||
- goto err_tx_skbuff_dma;
|
||||
-
|
||||
- priv->tx_skbuff = kmalloc_array(DMA_TX_SIZE, sizeof(struct sk_buff *),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->tx_skbuff)
|
||||
- goto err_tx_skbuff;
|
||||
-
|
||||
- if (priv->extend_desc) {
|
||||
- priv->dma_erx = dma_zalloc_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct
|
||||
- dma_extended_desc),
|
||||
- &priv->dma_rx_phy,
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->dma_erx)
|
||||
- goto err_dma;
|
||||
+ rx_q->queue_index = queue;
|
||||
+ rx_q->priv_data = priv;
|
||||
+
|
||||
|
||||
- priv->dma_etx = dma_zalloc_coherent(priv->device, DMA_TX_SIZE *
|
||||
- sizeof(struct
|
||||
- dma_extended_desc),
|
||||
- &priv->dma_tx_phy,
|
||||
+ rx_q->rx_skbuff_dma = kmalloc_array(DMA_RX_SIZE,
|
||||
+ sizeof(dma_addr_t),
|
||||
+ GFP_KERNEL);
|
||||
GFP_KERNEL);
|
||||
- if (!priv->dma_etx) {
|
||||
- dma_free_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct dma_extended_desc),
|
||||
- priv->dma_erx, priv->dma_rx_phy);
|
||||
- goto err_dma;
|
||||
- }
|
||||
- } else {
|
||||
- priv->dma_rx = dma_zalloc_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct dma_desc),
|
||||
- &priv->dma_rx_phy,
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->dma_rx)
|
||||
- goto err_dma;
|
||||
+ if (!rx_q->rx_skbuff_dma)
|
||||
+ return -ENOMEM;
|
||||
+
|
||||
|
||||
- priv->dma_tx = dma_zalloc_coherent(priv->device, DMA_TX_SIZE *
|
||||
- sizeof(struct dma_desc),
|
||||
- &priv->dma_tx_phy,
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->dma_tx) {
|
||||
- dma_free_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct dma_desc),
|
||||
- priv->dma_rx, priv->dma_rx_phy);
|
||||
+ rx_q->rx_skbuff = kmalloc_array(DMA_RX_SIZE,
|
||||
+ sizeof(struct sk_buff *),
|
||||
+ GFP_KERNEL);
|
||||
+ if (!rx_q->rx_skbuff)
|
||||
+ goto err_dma;
|
||||
goto err_dma;
|
||||
+
|
||||
+ if (priv->extend_desc) {
|
||||
+ rx_q->dma_erx = dma_zalloc_coherent(priv->device,
|
||||
|
@ -3469,12 +3531,19 @@
|
|||
+ GFP_KERNEL);
|
||||
+ if (!rx_q->dma_rx)
|
||||
+ goto err_dma;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ return 0;
|
||||
+
|
||||
+err_dma:
|
||||
}
|
||||
}
|
||||
|
||||
return 0;
|
||||
|
||||
err_dma:
|
||||
- kfree(priv->tx_skbuff);
|
||||
-err_tx_skbuff:
|
||||
- kfree(priv->tx_skbuff_dma);
|
||||
-err_tx_skbuff_dma:
|
||||
- kfree(priv->rx_skbuff);
|
||||
-err_rx_skbuff:
|
||||
- kfree(priv->rx_skbuff_dma);
|
||||
+ free_dma_rx_desc_resources(priv);
|
||||
+
|
||||
+ return ret;
|
||||
|
@ -3531,7 +3600,7 @@
|
|||
+ GFP_KERNEL);
|
||||
+ if (!tx_q->dma_tx)
|
||||
+ goto err_dma_buffers;
|
||||
}
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ return 0;
|
||||
|
@ -3560,183 +3629,14 @@
|
|||
+
|
||||
+ ret = alloc_dma_tx_desc_resources(priv);
|
||||
+
|
||||
+ return ret;
|
||||
+}
|
||||
+
|
||||
return ret;
|
||||
}
|
||||
|
||||
+/**
|
||||
+ * free_dma_desc_resources - free dma desc resources
|
||||
+ * @priv: private structure
|
||||
+ */
|
||||
+static void free_dma_desc_resources(struct stmmac_priv *priv)
|
||||
+{
|
||||
+ /* Release the DMA RX socket buffers */
|
||||
+ free_dma_rx_desc_resources(priv);
|
||||
+
|
||||
+ /* Release the DMA TX socket buffers */
|
||||
+ free_dma_tx_desc_resources(priv);
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
+ * stmmac_mac_enable_rx_queues - Enable MAC rx queues
|
||||
+ * @priv: driver private structure
|
||||
+ * Description: It is used for enabling the rx queues in the MAC
|
||||
+ */
|
||||
+static void stmmac_mac_enable_rx_queues(struct stmmac_priv *priv)
|
||||
+{
|
||||
+ u32 rx_queues_count = priv->plat->rx_queues_to_use;
|
||||
+ int queue;
|
||||
+ u8 mode;
|
||||
|
||||
- if (priv->tx_skbuff[i]) {
|
||||
- dev_kfree_skb_any(priv->tx_skbuff[i]);
|
||||
- priv->tx_skbuff[i] = NULL;
|
||||
- priv->tx_skbuff_dma[i].buf = 0;
|
||||
- priv->tx_skbuff_dma[i].map_as_page = false;
|
||||
- }
|
||||
+ for (queue = 0; queue < rx_queues_count; queue++) {
|
||||
+ mode = priv->plat->rx_queues_cfg[queue].mode_to_use;
|
||||
+ priv->hw->mac->rx_queue_enable(priv->hw, mode, queue);
|
||||
}
|
||||
}
|
||||
|
||||
/**
|
||||
- * alloc_dma_desc_resources - alloc TX/RX resources.
|
||||
- * @priv: private structure
|
||||
- * Description: according to which descriptor can be used (extend or basic)
|
||||
- * this function allocates the resources for TX and RX paths. In case of
|
||||
- * reception, for example, it pre-allocated the RX socket buffer in order to
|
||||
- * allow zero-copy mechanism.
|
||||
+ * stmmac_start_rx_dma - start RX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: RX channel index
|
||||
+ * Description:
|
||||
+ * This starts a RX DMA channel
|
||||
*/
|
||||
-static int alloc_dma_desc_resources(struct stmmac_priv *priv)
|
||||
+static void stmmac_start_rx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
{
|
||||
- int ret = -ENOMEM;
|
||||
-
|
||||
- priv->rx_skbuff_dma = kmalloc_array(DMA_RX_SIZE, sizeof(dma_addr_t),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->rx_skbuff_dma)
|
||||
- return -ENOMEM;
|
||||
-
|
||||
- priv->rx_skbuff = kmalloc_array(DMA_RX_SIZE, sizeof(struct sk_buff *),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->rx_skbuff)
|
||||
- goto err_rx_skbuff;
|
||||
-
|
||||
- priv->tx_skbuff_dma = kmalloc_array(DMA_TX_SIZE,
|
||||
- sizeof(*priv->tx_skbuff_dma),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->tx_skbuff_dma)
|
||||
- goto err_tx_skbuff_dma;
|
||||
-
|
||||
- priv->tx_skbuff = kmalloc_array(DMA_TX_SIZE, sizeof(struct sk_buff *),
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->tx_skbuff)
|
||||
- goto err_tx_skbuff;
|
||||
-
|
||||
- if (priv->extend_desc) {
|
||||
- priv->dma_erx = dma_zalloc_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct
|
||||
- dma_extended_desc),
|
||||
- &priv->dma_rx_phy,
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->dma_erx)
|
||||
- goto err_dma;
|
||||
-
|
||||
- priv->dma_etx = dma_zalloc_coherent(priv->device, DMA_TX_SIZE *
|
||||
- sizeof(struct
|
||||
- dma_extended_desc),
|
||||
- &priv->dma_tx_phy,
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->dma_etx) {
|
||||
- dma_free_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct dma_extended_desc),
|
||||
- priv->dma_erx, priv->dma_rx_phy);
|
||||
- goto err_dma;
|
||||
- }
|
||||
- } else {
|
||||
- priv->dma_rx = dma_zalloc_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct dma_desc),
|
||||
- &priv->dma_rx_phy,
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->dma_rx)
|
||||
- goto err_dma;
|
||||
+ netdev_dbg(priv->dev, "DMA RX processes started in channel %d\n", chan);
|
||||
+ priv->hw->dma->start_rx(priv->ioaddr, chan);
|
||||
+}
|
||||
|
||||
- priv->dma_tx = dma_zalloc_coherent(priv->device, DMA_TX_SIZE *
|
||||
- sizeof(struct dma_desc),
|
||||
- &priv->dma_tx_phy,
|
||||
- GFP_KERNEL);
|
||||
- if (!priv->dma_tx) {
|
||||
- dma_free_coherent(priv->device, DMA_RX_SIZE *
|
||||
- sizeof(struct dma_desc),
|
||||
- priv->dma_rx, priv->dma_rx_phy);
|
||||
- goto err_dma;
|
||||
- }
|
||||
- }
|
||||
+/**
|
||||
+ * stmmac_start_tx_dma - start TX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: TX channel index
|
||||
+ * Description:
|
||||
+ * This starts a TX DMA channel
|
||||
+ */
|
||||
+static void stmmac_start_tx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
+{
|
||||
+ netdev_dbg(priv->dev, "DMA TX processes started in channel %d\n", chan);
|
||||
+ priv->hw->dma->start_tx(priv->ioaddr, chan);
|
||||
+}
|
||||
|
||||
- return 0;
|
||||
+/**
|
||||
+ * stmmac_stop_rx_dma - stop RX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: RX channel index
|
||||
+ * Description:
|
||||
+ * This stops a RX DMA channel
|
||||
+ */
|
||||
+static void stmmac_stop_rx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
+{
|
||||
+ netdev_dbg(priv->dev, "DMA RX processes stopped in channel %d\n", chan);
|
||||
+ priv->hw->dma->stop_rx(priv->ioaddr, chan);
|
||||
+}
|
||||
|
||||
-err_dma:
|
||||
- kfree(priv->tx_skbuff);
|
||||
-err_tx_skbuff:
|
||||
- kfree(priv->tx_skbuff_dma);
|
||||
-err_tx_skbuff_dma:
|
||||
- kfree(priv->rx_skbuff);
|
||||
-err_rx_skbuff:
|
||||
- kfree(priv->rx_skbuff_dma);
|
||||
- return ret;
|
||||
+/**
|
||||
+ * stmmac_stop_tx_dma - stop TX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: TX channel index
|
||||
+ * Description:
|
||||
+ * This stops a TX DMA channel
|
||||
+ */
|
||||
+static void stmmac_stop_tx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
+{
|
||||
+ netdev_dbg(priv->dev, "DMA TX processes stopped in channel %d\n", chan);
|
||||
+ priv->hw->dma->stop_tx(priv->ioaddr, chan);
|
||||
}
|
||||
|
||||
-static void free_dma_desc_resources(struct stmmac_priv *priv)
|
||||
+/**
|
||||
+ * stmmac_start_all_dma - start all RX and TX DMA channels
|
||||
+ * @priv: driver private structure
|
||||
+ * Description:
|
||||
+ * This starts all the RX and TX DMA channels
|
||||
+ */
|
||||
+static void stmmac_start_all_dma(struct stmmac_priv *priv)
|
||||
static void free_dma_desc_resources(struct stmmac_priv *priv)
|
||||
{
|
||||
- /* Release the DMA TX/RX socket buffers */
|
||||
- dma_free_rx_skbufs(priv);
|
||||
|
@ -3762,6 +3662,99 @@
|
|||
- kfree(priv->rx_skbuff);
|
||||
- kfree(priv->tx_skbuff_dma);
|
||||
- kfree(priv->tx_skbuff);
|
||||
+ /* Release the DMA RX socket buffers */
|
||||
+ free_dma_rx_desc_resources(priv);
|
||||
+
|
||||
+ /* Release the DMA TX socket buffers */
|
||||
+ free_dma_tx_desc_resources(priv);
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -1271,19 +1646,104 @@ static void free_dma_desc_resources(stru
|
||||
*/
|
||||
static void stmmac_mac_enable_rx_queues(struct stmmac_priv *priv)
|
||||
{
|
||||
- int rx_count = priv->dma_cap.number_rx_queues;
|
||||
- int queue = 0;
|
||||
+ u32 rx_queues_count = priv->plat->rx_queues_to_use;
|
||||
+ int queue;
|
||||
+ u8 mode;
|
||||
|
||||
- /* If GMAC does not have multiple queues, then this is not necessary*/
|
||||
- if (rx_count == 1)
|
||||
- return;
|
||||
+ for (queue = 0; queue < rx_queues_count; queue++) {
|
||||
+ mode = priv->plat->rx_queues_cfg[queue].mode_to_use;
|
||||
+ priv->hw->mac->rx_queue_enable(priv->hw, mode, queue);
|
||||
+ }
|
||||
+}
|
||||
|
||||
- /**
|
||||
- * If the core is synthesized with multiple rx queues / multiple
|
||||
- * dma channels, then rx queues will be disabled by default.
|
||||
- * For now only rx queue 0 is enabled.
|
||||
- */
|
||||
- priv->hw->mac->rx_queue_enable(priv->hw, queue);
|
||||
+/**
|
||||
+ * stmmac_start_rx_dma - start RX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: RX channel index
|
||||
+ * Description:
|
||||
+ * This starts a RX DMA channel
|
||||
+ */
|
||||
+static void stmmac_start_rx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
+{
|
||||
+ netdev_dbg(priv->dev, "DMA RX processes started in channel %d\n", chan);
|
||||
+ priv->hw->dma->start_rx(priv->ioaddr, chan);
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
+ * stmmac_start_tx_dma - start TX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: TX channel index
|
||||
+ * Description:
|
||||
+ * This starts a TX DMA channel
|
||||
+ */
|
||||
+static void stmmac_start_tx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
+{
|
||||
+ netdev_dbg(priv->dev, "DMA TX processes started in channel %d\n", chan);
|
||||
+ priv->hw->dma->start_tx(priv->ioaddr, chan);
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
+ * stmmac_stop_rx_dma - stop RX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: RX channel index
|
||||
+ * Description:
|
||||
+ * This stops a RX DMA channel
|
||||
+ */
|
||||
+static void stmmac_stop_rx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
+{
|
||||
+ netdev_dbg(priv->dev, "DMA RX processes stopped in channel %d\n", chan);
|
||||
+ priv->hw->dma->stop_rx(priv->ioaddr, chan);
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
+ * stmmac_stop_tx_dma - stop TX DMA channel
|
||||
+ * @priv: driver private structure
|
||||
+ * @chan: TX channel index
|
||||
+ * Description:
|
||||
+ * This stops a TX DMA channel
|
||||
+ */
|
||||
+static void stmmac_stop_tx_dma(struct stmmac_priv *priv, u32 chan)
|
||||
+{
|
||||
+ netdev_dbg(priv->dev, "DMA TX processes stopped in channel %d\n", chan);
|
||||
+ priv->hw->dma->stop_tx(priv->ioaddr, chan);
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
+ * stmmac_start_all_dma - start all RX and TX DMA channels
|
||||
+ * @priv: driver private structure
|
||||
+ * Description:
|
||||
+ * This starts all the RX and TX DMA channels
|
||||
+ */
|
||||
+static void stmmac_start_all_dma(struct stmmac_priv *priv)
|
||||
+{
|
||||
+ u32 rx_channels_count = priv->plat->rx_queues_to_use;
|
||||
+ u32 tx_channels_count = priv->plat->tx_queues_to_use;
|
||||
+ u32 chan = 0;
|
||||
|
@ -3771,38 +3764,23 @@
|
|||
+
|
||||
+ for (chan = 0; chan < tx_channels_count; chan++)
|
||||
+ stmmac_start_tx_dma(priv, chan);
|
||||
}
|
||||
|
||||
/**
|
||||
- * stmmac_mac_enable_rx_queues - Enable MAC rx queues
|
||||
- * @priv: driver private structure
|
||||
- * Description: It is used for enabling the rx queues in the MAC
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
+ * stmmac_stop_all_dma - stop all RX and TX DMA channels
|
||||
+ * @priv: driver private structure
|
||||
+ * Description:
|
||||
+ * This stops the RX and TX DMA channels
|
||||
*/
|
||||
-static void stmmac_mac_enable_rx_queues(struct stmmac_priv *priv)
|
||||
+ */
|
||||
+static void stmmac_stop_all_dma(struct stmmac_priv *priv)
|
||||
{
|
||||
- int rx_count = priv->dma_cap.number_rx_queues;
|
||||
- int queue = 0;
|
||||
+{
|
||||
+ u32 rx_channels_count = priv->plat->rx_queues_to_use;
|
||||
+ u32 tx_channels_count = priv->plat->tx_queues_to_use;
|
||||
+ u32 chan = 0;
|
||||
|
||||
- /* If GMAC does not have multiple queues, then this is not necessary*/
|
||||
- if (rx_count == 1)
|
||||
- return;
|
||||
+
|
||||
+ for (chan = 0; chan < rx_channels_count; chan++)
|
||||
+ stmmac_stop_rx_dma(priv, chan);
|
||||
|
||||
- /**
|
||||
- * If the core is synthesized with multiple rx queues / multiple
|
||||
- * dma channels, then rx queues will be disabled by default.
|
||||
- * For now only rx queue 0 is enabled.
|
||||
- */
|
||||
- priv->hw->mac->rx_queue_enable(priv->hw, queue);
|
||||
+
|
||||
+ for (chan = 0; chan < tx_channels_count; chan++)
|
||||
+ stmmac_stop_tx_dma(priv, chan);
|
||||
}
|
||||
|
|
Loading…
Reference in New Issue