mirror of https://github.com/hak5/openwrt.git
libjson-c: update to 0.15
Drop patches as they've been upstreamed: * 001-Fix-CVE-2020-12762.patch Refresh patches: * 000-libm.patch Add patch to avoid build failure due to missing docs in tarball. Signed-off-by: David Bauer <mail@david-bauer.net>master
parent
056945faa4
commit
c2e75017a2
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=json-c
|
||||
PKG_VERSION:=0.14
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.15
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
|
||||
PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
|
||||
PKG_HASH:=99914e644a25201d82ccefa20430f7515c110923360f9ef46755527c02412afa
|
||||
PKG_HASH:=99bca4f944b8ced8ae0bbc6310d6a3528ca715e69541793a1ef51f8c5b4b0878
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=MIT
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/math_compat.h
|
||||
+++ b/math_compat.h
|
||||
@@ -6,31 +6,9 @@
|
||||
@@ -6,38 +6,9 @@
|
||||
* @brief Do not use, json-c internal, may be changed or removed at any time.
|
||||
*/
|
||||
|
||||
|
@ -10,6 +10,9 @@
|
|||
-#ifdef HAVE_DECL__ISNAN
|
||||
-#include <float.h>
|
||||
-#define isnan(x) _isnan(x)
|
||||
-#else
|
||||
-/* On platforms like AIX and "IBM i" we need to provide our own isnan */
|
||||
-#define isnan(x) ((x) != (x))
|
||||
-#endif
|
||||
-#endif
|
||||
-
|
||||
|
@ -17,6 +20,10 @@
|
|||
-#ifdef HAVE_DECL__FINITE
|
||||
-#include <float.h>
|
||||
-#define isinf(x) (!_finite(x))
|
||||
-#else
|
||||
-#include <float.h>
|
||||
-/* On platforms like AIX and "IBM i" we need to provide our own isinf */
|
||||
-#define isinf(x) ((x) < -DBL_MAX || (x) > DBL_MAX)
|
||||
-#endif
|
||||
-#endif
|
||||
-
|
||||
|
|
File diff suppressed because one or more lines are too long
|
@ -0,0 +1,11 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -401,8 +401,6 @@ set(JSON_C_SOURCES
|
||||
include_directories(${PROJECT_SOURCE_DIR})
|
||||
include_directories(${PROJECT_BINARY_DIR})
|
||||
|
||||
-add_subdirectory(doc)
|
||||
-
|
||||
# uninstall
|
||||
add_custom_target(uninstall
|
||||
COMMAND cat ${PROJECT_BINARY_DIR}/install_manifest.txt | xargs rm
|
Loading…
Reference in New Issue