mirror of https://github.com/hak5/openwrt.git
parent
f86e412389
commit
c1dc6df8bd
|
@ -35,8 +35,8 @@ endif
|
||||||
ifeq ($(LINUX_VERSION),3.1.10)
|
ifeq ($(LINUX_VERSION),3.1.10)
|
||||||
LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
|
LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.2.9)
|
ifeq ($(LINUX_VERSION),3.2.12)
|
||||||
LINUX_KERNEL_MD5SUM:=f6c2ede7c6df0f62c8fbf7932ccf63b6
|
LINUX_KERNEL_MD5SUM:=e3dd3772f0cf14d444a3fb474bd624fe
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
SUBTARGETS:=generic nand
|
SUBTARGETS:=generic nand
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
|
||||||
SUBTARGETS=au1500 au1550
|
SUBTARGETS=au1500 au1550
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
||||||
BOARDNAME:=Broadcom BCM947xx/953xx
|
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||||
FEATURES:=squashfs usb pcmcia
|
FEATURES:=squashfs usb pcmcia
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
||||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
||||||
FEATURES:=squashfs broken
|
FEATURES:=squashfs broken
|
||||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
|
||||||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -106,8 +106,8 @@
|
||||||
{
|
{
|
||||||
--- a/fs/partitions/check.c
|
--- a/fs/partitions/check.c
|
||||||
+++ b/fs/partitions/check.c
|
+++ b/fs/partitions/check.c
|
||||||
@@ -664,6 +664,7 @@ rescan:
|
@@ -696,6 +696,7 @@ int invalidate_partitions(struct gendisk
|
||||||
kfree(state);
|
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
+EXPORT_SYMBOL(rescan_partitions);
|
+EXPORT_SYMBOL(rescan_partitions);
|
||||||
|
|
|
@ -32,7 +32,7 @@
|
||||||
+obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_stubs.o
|
+obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_stubs.o
|
||||||
--- a/net/ipv6/addrconf.c
|
--- a/net/ipv6/addrconf.c
|
||||||
+++ b/net/ipv6/addrconf.c
|
+++ b/net/ipv6/addrconf.c
|
||||||
@@ -1107,7 +1107,7 @@ out:
|
@@ -1111,7 +1111,7 @@ out:
|
||||||
return ret;
|
return ret;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -41,7 +41,7 @@
|
||||||
const struct in6_addr *daddr, unsigned int prefs,
|
const struct in6_addr *daddr, unsigned int prefs,
|
||||||
struct in6_addr *saddr)
|
struct in6_addr *saddr)
|
||||||
{
|
{
|
||||||
@@ -1232,7 +1232,6 @@ try_nextdev:
|
@@ -1236,7 +1236,6 @@ try_nextdev:
|
||||||
in6_ifa_put(hiscore->ifa);
|
in6_ifa_put(hiscore->ifa);
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
@ -49,7 +49,7 @@
|
||||||
|
|
||||||
int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
|
int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
|
||||||
unsigned char banned_flags)
|
unsigned char banned_flags)
|
||||||
@@ -4814,6 +4813,9 @@ int __init addrconf_init(void)
|
@@ -4818,6 +4817,9 @@ int __init addrconf_init(void)
|
||||||
|
|
||||||
ipv6_addr_label_rtnl_register();
|
ipv6_addr_label_rtnl_register();
|
||||||
|
|
||||||
|
@ -59,7 +59,7 @@
|
||||||
return 0;
|
return 0;
|
||||||
errout:
|
errout:
|
||||||
rtnl_af_unregister(&inet6_ops);
|
rtnl_af_unregister(&inet6_ops);
|
||||||
@@ -4832,6 +4834,9 @@ void addrconf_cleanup(void)
|
@@ -4836,6 +4838,9 @@ void addrconf_cleanup(void)
|
||||||
struct net_device *dev;
|
struct net_device *dev;
|
||||||
int i;
|
int i;
|
||||||
|
|
||||||
|
|
|
@ -100,7 +100,7 @@
|
||||||
|
|
||||||
--- a/net/bridge/br_multicast.c
|
--- a/net/bridge/br_multicast.c
|
||||||
+++ b/net/bridge/br_multicast.c
|
+++ b/net/bridge/br_multicast.c
|
||||||
@@ -824,7 +824,7 @@ static void __br_multicast_send_query(st
|
@@ -827,7 +827,7 @@ static void __br_multicast_send_query(st
|
||||||
if (port) {
|
if (port) {
|
||||||
__skb_push(skb, sizeof(struct ethhdr));
|
__skb_push(skb, sizeof(struct ethhdr));
|
||||||
skb->dev = port->dev;
|
skb->dev = port->dev;
|
||||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
||||||
FEATURES:=targz ext4
|
FEATURES:=targz ext4
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=omap4
|
||||||
BOARDNAME:=TI OMAP4
|
BOARDNAME:=TI OMAP4
|
||||||
FEATURES:=usb targz audio display
|
FEATURES:=usb targz audio display
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.11
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -25,7 +25,7 @@
|
||||||
label = "env";
|
label = "env";
|
||||||
--- a/arch/powerpc/boot/dts/canyonlands.dts
|
--- a/arch/powerpc/boot/dts/canyonlands.dts
|
||||||
+++ b/arch/powerpc/boot/dts/canyonlands.dts
|
+++ b/arch/powerpc/boot/dts/canyonlands.dts
|
||||||
@@ -217,24 +217,12 @@
|
@@ -222,24 +222,12 @@
|
||||||
#address-cells = <1>;
|
#address-cells = <1>;
|
||||||
#size-cells = <1>;
|
#size-cells = <1>;
|
||||||
partition@0 {
|
partition@0 {
|
||||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES+=\
|
DEFAULT_PACKAGES+=\
|
||||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
||||||
FEATURES:=ext4 audio
|
FEATURES:=ext4 audio
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.2.9
|
LINUX_VERSION:=3.2.12
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue