mirror of https://github.com/hak5/openwrt.git
bcm53xx: add support for Asus RT-N18U LEDs & buttons
Got GPIOs from #18152 thanks to Grrruk Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 43010lede-17.01
parent
4d5218e083
commit
bf0342f0ef
|
@ -1,4 +1,4 @@
|
||||||
From 3f3217b834f59c584f1a213c039349b4a3bb44d3 Mon Sep 17 00:00:00 2001
|
From 89fe6f9b7875f74e7d63a90ae3a51d84d3cf9369 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
||||||
Date: Thu, 9 Oct 2014 18:16:26 +0200
|
Date: Thu, 9 Oct 2014 18:16:26 +0200
|
||||||
Subject: [PATCH] ARM: BCM5301X: Add DT for Asus RT-N18U
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Asus RT-N18U
|
||||||
|
@ -8,11 +8,11 @@ Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
---
|
---
|
||||||
arch/arm/boot/dts/Makefile | 3 ++-
|
arch/arm/boot/dts/Makefile | 3 +-
|
||||||
arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts | 35 +++++++++++++++++++++++++++++
|
arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts | 88 +++++++++++++++++++++++++++++
|
||||||
arch/arm/boot/dts/bcm47081.dtsi | 26 +++++++++++++++++++++
|
arch/arm/boot/dts/bcm47081.dtsi | 26 +++++++++
|
||||||
arch/arm/mach-bcm/bcm_5301x.c | 1 +
|
arch/arm/mach-bcm/bcm_5301x.c | 1 +
|
||||||
4 files changed, 64 insertions(+), 1 deletion(-)
|
4 files changed, 117 insertions(+), 1 deletion(-)
|
||||||
create mode 100644 arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
create mode 100644 arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
||||||
create mode 100644 arch/arm/boot/dts/bcm47081.dtsi
|
create mode 100644 arch/arm/boot/dts/bcm47081.dtsi
|
||||||
|
|
||||||
|
@ -32,10 +32,10 @@ index 17c717b..330e0e0 100644
|
||||||
berlin2cd-google-chromecast.dtb
|
berlin2cd-google-chromecast.dtb
|
||||||
diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..e6347a9
|
index 0000000..cf8e9a5
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
||||||
@@ -0,0 +1,35 @@
|
@@ -0,0 +1,88 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Broadcom BCM470X / BCM5301X arm platform code.
|
+ * Broadcom BCM470X / BCM5301X arm platform code.
|
||||||
+ * DTS for Asus RT-N18U
|
+ * DTS for Asus RT-N18U
|
||||||
|
@ -70,6 +70,59 @@ index 0000000..e6347a9
|
||||||
+ status = "okay";
|
+ status = "okay";
|
||||||
+ };
|
+ };
|
||||||
+ };
|
+ };
|
||||||
|
+
|
||||||
|
+ leds {
|
||||||
|
+ compatible = "gpio-leds";
|
||||||
|
+
|
||||||
|
+ power {
|
||||||
|
+ label = "bcm53xx:blue:power";
|
||||||
|
+ gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-on";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ usb2 {
|
||||||
|
+ label = "bcm53xx:blue:usb2";
|
||||||
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ wan {
|
||||||
|
+ label = "bcm53xx:blue:wan";
|
||||||
|
+ gpios = <&chipcommon 6 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-on";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ lan {
|
||||||
|
+ label = "bcm53xx:blue:lan";
|
||||||
|
+ gpios = <&chipcommon 9 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-on";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ usb3 {
|
||||||
|
+ label = "bcm53xx:blue:usb3";
|
||||||
|
+ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ gpio-keys {
|
||||||
|
+ compatible = "gpio-keys-polled";
|
||||||
|
+ #address-cells = <1>;
|
||||||
|
+ #size-cells = <0>;
|
||||||
|
+ poll-interval = <200>;
|
||||||
|
+
|
||||||
|
+ restart {
|
||||||
|
+ label = "Reset";
|
||||||
|
+ linux,code = <KEY_RESTART>;
|
||||||
|
+ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ wps {
|
||||||
|
+ label = "WPS";
|
||||||
|
+ linux,code = <KEY_WPS_BUTTON>;
|
||||||
|
+ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
+};
|
+};
|
||||||
diff --git a/arch/arm/boot/dts/bcm47081.dtsi b/arch/arm/boot/dts/bcm47081.dtsi
|
diff --git a/arch/arm/boot/dts/bcm47081.dtsi b/arch/arm/boot/dts/bcm47081.dtsi
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
|
|
Loading…
Reference in New Issue