kernel: update linux 3.7 to 3.7.7

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 35571
lede-17.01
Gabor Juhos 2013-02-12 09:51:11 +00:00
parent 99b69fd9c5
commit bae4bfe3f8
18 changed files with 19 additions and 19 deletions

View File

@ -8,8 +8,8 @@ endif
ifeq ($(LINUX_VERSION),3.6.11) ifeq ($(LINUX_VERSION),3.6.11)
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54 LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
endif endif
ifeq ($(LINUX_VERSION),3.7.6) ifeq ($(LINUX_VERSION),3.7.7)
LINUX_KERNEL_MD5SUM:=4c4d80619c713f83015fc6b1c6280891 LINUX_KERNEL_MD5SUM:=bd37c2e05cb82331eb00da81773b2d85
endif endif
# disable the md5sum check for unknown kernel versions # disable the md5sum check for unknown kernel versions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120 BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120 BOARDNAME:=Infineon/ADMtek ADM5120
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
SUBTARGETS:=router_le router_be rb1xx SUBTARGETS:=router_le router_be rb1xx
INITRAMFS_EXTRA_FILES:= INITRAMFS_EXTRA_FILES:=

View File

@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand SUBTARGETS:=generic nand
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia FEATURES:=squashfs jffs2 usb atm pci pcmcia
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
MAINTAINER:=Florian Fainelli <florian@openwrt.org> MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
FEATURES:=squashfs FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -20,7 +20,7 @@
mask = PORT_CSC | PORT_PEC | PORT_OCC; mask = PORT_CSC | PORT_PEC | PORT_OCC;
else else
mask = PORT_CSC | PORT_PEC; mask = PORT_CSC | PORT_PEC;
@@ -804,7 +804,7 @@ static int ehci_hub_control ( @@ -808,7 +808,7 @@ static int ehci_hub_control (
if (temp & PORT_PEC) if (temp & PORT_PEC)
status |= USB_PORT_STAT_C_ENABLE << 16; status |= USB_PORT_STAT_C_ENABLE << 16;

View File

@ -39,7 +39,7 @@
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask) static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{ {
u16 cmd; u16 cmd;
@@ -973,3 +988,4 @@ static void __devinit quirk_usb_early_ha @@ -974,3 +989,4 @@ static void __devinit quirk_usb_early_ha
} }
DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID, DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff); PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);

View File

@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs jffs2 FEATURES:=squashfs jffs2
SUBTARGETS=xway ase falcon SUBTARGETS=xway ase falcon
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely

View File

@ -9,7 +9,7 @@ Subject: [PATCH 123/123] USB: fix roothub for IFXHCD
--- a/drivers/usb/core/hub.c --- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c +++ b/drivers/usb/core/hub.c
@@ -3906,7 +3906,7 @@ hub_port_init (struct usb_hub *hub, stru @@ -3940,7 +3940,7 @@ hub_port_init (struct usb_hub *hub, stru
udev->ttport = hdev->ttport; udev->ttport = hdev->ttport;
} else if (udev->speed != USB_SPEED_HIGH } else if (udev->speed != USB_SPEED_HIGH
&& hdev->speed == USB_SPEED_HIGH) { && hdev->speed == USB_SPEED_HIGH) {

View File

@ -13,7 +13,7 @@ SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:= INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org> MAINTAINER:=Florian Fainelli <florian@openwrt.org>
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
DEVICE_TYPE:=developerboard DEVICE_TYPE:=developerboard

View File

@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
FEATURES:=squashfs targz FEATURES:=squashfs targz
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org> MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
FEATURES:=spe_fpu ramdisk FEATURES:=spe_fpu ramdisk
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org> MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -13,7 +13,7 @@ FEATURES:=squashfs
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org> MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -13,7 +13,7 @@ FEATURES:=squashfs broken
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org> MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\ DEFAULT_PACKAGES+=\

View File

@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532 BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci targz broken FEATURES:=jffs2 pci targz broken
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532

View File

@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \ kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev \ kmod-ledtrig-netdev \
kmod-cpu-msr hwclock wpad kmod-cpu-msr hwclock wpad
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
CS5535_MASK:=0x0b000042 CS5535_MASK:=0x0b000042
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \ CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \

View File

@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
kmod-cpu-msr \ kmod-cpu-msr \
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
hwclock wpad flashrom tc hwclock wpad flashrom tc
LINUX_VERSION:=3.7.6 LINUX_VERSION:=3.7.7
CS5535_MASK:=0x0E000048 CS5535_MASK:=0x0E000048
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \ CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \