mirror of https://github.com/hak5/openwrt.git
parent
92981b6bb3
commit
b8227050fb
|
@ -15,8 +15,6 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
5 files changed, 21 insertions(+), 2 deletions(-)
|
||||
create mode 100644 arch/arm/boot/compressed/piggy.xzkern.S
|
||||
|
||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||
index c2e5f3d..489fe16 100644
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -20,6 +20,7 @@ config ARM
|
||||
|
@ -27,11 +25,9 @@ index c2e5f3d..489fe16 100644
|
|||
select HAVE_IRQ_WORK
|
||||
select HAVE_PERF_EVENTS
|
||||
select PERF_USE_VMALLOC
|
||||
diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
|
||||
index 23aad07..e5db34e 100644
|
||||
--- a/arch/arm/boot/compressed/Makefile
|
||||
+++ b/arch/arm/boot/compressed/Makefile
|
||||
@@ -82,13 +82,14 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/BSS_START/$(ZBSSADDR)/
|
||||
@@ -82,13 +82,14 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/
|
||||
suffix_$(CONFIG_KERNEL_GZIP) = gzip
|
||||
suffix_$(CONFIG_KERNEL_LZO) = lzo
|
||||
suffix_$(CONFIG_KERNEL_LZMA) = lzma
|
||||
|
@ -47,7 +43,7 @@ index 23aad07..e5db34e 100644
|
|||
|
||||
ifeq ($(CONFIG_FUNCTION_TRACER),y)
|
||||
ORIG_CFLAGS := $(KBUILD_CFLAGS)
|
||||
@@ -133,8 +134,14 @@ bad_syms=$$($(CROSS_COMPILE)nm $@ | sed -n 's/^.\{8\} [bc] \(.*\)/\1/p') && \
|
||||
@@ -133,8 +134,14 @@ bad_syms=$$($(CROSS_COMPILE)nm $@ | sed
|
||||
( echo "following symbols must have non local/private scope:" >&2; \
|
||||
echo "$$bad_syms" >&2; rm -f $@; false )
|
||||
|
||||
|
@ -63,8 +59,6 @@ index 23aad07..e5db34e 100644
|
|||
$(call if_changed,ld)
|
||||
@$(check_for_bad_syms)
|
||||
|
||||
diff --git a/arch/arm/boot/compressed/decompress.c b/arch/arm/boot/compressed/decompress.c
|
||||
index 07be5a2..0ecd8b4 100644
|
||||
--- a/arch/arm/boot/compressed/decompress.c
|
||||
+++ b/arch/arm/boot/compressed/decompress.c
|
||||
@@ -44,6 +44,10 @@ extern void error(char *);
|
||||
|
@ -78,9 +72,6 @@ index 07be5a2..0ecd8b4 100644
|
|||
int do_decompress(u8 *input, int len, u8 *output, void (*error)(char *x))
|
||||
{
|
||||
return decompress(input, len, NULL, NULL, output, NULL, error);
|
||||
diff --git a/arch/arm/boot/compressed/piggy.xzkern.S b/arch/arm/boot/compressed/piggy.xzkern.S
|
||||
new file mode 100644
|
||||
index 0000000..5703f30
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/compressed/piggy.xzkern.S
|
||||
@@ -0,0 +1,6 @@
|
||||
|
@ -90,8 +81,6 @@ index 0000000..5703f30
|
|||
+ .incbin "arch/arm/boot/compressed/piggy.xzkern"
|
||||
+ .globl input_data_end
|
||||
+input_data_end:
|
||||
diff --git a/lib/xz/xz_dec_stream.c b/lib/xz/xz_dec_stream.c
|
||||
index ac809b1..9a60cc2 100644
|
||||
--- a/lib/xz/xz_dec_stream.c
|
||||
+++ b/lib/xz/xz_dec_stream.c
|
||||
@@ -9,6 +9,7 @@
|
||||
|
@ -102,6 +91,3 @@ index ac809b1..9a60cc2 100644
|
|||
|
||||
/* Hash used to validate the Index field */
|
||||
struct xz_dec_hash {
|
||||
--
|
||||
1.7.1
|
||||
|
||||
|
|
Loading…
Reference in New Issue