mirror of https://github.com/hak5/openwrt.git
uboot-envtools: Add TARGET_LDFLAGS to fix PIE and RELRO
Forward the OpenWrt TARGET_LDFLAGS to the linker of the fw_printenv tool. In addition also use the more standard make invocation script. With this change the fw_printenv tool is built with PIE and Full RELRO support when activated globally in OpenWrt. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>master
parent
39035df71c
commit
b7b2be0b26
|
@ -51,16 +51,11 @@ define Build/Configure
|
|||
touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
MAKE_FLAGS += \
|
||||
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
|
||||
HOSTLDFLAGS= \
|
||||
TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
no-dot-config-targets=envtools \
|
||||
envtools
|
||||
endef
|
||||
|
||||
define Package/uboot-envtools/conffiles
|
||||
/etc/config/ubootenv
|
||||
|
|
|
@ -1,12 +1,15 @@
|
|||
--- a/tools/env/Makefile
|
||||
+++ b/tools/env/Makefile
|
||||
@@ -8,6 +8,10 @@
|
||||
@@ -8,6 +8,13 @@
|
||||
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
|
||||
override HOSTCC = $(CC)
|
||||
|
||||
+ifneq ($(TARGET_CFLAGS),)
|
||||
+HOSTCFLAGS = $(TARGET_CFLAGS)
|
||||
+endif
|
||||
+ifneq ($(TARGET_LDFLAGS),)
|
||||
+HOSTLDFLAGS = $(TARGET_LDFLAGS)
|
||||
+endif
|
||||
+
|
||||
# Compile for a hosted environment on the target
|
||||
HOST_EXTRACFLAGS = -I$(srctree)/tools \
|
||||
|
|
Loading…
Reference in New Issue