mirror of https://github.com/hak5/openwrt.git
openssl: fix build failure on arm, aes asm version is not shipped anymore (closes: #6778)
SVN-Revision: 19945lede-17.01
parent
45f7dc9459
commit
b3f90f939b
|
@ -82,11 +82,7 @@ else
|
||||||
OPENSSL_OPTIONS += no-engines
|
OPENSSL_OPTIONS += no-engines
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifdef CONFIG_arm
|
|
||||||
OPENSSL_MAKEFLAGS := AES_ASM_OBJ="aes-armv4.o aes_cbc.o"
|
|
||||||
else
|
|
||||||
OPENSSL_OPTIONS += no-perlasm
|
OPENSSL_OPTIONS += no-perlasm
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
(cd $(PKG_BUILD_DIR); \
|
(cd $(PKG_BUILD_DIR); \
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- a/crypto/aes/Makefile
|
|
||||||
+++ b/crypto/aes/Makefile
|
|
||||||
@@ -47,6 +47,9 @@ lib: $(LIBOBJ)
|
|
||||||
|
|
||||||
$(LIBOBJ): $(LIBSRC)
|
|
||||||
|
|
||||||
+aes-armv4.s: asm/aes-armv4.pl
|
|
||||||
+ $(PERL) $^ > $@
|
|
||||||
+
|
|
||||||
aes-ia64.s: asm/aes-ia64.S
|
|
||||||
$(CC) $(CFLAGS) -E asm/aes-ia64.S > $@
|
|
||||||
|
|
Loading…
Reference in New Issue