mirror of https://github.com/hak5/openwrt.git
uboot-at91: bump version to linux4sam-2020.04
Bump version to linux4sam-2020.04 and add patch to fix Wformat-security warnings. Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>master
parent
9b36ca8032
commit
abf6c288c1
|
@ -7,12 +7,12 @@
|
|||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_VERSION:=linux4sam_6.0
|
||||
PKG_VERSION:=linux4sam-2020.04
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
|
||||
PKG_SOURCE_VERSION:=1e7d2e5973c1fb780e55e28a801c6c574158ac14
|
||||
PKG_SOURCE_VERSION:=0e1d1b6efb7f8e27c372279a906fcd2524df09da
|
||||
|
||||
include $(INCLUDE_DIR)/u-boot.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
|
|
@ -1,13 +1,39 @@
|
|||
diff --git a/cmd/version.c b/cmd/version.c
|
||||
index b2fffe9..bcbbeb1 100644
|
||||
index b2fffe99..bcbbeb18 100644
|
||||
--- a/cmd/version.c
|
||||
+++ b/cmd/version.c
|
||||
@@ -18,7 +18,7 @@ static int do_version(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
|
||||
{
|
||||
char buf[DISPLAY_OPTIONS_BANNER_LENGTH];
|
||||
|
||||
char buf[DISPLAY_OPTIONS_BANNER_LENGTH];
|
||||
|
||||
- printf(display_options_get_banner(false, buf, sizeof(buf)));
|
||||
+ printf("%s",display_options_get_banner(false, buf, sizeof(buf)));
|
||||
#ifdef CC_VERSION_STRING
|
||||
puts(CC_VERSION_STRING "\n");
|
||||
puts(CC_VERSION_STRING "\n");
|
||||
#endif
|
||||
diff --git a/drivers/pinctrl/pinctrl-uclass.c b/drivers/pinctrl/pinctrl-uclass.c
|
||||
index 3425ed11..8c2e1d5c 100644
|
||||
--- a/drivers/pinctrl/pinctrl-uclass.c
|
||||
+++ b/drivers/pinctrl/pinctrl-uclass.c
|
||||
@@ -368,7 +368,7 @@ int pinctrl_get_pin_name(struct udevice *dev, int selector, char *buf,
|
||||
if (!ops->get_pin_name)
|
||||
return -ENOSYS;
|
||||
|
||||
- snprintf(buf, size, ops->get_pin_name(dev, selector));
|
||||
+ snprintf(buf, size, "%s", ops->get_pin_name(dev, selector));
|
||||
|
||||
return 0;
|
||||
}
|
||||
diff --git a/lib/efi_loader/efi_variable.c b/lib/efi_loader/efi_variable.c
|
||||
index c316bdfe..5fe8129c 100644
|
||||
--- a/lib/efi_loader/efi_variable.c
|
||||
+++ b/lib/efi_loader/efi_variable.c
|
||||
@@ -522,7 +522,7 @@ efi_status_t EFIAPI efi_set_variable(u16 *variable_name,
|
||||
|
||||
if (old_size)
|
||||
/* APPEND_WRITE */
|
||||
- s += sprintf(s, old_val);
|
||||
+ s += sprintf(s, "%s", old_val);
|
||||
else
|
||||
s += sprintf(s, "(blob)");
|
||||
|
||||
|
|
Loading…
Reference in New Issue