mirror of https://github.com/hak5/openwrt.git
parent
62cdbe18f3
commit
ab1afcbabb
|
@ -286,3 +286,6 @@ endif
|
|||
ifneq ($(BR2_PACKAGE_ULOGD_MOD_PGSQL),)
|
||||
ulogd-compile: postgresql-compile
|
||||
endif
|
||||
ifneq ($(BR2_PACKAGE_ULOGD_MOD_SQLITE),)
|
||||
ulogd-compile: sqlite-compile
|
||||
endif
|
||||
|
|
|
@ -31,6 +31,13 @@ config BR2_PACKAGE_ULOGD_MOD_PGSQL
|
|||
depends BR2_PACKAGE_ULOGD
|
||||
select BR2_PACKAGE_LIBPQ
|
||||
|
||||
config BR2_PACKAGE_ULOGD_MOD_SQLITE
|
||||
prompt "ulogd-mod-sqlite................ Output plugin for logging into an SQLite database"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
depends BR2_PACKAGE_ULOGD
|
||||
select BR2_PACKAGE_LIBSQLITE
|
||||
|
||||
config BR2_PACKAGE_ULOGD_MOD_EXTRA
|
||||
prompt "ulogd-mod-extra................. All other plugins"
|
||||
tristate
|
||||
|
|
|
@ -3,9 +3,9 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ulogd
|
||||
PKG_VERSION:=1.23
|
||||
PKG_RELEASE:=2.1
|
||||
PKG_MD5SUM:=fa3dfcaacf31855626d5b731b04a077f
|
||||
PKG_VERSION:=1.24
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=05b4ed2926b9a22aaeaf642917bbf8ff
|
||||
|
||||
PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/ulogd/ \
|
||||
ftp://ftp.be.netfilter.org/pub/netfilter/ulogd/ \
|
||||
|
@ -31,6 +31,10 @@ ifneq ($(BR2_PACKAGE_ULOGD_MOD_PGSQL),)
|
|||
ULOGD_PGSQL_OPTION:=--with-pgsql=$(STAGING_DIR)/usr
|
||||
endif
|
||||
|
||||
ifneq ($(BR2_PACKAGE_ULOGD_MOD_SQLITE),)
|
||||
ULOGD_SQLITE_OPTION:=--with-sqlite3=$(STAGING_DIR)/usr
|
||||
endif
|
||||
|
||||
define IPKG_plugin_template
|
||||
|
||||
$$(IPKG_$(1)):
|
||||
|
@ -49,11 +53,13 @@ $(eval $(call PKG_template,ULOGD,ulogd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
|||
$(eval $(call PKG_template,ULOGD_MOD_MYSQL,ulogd-mod-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,ULOGD_MOD_PCAP,ulogd-mod-pcap,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,ULOGD_MOD_PGSQL,ulogd-mod-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,ULOGD_MOD_SQLITE,ulogd-mod-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,ULOGD_MOD_EXTRA,ulogd-mod-extra,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(eval $(call IPKG_plugin_template,ULOGD_MOD_MYSQL,MYSQL))
|
||||
$(eval $(call IPKG_plugin_template,ULOGD_MOD_PCAP,PCAP))
|
||||
$(eval $(call IPKG_plugin_template,ULOGD_MOD_PGSQL,PGSQL))
|
||||
$(eval $(call IPKG_plugin_template,ULOGD_MOD_SQLITE,SQLITE3))
|
||||
$(eval $(call IPKG_plugin_template,ULOGD_MOD_EXTRA,LOCAL LOGEMU OPRINT PWSNIFF SYSLOG))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
|
@ -87,6 +93,7 @@ $(PKG_BUILD_DIR)/.configured:
|
|||
--disable-static \
|
||||
$(ULOGD_MYSQL_OPTION) \
|
||||
$(ULOGD_PGSQL_OPTION) \
|
||||
$(ULOGD_SQLITE_OPTION) \
|
||||
);
|
||||
touch $@
|
||||
|
||||
|
|
|
@ -0,0 +1,5 @@
|
|||
Package: ulogd-mod-sqlite
|
||||
Priority: optional
|
||||
Section: net
|
||||
Description: Netfilter userspace logging daemon (SQLite plugin)
|
||||
Depends: libsqlite, ulogd
|
|
@ -1,24 +0,0 @@
|
|||
diff -ur ulogd-1.23/extensions/ulogd_SYSLOG.c ulogd-1.23-owrt/extensions/ulogd_SYSLOG.c
|
||||
--- ulogd-1.23/extensions/ulogd_SYSLOG.c 2005-02-12 22:17:41.000000000 +0100
|
||||
+++ ulogd-1.23-owrt/extensions/ulogd_SYSLOG.c 2006-01-29 19:58:43.000000000 +0100
|
||||
@@ -136,7 +136,7 @@
|
||||
.name = "syslog",
|
||||
.init = &syslog_init,
|
||||
.fini = &syslog_fini,
|
||||
- .output &_output_syslog
|
||||
+ .output = &_output_syslog
|
||||
};
|
||||
|
||||
|
||||
diff -ur ulogd-1.23/include/ulogd/ulogd.h ulogd-1.23-owrt/include/ulogd/ulogd.h
|
||||
--- ulogd-1.23/include/ulogd/ulogd.h 2004-04-25 00:40:54.000000000 +0200
|
||||
+++ ulogd-1.23-owrt/include/ulogd/ulogd.h 2006-01-29 19:58:40.000000000 +0100
|
||||
@@ -56,8 +56,6 @@
|
||||
#define ULOGD_ERROR 7 /* error condition, requires user action */
|
||||
#define ULOGD_FATAL 8 /* fatal, program aborted */
|
||||
|
||||
-extern FILE *logfile;
|
||||
-
|
||||
typedef struct ulog_iret {
|
||||
/* next interpreter return (key) in the global list */
|
||||
struct ulog_iret *next;
|
|
@ -1,20 +0,0 @@
|
|||
diff -ruN ulogd-1.23-old/ulogd.conf.in.rej ulogd-1.23-new/ulogd.conf.in.rej
|
||||
--- ulogd-1.23-old/ulogd.conf.in.rej 2005-04-18 16:19:06.000000000 +0200
|
||||
+++ ulogd-1.23-new/ulogd.conf.in.rej 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,16 +0,0 @@
|
||||
-***************
|
||||
-*** 62,68 ****
|
||||
- user="laforge"
|
||||
- db="ulogd"
|
||||
- host="localhost"
|
||||
-- use_ssl=0
|
||||
-
|
||||
- [PGSQL]
|
||||
- table="ulog"
|
||||
---- 62,67 ----
|
||||
- user="laforge"
|
||||
- db="ulogd"
|
||||
- host="localhost"
|
||||
-
|
||||
- [PGSQL]
|
||||
- table="ulog"
|
Loading…
Reference in New Issue