mirror of https://github.com/hak5/openwrt.git
ifxmips: move header files, split up patches, rename some files
SVN-Revision: 18010lede-17.01
parent
76ff676a1e
commit
aaf52c0c7d
|
@ -6,18 +6,6 @@ config MTD_IFXMIPS
|
|||
bool "IFXMips flash map"
|
||||
default y
|
||||
|
||||
config IFXMIPS_SSC
|
||||
bool "IFXMips ssc"
|
||||
default y
|
||||
|
||||
config IFXMIPS_EEPROM
|
||||
bool "IFXMips eeprom"
|
||||
default y
|
||||
|
||||
config IFXMIPS_MEI
|
||||
bool "IFXMips mei"
|
||||
default y
|
||||
|
||||
config IFXMIPS_GPIO_RST_BTN
|
||||
bool "Reset Button"
|
||||
default y
|
||||
|
|
|
@ -1 +1 @@
|
|||
obj-y := reset.o prom.o setup.o interrupt.o dma-core.o pmu.o board.o clock.o gpio.o
|
||||
obj-y := reset.o prom.o setup.o irq.o dma-core.o pmu.o board.o clock.o gpio.o
|
||||
|
|
|
@ -31,10 +31,12 @@
|
|||
#include <linux/time.h>
|
||||
#include <linux/io.h>
|
||||
#include <linux/gpio.h>
|
||||
|
||||
#include <asm/bootinfo.h>
|
||||
#include <asm/irq.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_irq.h>
|
||||
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_irq.h>
|
||||
|
||||
#define MAX_BOARD_NAME_LEN 32
|
||||
#define MAX_IFXMIPS_DEVS 9
|
||||
|
|
|
@ -26,11 +26,13 @@
|
|||
#include <linux/init.h>
|
||||
#include <linux/uaccess.h>
|
||||
#include <linux/unistd.h>
|
||||
#include <linux/errno.h>
|
||||
|
||||
#include <asm/irq.h>
|
||||
#include <asm/div64.h>
|
||||
#include <linux/errno.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/mach-ifxmips/cgu.h>
|
||||
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_cgu.h>
|
||||
|
||||
static unsigned int cgu_get_pll0_fdiv(void);
|
||||
unsigned int ifxmips_clocks[] = {CLOCK_167M, CLOCK_133M, CLOCK_111M, CLOCK_83M };
|
||||
|
|
|
@ -19,10 +19,10 @@
|
|||
#include <linux/errno.h>
|
||||
#include <linux/io.h>
|
||||
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_irq.h>
|
||||
#include <asm/ifxmips/ifxmips_dma.h>
|
||||
#include <asm/ifxmips/ifxmips_pmu.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_irq.h>
|
||||
#include <ifxmips_dma.h>
|
||||
#include <ifxmips_pmu.h>
|
||||
|
||||
/*25 descriptors for each dma channel,4096/8/20=25.xx*/
|
||||
#define IFXMIPS_DMA_DESCRIPTOR_OFFSET 25
|
||||
|
|
|
@ -34,10 +34,12 @@
|
|||
#include <linux/skbuff.h>
|
||||
#include <linux/netlink.h>
|
||||
#include <linux/platform_device.h>
|
||||
#include <net/sock.h>
|
||||
#include <linux/uaccess.h>
|
||||
#include <linux/semaphore.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
|
||||
#include <net/sock.h>
|
||||
|
||||
#include <ifxmips.h>
|
||||
|
||||
#define MAX_PORTS 2
|
||||
#define PINS_PER_PORT 16
|
||||
|
|
|
@ -26,10 +26,11 @@
|
|||
|
||||
#include <asm/bootinfo.h>
|
||||
#include <asm/irq.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_irq.h>
|
||||
#include <asm/irq_cpu.h>
|
||||
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_irq.h>
|
||||
|
||||
void ifxmips_disable_irq(unsigned int irq_nr)
|
||||
{
|
||||
int i;
|
|
@ -22,7 +22,8 @@
|
|||
#include <linux/kernel.h>
|
||||
#include <linux/module.h>
|
||||
#include <linux/version.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
|
||||
#include <ifxmips.h>
|
||||
|
||||
void ifxmips_pmu_enable(unsigned int module)
|
||||
{
|
||||
|
|
|
@ -20,8 +20,10 @@
|
|||
#include <linux/init.h>
|
||||
#include <linux/module.h>
|
||||
#include <linux/bootmem.h>
|
||||
|
||||
#include <asm/bootinfo.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
|
||||
#include <ifxmips.h>
|
||||
|
||||
static char buf[1024]; /* for prom_printf() */
|
||||
|
||||
|
|
|
@ -19,9 +19,10 @@
|
|||
#include <linux/kernel.h>
|
||||
#include <linux/pm.h>
|
||||
#include <linux/io.h>
|
||||
|
||||
#include <asm/reboot.h>
|
||||
#include <asm/system.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <ifxmips.h>
|
||||
|
||||
static void ifxmips_machine_restart(char *command)
|
||||
{
|
||||
|
|
|
@ -18,8 +18,6 @@
|
|||
*/
|
||||
|
||||
#include <linux/init.h>
|
||||
|
||||
|
||||
#include <linux/cpu.h>
|
||||
|
||||
#include <asm/time.h>
|
||||
|
@ -27,11 +25,11 @@
|
|||
#include <asm/irq.h>
|
||||
#include <asm/bootinfo.h>
|
||||
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_irq.h>
|
||||
#include <asm/ifxmips/ifxmips_pmu.h>
|
||||
#include <asm/mach-ifxmips/cgu.h>
|
||||
#include <asm/ifxmips/ifxmips_prom.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_irq.h>
|
||||
#include <ifxmips_pmu.h>
|
||||
#include <ifxmips_cgu.h>
|
||||
#include <ifxmips_prom.h>
|
||||
|
||||
static unsigned int r4k_offset;
|
||||
static unsigned int r4k_cur;
|
||||
|
|
|
@ -22,8 +22,8 @@
|
|||
#ifndef _IFXMIPS_GPIO_H_
|
||||
#define _IFXMIPS_GPIO_H_
|
||||
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_gpio.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_gpio.h>
|
||||
|
||||
#define GPIO_TO_PORT(x) ((x > 15) ? (1) : (0))
|
||||
#define GPIO_TO_GPIO(x) ((x > 15) ? (x-16) : (x))
|
||||
|
|
|
@ -4,11 +4,11 @@
|
|||
#include <linux/init.h>
|
||||
#include <linux/delay.h>
|
||||
#include <linux/mm.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_irq.h>
|
||||
#include <asm/addrspace.h>
|
||||
#include <linux/vmalloc.h>
|
||||
#include <asm/ifxmips/ifxmips_ebu.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_irq.h>
|
||||
#include <ifxmips_ebu.h>
|
||||
|
||||
#define IFXMIPS_PCI_CFG_BUSNUM_SHF 16
|
||||
#define IFXMIPS_PCI_CFG_DEVNUM_SHF 11
|
||||
|
|
|
@ -4,11 +4,11 @@
|
|||
#include <linux/init.h>
|
||||
#include <linux/delay.h>
|
||||
#include <linux/mm.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_irq.h>
|
||||
#include <asm/mach-ifxmips/cgu.h>
|
||||
#include <asm/addrspace.h>
|
||||
#include <linux/vmalloc.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_irq.h>
|
||||
#include <ifxmips_cgu.h>
|
||||
|
||||
#define IFXMIPS_PCI_MEM_BASE 0x18000000
|
||||
#define IFXMIPS_PCI_MEM_SIZE 0x02000000
|
||||
|
@ -49,6 +49,8 @@ static struct pci_controller ifxmips_pci_controller =
|
|||
.io_offset = 0x00000000UL,
|
||||
};
|
||||
|
||||
/* the cpu can can generate the 33Mhz or rely on an external clock the cgu needs the
|
||||
proper setting, otherwise the cpu hangs. we have no way of runtime detecting this */
|
||||
u32 ifxmips_pci_mapped_cfg;
|
||||
int ifxmips_pci_external_clock = 0;
|
||||
|
||||
|
|
|
@ -31,9 +31,9 @@
|
|||
#include <linux/leds.h>
|
||||
#include <linux/delay.h>
|
||||
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_gpio.h>
|
||||
#include <asm/ifxmips/ifxmips_pmu.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_gpio.h>
|
||||
#include <ifxmips_pmu.h>
|
||||
|
||||
#define DRVNAME "ifxmips_led"
|
||||
|
||||
|
|
|
@ -29,9 +29,9 @@
|
|||
#include <linux/magic.h>
|
||||
#include <linux/platform_device.h>
|
||||
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_prom.h>
|
||||
#include <asm/ifxmips/ifxmips_ebu.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_prom.h>
|
||||
#include <ifxmips_ebu.h>
|
||||
|
||||
#ifndef CONFIG_MTD_PARTITIONS
|
||||
#error Please enable CONFIG_MTD_PARTITIONS
|
||||
|
@ -244,7 +244,7 @@ static int ifxmips_mtd_probe(struct platform_device *dev)
|
|||
add_mtd_partitions(ifxmips_mtd, &ifxmips_meta_partition, 1);
|
||||
|
||||
printk(KERN_INFO "ifxmips_mtd: added %s flash with %dMB\n",
|
||||
ifxmips_map.name, ifxmips_mtd->size >> 20);
|
||||
ifxmips_map.name, ifxmips_mtd->size);
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
|
|
@ -34,10 +34,12 @@
|
|||
#include <linux/ethtool.h>
|
||||
#include <linux/init.h>
|
||||
#include <linux/delay.h>
|
||||
|
||||
#include <asm/checksum.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_dma.h>
|
||||
#include <asm/ifxmips/ifxmips_pmu.h>
|
||||
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_dma.h>
|
||||
#include <ifxmips_pmu.h>
|
||||
|
||||
struct ifxmips_mii_priv {
|
||||
struct net_device_stats stats;
|
||||
|
|
|
@ -48,8 +48,8 @@
|
|||
|
||||
#include <asm/system.h>
|
||||
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <asm/ifxmips/ifxmips_irq.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_irq.h>
|
||||
|
||||
#define PORT_IFXMIPSASC 111
|
||||
|
||||
|
|
|
@ -25,8 +25,8 @@
|
|||
#include <linux/platform_device.h>
|
||||
#include <linux/uaccess.h>
|
||||
|
||||
#include <asm/mach-ifxmips/cgu.h>
|
||||
#include <asm/ifxmips/ifxmips.h>
|
||||
#include <ifxmips.h>
|
||||
#include <ifxmips_cgu.h>
|
||||
|
||||
#define IFXMIPS_WDT_PW1 0x00BE0000
|
||||
#define IFXMIPS_WDT_PW2 0x00DC0000
|
||||
|
|
|
@ -53,15 +53,6 @@ Index: linux-2.6.30.5/arch/mips/Makefile
|
|||
# DECstation family
|
||||
#
|
||||
core-$(CONFIG_MACH_DECSTATION) += arch/mips/dec/
|
||||
Index: linux-2.6.30.5/arch/mips/pci/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/arch/mips/pci/Makefile 2009-09-02 22:12:48.000000000 +0200
|
||||
+++ linux-2.6.30.5/arch/mips/pci/Makefile 2009-09-02 22:12:53.000000000 +0200
|
||||
@@ -52,3 +52,4 @@
|
||||
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
|
||||
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
||||
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
|
||||
+obj-$(CONFIG_IFXMIPS) += pci-ifxmips.o ops-ifxmips.o
|
||||
Index: linux-2.6.30.5/arch/mips/include/asm/bootinfo.h
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/arch/mips/include/asm/bootinfo.h 2009-09-02 22:12:48.000000000 +0200
|
||||
|
|
|
@ -1,139 +0,0 @@
|
|||
Index: linux-2.6.30.5/drivers/char/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/char/Makefile 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/char/Makefile 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -112,6 +112,10 @@
|
||||
obj-$(CONFIG_JS_RTC) += js-rtc.o
|
||||
js-rtc-y = rtc.o
|
||||
|
||||
+obj-$(CONFIG_IFXMIPS_SSC) += ifxmips_ssc.o
|
||||
+obj-$(CONFIG_IFXMIPS_EEPROM) += ifxmips_eeprom.o
|
||||
+obj-$(CONFIG_IFXMIPS_MEI) += ifxmips_mei_core.o
|
||||
+
|
||||
# Files generated that shall be removed upon make clean
|
||||
clean-files := consolemap_deftbl.c defkeymap.c
|
||||
|
||||
Index: linux-2.6.30.5/drivers/mtd/maps/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/mtd/maps/Makefile 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/mtd/maps/Makefile 2009-09-02 18:30:09.000000000 +0200
|
||||
@@ -62,3 +62,4 @@
|
||||
obj-$(CONFIG_MTD_BFIN_ASYNC) += bfin-async-flash.o
|
||||
obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
|
||||
obj-$(CONFIG_MTD_VMU) += vmu-flash.o
|
||||
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
||||
Index: linux-2.6.30.5/drivers/net/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/net/Kconfig 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/net/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -353,6 +353,12 @@
|
||||
|
||||
source "drivers/net/arm/Kconfig"
|
||||
|
||||
+config IFXMIPS_MII0
|
||||
+ tristate "Infineon IFXMips eth0 driver"
|
||||
+ depends on IFXMIPS
|
||||
+ help
|
||||
+ Support for the MII0 inside the IFXMips SOC
|
||||
+
|
||||
config AX88796
|
||||
tristate "ASIX AX88796 NE2000 clone support"
|
||||
depends on ARM || MIPS || SUPERH
|
||||
Index: linux-2.6.30.5/drivers/serial/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/serial/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/serial/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -1365,6 +1365,14 @@
|
||||
help
|
||||
Support for Console on the NWP serial ports.
|
||||
|
||||
+config SERIAL_IFXMIPS
|
||||
+ bool "IFXMips serial driver"
|
||||
+ depends on IFXMIPS
|
||||
+ select SERIAL_CORE
|
||||
+ select SERIAL_CORE_CONSOLE
|
||||
+ help
|
||||
+ Driver for the ifxmipss built in ASC hardware
|
||||
+
|
||||
config SERIAL_QE
|
||||
tristate "Freescale QUICC Engine serial port support"
|
||||
depends on QUICC_ENGINE
|
||||
Index: linux-2.6.30.5/drivers/serial/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/serial/Makefile 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/serial/Makefile 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -77,3 +77,4 @@
|
||||
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
||||
obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o
|
||||
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
|
||||
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
|
||||
Index: linux-2.6.30.5/drivers/watchdog/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -105,6 +105,7 @@
|
||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
||||
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
||||
+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
|
||||
|
||||
# PARISC Architecture
|
||||
|
||||
Index: linux-2.6.30.5/drivers/net/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/net/Makefile 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/net/Makefile 2009-09-02 18:30:37.000000000 +0200
|
||||
@@ -234,6 +234,7 @@
|
||||
obj-$(CONFIG_MLX4_CORE) += mlx4/
|
||||
obj-$(CONFIG_ENC28J60) += enc28j60.o
|
||||
obj-$(CONFIG_ETHOC) += ethoc.o
|
||||
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
|
||||
|
||||
obj-$(CONFIG_XTENSA_XT2000_SONIC) += xtsonic.o
|
||||
|
||||
Index: linux-2.6.30.5/drivers/leds/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/leds/Kconfig 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/leds/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -227,6 +227,12 @@
|
||||
This option enables support for BD2802GU RGB LED driver chips
|
||||
accessed via the I2C bus.
|
||||
|
||||
+config LEDS_IFXMIPS
|
||||
+ tristate "LED Support for IFXMIPS LEDs"
|
||||
+ depends on LEDS_CLASS && IFXMIPS
|
||||
+ help
|
||||
+ This option enables support for the CM-X270 LEDs.
|
||||
+
|
||||
comment "LED Triggers"
|
||||
|
||||
config LEDS_TRIGGERS
|
||||
Index: linux-2.6.30.5/drivers/leds/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/leds/Makefile 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/leds/Makefile 2009-09-02 18:31:23.000000000 +0200
|
||||
@@ -27,6 +27,7 @@
|
||||
obj-$(CONFIG_LEDS_DA903X) += leds-da903x.o
|
||||
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
|
||||
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
||||
+obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
|
||||
|
||||
# LED SPI Drivers
|
||||
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
||||
Index: linux-2.6.30.5/drivers/watchdog/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -764,6 +764,12 @@
|
||||
help
|
||||
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
||||
|
||||
+config IFXMIPS_WDT
|
||||
+ bool "IFXMips watchdog"
|
||||
+ depends on IFXMIPS
|
||||
+ help
|
||||
+ Hardware driver for the IFXMIPS Watchdog Timer.
|
||||
+
|
||||
# PARISC Architecture
|
||||
|
||||
# POWERPC Architecture
|
|
@ -0,0 +1,9 @@
|
|||
Index: linux-2.6.30.5/arch/mips/pci/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/arch/mips/pci/Makefile 2009-09-02 22:12:48.000000000 +0200
|
||||
+++ linux-2.6.30.5/arch/mips/pci/Makefile 2009-09-02 22:12:53.000000000 +0200
|
||||
@@ -52,3 +52,4 @@
|
||||
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
|
||||
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
||||
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
|
||||
+obj-$(CONFIG_IFXMIPS) += pci-ifxmips.o ops-ifxmips.o
|
|
@ -0,0 +1,28 @@
|
|||
Index: linux-2.6.30.5/drivers/serial/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/serial/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/serial/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -1365,6 +1365,14 @@
|
||||
help
|
||||
Support for Console on the NWP serial ports.
|
||||
|
||||
+config SERIAL_IFXMIPS
|
||||
+ bool "IFXMips serial driver"
|
||||
+ depends on IFXMIPS
|
||||
+ select SERIAL_CORE
|
||||
+ select SERIAL_CORE_CONSOLE
|
||||
+ help
|
||||
+ Driver for the ifxmipss built in ASC hardware
|
||||
+
|
||||
config SERIAL_QE
|
||||
tristate "Freescale QUICC Engine serial port support"
|
||||
depends on QUICC_ENGINE
|
||||
Index: linux-2.6.30.5/drivers/serial/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/serial/Makefile 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/serial/Makefile 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -77,3 +77,4 @@
|
||||
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
||||
obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o
|
||||
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
|
||||
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
|
|
@ -0,0 +1,29 @@
|
|||
Index: linux-2.6.30.5/drivers/net/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/net/Kconfig 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/net/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -353,6 +353,12 @@
|
||||
|
||||
source "drivers/net/arm/Kconfig"
|
||||
|
||||
+config IFXMIPS_MII0
|
||||
+ tristate "Infineon IFXMips eth0 driver"
|
||||
+ depends on IFXMIPS
|
||||
+ help
|
||||
+ Support for the MII0 inside the IFXMips SOC
|
||||
+
|
||||
config AX88796
|
||||
tristate "ASIX AX88796 NE2000 clone support"
|
||||
depends on ARM || MIPS || SUPERH
|
||||
Index: linux-2.6.30.5/drivers/net/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/net/Makefile 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/net/Makefile 2009-09-02 18:30:37.000000000 +0200
|
||||
@@ -234,6 +234,7 @@
|
||||
obj-$(CONFIG_MLX4_CORE) += mlx4/
|
||||
obj-$(CONFIG_ENC28J60) += enc28j60.o
|
||||
obj-$(CONFIG_ETHOC) += ethoc.o
|
||||
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
|
||||
|
||||
obj-$(CONFIG_XTENSA_XT2000_SONIC) += xtsonic.o
|
||||
|
|
@ -0,0 +1,9 @@
|
|||
Index: linux-2.6.30.5/drivers/mtd/maps/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/mtd/maps/Makefile 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/mtd/maps/Makefile 2009-09-02 18:30:09.000000000 +0200
|
||||
@@ -62,3 +62,4 @@
|
||||
obj-$(CONFIG_MTD_BFIN_ASYNC) += bfin-async-flash.o
|
||||
obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
|
||||
obj-$(CONFIG_MTD_VMU) += vmu-flash.o
|
||||
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
|
@ -0,0 +1,29 @@
|
|||
Index: linux-2.6.30.5/drivers/watchdog/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -105,6 +105,7 @@
|
||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
||||
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
||||
+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
|
||||
|
||||
# PARISC Architecture
|
||||
|
||||
Index: linux-2.6.30.5/drivers/watchdog/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -764,6 +764,12 @@
|
||||
help
|
||||
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
||||
|
||||
+config IFXMIPS_WDT
|
||||
+ bool "IFXMips watchdog"
|
||||
+ depends on IFXMIPS
|
||||
+ help
|
||||
+ Hardware driver for the IFXMIPS Watchdog Timer.
|
||||
+
|
||||
# PARISC Architecture
|
||||
|
||||
# POWERPC Architecture
|
|
@ -0,0 +1,29 @@
|
|||
Index: linux-2.6.30.5/drivers/leds/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/leds/Kconfig 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/leds/Kconfig 2009-09-02 18:29:51.000000000 +0200
|
||||
@@ -227,6 +227,12 @@
|
||||
This option enables support for BD2802GU RGB LED driver chips
|
||||
accessed via the I2C bus.
|
||||
|
||||
+config LEDS_IFXMIPS
|
||||
+ tristate "LED Support for IFXMIPS LEDs"
|
||||
+ depends on LEDS_CLASS && IFXMIPS
|
||||
+ help
|
||||
+ This option enables support for the CM-X270 LEDs.
|
||||
+
|
||||
comment "LED Triggers"
|
||||
|
||||
config LEDS_TRIGGERS
|
||||
Index: linux-2.6.30.5/drivers/leds/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/leds/Makefile 2009-09-02 18:22:49.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/leds/Makefile 2009-09-02 18:31:23.000000000 +0200
|
||||
@@ -27,6 +27,7 @@
|
||||
obj-$(CONFIG_LEDS_DA903X) += leds-da903x.o
|
||||
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
|
||||
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
||||
+obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
|
||||
|
||||
# LED SPI Drivers
|
||||
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
|
@ -1,13 +0,0 @@
|
|||
Index: linux-2.6.30.5/arch/mips/mm/cache.c
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/arch/mips/mm/cache.c 2009-09-02 18:31:37.000000000 +0200
|
||||
+++ linux-2.6.30.5/arch/mips/mm/cache.c 2009-09-02 18:31:42.000000000 +0200
|
||||
@@ -52,6 +52,8 @@
|
||||
void (*_dma_cache_inv)(unsigned long start, unsigned long size);
|
||||
|
||||
EXPORT_SYMBOL(_dma_cache_wback_inv);
|
||||
+EXPORT_SYMBOL(_dma_cache_wback);
|
||||
+EXPORT_SYMBOL(_dma_cache_inv);
|
||||
|
||||
#endif /* CONFIG_DMA_NONCOHERENT */
|
||||
|
Loading…
Reference in New Issue