mirror of https://github.com/hak5/openwrt.git
toolchain/musl: update to version 1.1.18
Signed-off-by: Felix Fietkau <nbd@nbd.name>openwrt-18.06
parent
6bcc1c5331
commit
981be0c3bd
|
@ -8,13 +8,13 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
PKG_NAME:=musl
|
PKG_NAME:=musl
|
||||||
PKG_VERSION:=1.1.16
|
PKG_VERSION:=1.1.18
|
||||||
PKG_RELEASE=1
|
PKG_RELEASE=1
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE_VERSION:=5f7efb87a28a311ad377dd26adf53715dedb096d
|
PKG_SOURCE_VERSION:=eb03bde2f24582874cb72b56c7811bf51da0c817
|
||||||
PKG_MIRROR_HASH:=da18ef24f270e5cae6bc4c440479da17bec1949ae5a1bc990352ca04f24c4378
|
PKG_MIRROR_HASH:=150808458007eeb0b977059f36f88127d1a1e80ddb6ad1837b5a63efd2958e34
|
||||||
PKG_SOURCE_URL:=git://git.musl-libc.org/musl
|
PKG_SOURCE_URL:=git://git.musl-libc.org/musl
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
|
||||||
|
|
||||||
|
|
|
@ -32,7 +32,7 @@
|
||||||
|
|
||||||
static int fuzzycmp(const unsigned char *a, const unsigned char *b)
|
static int fuzzycmp(const unsigned char *a, const unsigned char *b)
|
||||||
{
|
{
|
||||||
@@ -216,6 +220,7 @@ size_t iconv(iconv_t cd0, char **restric
|
@@ -224,6 +228,7 @@ size_t iconv(iconv_t cd0, char **restric
|
||||||
c = ((c-0xd7c0)<<10) + (d-0xdc00);
|
c = ((c-0xd7c0)<<10) + (d-0xdc00);
|
||||||
}
|
}
|
||||||
break;
|
break;
|
||||||
|
@ -40,14 +40,14 @@
|
||||||
case SHIFT_JIS:
|
case SHIFT_JIS:
|
||||||
if (c-0xa1 <= 0xdf-0xa1) {
|
if (c-0xa1 <= 0xdf-0xa1) {
|
||||||
c += 0xff61-0xa1;
|
c += 0xff61-0xa1;
|
||||||
@@ -362,6 +367,7 @@ size_t iconv(iconv_t cd0, char **restric
|
@@ -370,6 +375,7 @@ size_t iconv(iconv_t cd0, char **restric
|
||||||
c = ksc[c][d];
|
c = ksc[c][d];
|
||||||
if (!c) goto ilseq;
|
if (!c) goto ilseq;
|
||||||
break;
|
break;
|
||||||
+#endif
|
+#endif
|
||||||
default:
|
default:
|
||||||
if (c < 128+type) break;
|
if (c < 128+type) break;
|
||||||
c -= 128+type;
|
c = legacy_map(map, c);
|
||||||
--- a/src/locale/codepages.h
|
--- a/src/locale/codepages.h
|
||||||
+++ b/src/locale/codepages.h
|
+++ b/src/locale/codepages.h
|
||||||
@@ -118,6 +118,7 @@
|
@@ -118,6 +118,7 @@
|
||||||
|
|
Loading…
Reference in New Issue