mirror of https://github.com/hak5/openwrt.git
kernel: act_ctinfo: fixup build error on 4.14
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>master
parent
40842167d2
commit
943cc81b0f
|
@ -112,7 +112,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
|||
include/uapi/linux/tc_act/tc_ctinfo.h | 29 ++
|
||||
net/sched/Kconfig | 13 +
|
||||
net/sched/Makefile | 1 +
|
||||
net/sched/act_ctinfo.c | 404 ++++++++++++++++++++++++++
|
||||
net/sched/act_ctinfo.c | 405 ++++++++++++++++++++++++++
|
||||
6 files changed, 482 insertions(+), 1 deletion(-)
|
||||
create mode 100644 include/net/tc_act/tc_ctinfo.h
|
||||
create mode 100644 include/uapi/linux/tc_act/tc_ctinfo.h
|
||||
|
@ -232,7 +232,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
|||
obj-$(CONFIG_NET_IFE_SKBMARK) += act_meta_mark.o
|
||||
--- /dev/null
|
||||
+++ b/net/sched/act_ctinfo.c
|
||||
@@ -0,0 +1,404 @@
|
||||
@@ -0,0 +1,405 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0+
|
||||
+/* net/sched/act_ctinfo.c netfilter ctinfo connmark actions
|
||||
+ *
|
||||
|
@ -579,6 +579,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
|||
+ return tcf_idr_search(tn, a, index);
|
||||
+}
|
||||
+
|
||||
+static void tcf_ctinfo_cleanup(struct tc_action *a)
|
||||
+{
|
||||
+ struct tcf_ctinfo *ci = to_ctinfo(a);
|
||||
+ struct tcf_ctinfo_params *cp;
|
||||
|
|
Loading…
Reference in New Issue