mirror of https://github.com/hak5/openwrt.git
uboot-mxs: bump to v2020.01
Also update the U-Boot BSP patch for I2SE Duckbill devices. Run tested on I2SE Duckbill and Olimex OLinuXino Maxi boards. Signed-off-by: Michael Heimpold <mhei@heimpold.de>master
parent
a468a45253
commit
9405fb079b
|
@ -8,10 +8,10 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_VERSION:=2019.10
|
||||
PKG_VERSION:=2020.01
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_HASH:=8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829ca79667014
|
||||
PKG_HASH:=aa453c603208b1b27bd03525775a7f79b443adec577fdc6e8f06974025a135f1
|
||||
|
||||
include $(INCLUDE_DIR)/u-boot.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 821d083ae4cfb795eab385eda43a20cdc8c3cacd Mon Sep 17 00:00:00 2001
|
||||
From b66c70cd15fa02297b94d928970932ef62c2ff02 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Heimpold <mhei@heimpold.de>
|
||||
Date: Sun, 3 Nov 2019 00:50:21 +0100
|
||||
Subject: [PATCH] arm: mxs: add support for I2SE's Duckbill boards
|
||||
|
@ -32,9 +32,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
|||
board/i2se/duckbill/Makefile | 10 ++
|
||||
board/i2se/duckbill/duckbill.c | 186 ++++++++++++++++++++++++++++++++
|
||||
board/i2se/duckbill/iomux.c | 156 +++++++++++++++++++++++++++
|
||||
configs/duckbill_defconfig | 40 +++++++
|
||||
include/configs/duckbill.h | 179 ++++++++++++++++++++++++++++++
|
||||
8 files changed, 597 insertions(+)
|
||||
configs/duckbill_defconfig | 41 +++++++
|
||||
include/configs/duckbill.h | 176 ++++++++++++++++++++++++++++++
|
||||
8 files changed, 595 insertions(+)
|
||||
create mode 100644 board/i2se/duckbill/Kconfig
|
||||
create mode 100644 board/i2se/duckbill/MAINTAINERS
|
||||
create mode 100644 board/i2se/duckbill/Makefile
|
||||
|
@ -471,10 +471,10 @@ index 0000000000..1db3c52c34
|
|||
+}
|
||||
diff --git a/configs/duckbill_defconfig b/configs/duckbill_defconfig
|
||||
new file mode 100644
|
||||
index 0000000000..5a8c561b4e
|
||||
index 0000000000..fcdec4f3c7
|
||||
--- /dev/null
|
||||
+++ b/configs/duckbill_defconfig
|
||||
@@ -0,0 +1,40 @@
|
||||
@@ -0,0 +1,41 @@
|
||||
+CONFIG_ARM=y
|
||||
+CONFIG_ARCH_MX28=y
|
||||
+CONFIG_SYS_TEXT_BASE=0x40002000
|
||||
|
@ -483,6 +483,8 @@ index 0000000000..5a8c561b4e
|
|||
+CONFIG_SPL_LIBGENERIC_SUPPORT=y
|
||||
+CONFIG_TARGET_DUCKBILL=y
|
||||
+CONFIG_SPL_SERIAL_SUPPORT=y
|
||||
+CONFIG_ENV_SIZE=0x20000
|
||||
+CONFIG_ENV_OFFSET=0x20000
|
||||
+CONFIG_NR_DRAM_BANKS=1
|
||||
+CONFIG_SPL=y
|
||||
+CONFIG_SPL_TEXT_BASE=0x00001000
|
||||
|
@ -496,7 +498,6 @@ index 0000000000..5a8c561b4e
|
|||
+CONFIG_CMD_BOOTZ=y
|
||||
+# CONFIG_CMD_ELF is not set
|
||||
+CONFIG_CMD_UNZIP=y
|
||||
+# CONFIG_CMD_FLASH is not set
|
||||
+CONFIG_CMD_FUSE=y
|
||||
+CONFIG_CMD_GPIO=y
|
||||
+CONFIG_CMD_MMC=y
|
||||
|
@ -509,18 +510,18 @@ index 0000000000..5a8c561b4e
|
|||
+CONFIG_CMD_FS_GENERIC=y
|
||||
+CONFIG_DOS_PARTITION=y
|
||||
+CONFIG_ENV_IS_IN_MMC=y
|
||||
+CONFIG_SYS_RELOC_GD_ENV_ADDR=y
|
||||
+CONFIG_MXS_GPIO=y
|
||||
+CONFIG_MMC_MXS=y
|
||||
+CONFIG_MII=y
|
||||
+CONFIG_CONS_INDEX=0
|
||||
+CONFIG_OF_LIBFDT=y
|
||||
+# CONFIG_EFI_LOADER is not set
|
||||
diff --git a/include/configs/duckbill.h b/include/configs/duckbill.h
|
||||
new file mode 100644
|
||||
index 0000000000..e7fce8843e
|
||||
index 0000000000..76da1008b8
|
||||
--- /dev/null
|
||||
+++ b/include/configs/duckbill.h
|
||||
@@ -0,0 +1,179 @@
|
||||
@@ -0,0 +1,176 @@
|
||||
+/* SPDX-License-Identifier: GPL-2.0+ */
|
||||
+/*
|
||||
+ * Copyright (C) 2014-2019 Michael Heimpold <mhei@heimpold.de>
|
||||
|
@ -543,9 +544,6 @@ index 0000000000..e7fce8843e
|
|||
+
|
||||
+/* Environment is in MMC */
|
||||
+#define CONFIG_ENV_OVERWRITE
|
||||
+#define CONFIG_ENV_SIZE (128 * 1024)
|
||||
+#define CONFIG_ENV_OFFSET (128 * 1024)
|
||||
+#define CONFIG_ENV_OFFSET_REDUND (256 * 1024)
|
||||
+#define CONFIG_SYS_MMC_ENV_DEV 0
|
||||
+#define CONFIG_SYS_REDUNDAND_ENVIRONMENT
|
||||
+
|
||||
|
|
Loading…
Reference in New Issue