mirror of https://github.com/hak5/openwrt.git
ltq-vdsl-mei: activate format security checks
This activates the format warnings in this package and that makes it possible to activate format-security checks. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 48785lede-17.01
parent
29a36d1fd6
commit
93c59ac892
|
@ -19,7 +19,6 @@ PKG_MD5SUM:=78bf61dbc3421123c6716b874a930759
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
PKG_CHECK_FORMAT_SECURITY:=0
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
|
|
@ -24,3 +24,14 @@
|
||||||
|
|
||||||
if (pDynNfc->pRecvDataCntrl[pDynNfc->rdIdxRd].bufCtrl != MEI_RECV_BUF_CTRL_FREE) /* buffer in use */
|
if (pDynNfc->pRecvDataCntrl[pDynNfc->rdIdxRd].bufCtrl != MEI_RECV_BUF_CTRL_FREE) /* buffer in use */
|
||||||
{
|
{
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -201,7 +201,7 @@ else
|
||||||
|
|
||||||
|
drv_mei_cpe_common_cflags = \
|
||||||
|
$(AM_CFLAGS) -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB \
|
||||||
|
- -pipe -Wno-format -Wimplicit -Wunused -Wuninitialized -Wsign-compare -Wstrict-aliasing
|
||||||
|
+ -pipe -Wall -Wimplicit -Wunused -Wuninitialized -Wstrict-aliasing
|
||||||
|
|
||||||
|
endif
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue