rockchip: refresh NanoPi R2S patches

Update the patches for the NanoPi R2S to the v3 sent (and accepted)
upstream.

Signed-off-by: David Bauer <mail@david-bauer.net>
master
David Bauer 2020-09-13 06:45:52 +02:00
parent f29c7a1f30
commit 8b4233188d
4 changed files with 173 additions and 148 deletions

View File

@ -1,4 +1,4 @@
From 749cbb7b1a4bc2244b6af8cd7d8b471d4e33c80f Mon Sep 17 00:00:00 2001 From 0720be5371c806c1b89936984a321248fa739bea Mon Sep 17 00:00:00 2001
From: David Bauer <mail@david-bauer.net> From: David Bauer <mail@david-bauer.net>
Date: Fri, 10 Jul 2020 15:57:46 +0200 Date: Fri, 10 Jul 2020 15:57:46 +0200
Subject: [PATCH] rockchip: rk3328: Add support for FriendlyARM NanoPi R2S Subject: [PATCH] rockchip: rk3328: Add support for FriendlyARM NanoPi R2S
@ -17,8 +17,8 @@ WAN - LAN - SYS LED
Signed-off-by: David Bauer <mail@david-bauer.net> Signed-off-by: David Bauer <mail@david-bauer.net>
--- ---
arch/arm64/boot/dts/rockchip/Makefile | 1 + arch/arm64/boot/dts/rockchip/Makefile | 1 +
.../boot/dts/rockchip/rk3328-nanopi-r2s.dts | 334 ++++++++++++++++++ .../boot/dts/rockchip/rk3328-nanopi-r2s.dts | 368 ++++++++++++++++++
2 files changed, 335 insertions(+) 2 files changed, 369 insertions(+)
create mode 100644 arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts create mode 100644 arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
--- a/arch/arm64/boot/dts/rockchip/Makefile --- a/arch/arm64/boot/dts/rockchip/Makefile
@ -33,7 +33,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3368-evb-act8846.dtb dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3368-evb-act8846.dtb
--- /dev/null --- /dev/null
+++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts +++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
@@ -0,0 +1,334 @@ @@ -0,0 +1,368 @@
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT) +// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
+/* +/*
+ * Copyright (c) 2020 David Bauer <mail@david-bauer.net> + * Copyright (c) 2020 David Bauer <mail@david-bauer.net>
@ -46,92 +46,91 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+#include "rk3328.dtsi" +#include "rk3328.dtsi"
+ +
+/ { +/ {
+ model = "FriendlyARM NanoPi R2S"; + model = "FriendlyElec NanoPi R2S";
+ compatible = "friendlyarm,nanopi-r2s", "rockchip,rk3328"; + compatible = "friendlyarm,nanopi-r2s", "rockchip,rk3328";
+ +
+ chosen { + chosen {
+ stdout-path = "serial2:1500000n8"; + stdout-path = "serial2:1500000n8";
+ }; + };
+ +
+ gmac_clkin: external-gmac-clock { + gmac_clk: gmac-clock {
+ compatible = "fixed-clock"; + compatible = "fixed-clock";
+ clock-frequency = <125000000>; + clock-frequency = <125000000>;
+ clock-output-names = "gmac_clkin"; + clock-output-names = "gmac_clk";
+ #clock-cells = <0>; + #clock-cells = <0>;
+ }; + };
+ +
+ vcc_sd: sdmmc-regulator { + keys {
+ compatible = "regulator-fixed"; + compatible = "gpio-keys";
+ gpio = <&gpio0 RK_PD6 GPIO_ACTIVE_LOW>; + pinctrl-0 = <&reset_button_pin>;
+ pinctrl-names = "default"; + pinctrl-names = "default";
+ pinctrl-0 = <&sdmmc0m1_gpio>;
+ regulator-name = "vcc_sd";
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ vin-supply = <&vcc_io>;
+ };
+ +
+ vcc_sdio: sdmmcio-regulator { + reset {
+ compatible = "regulator-gpio"; + label = "reset";
+ gpios = <&gpio1 RK_PD4 GPIO_ACTIVE_HIGH>; + gpios = <&gpio0 RK_PA0 GPIO_ACTIVE_LOW>;
+ enable-active-high; + linux,code = <KEY_RESTART>;
+ states = <1800000 0x1 + debounce-interval = <50>;
+ 3300000 0x0>; + };
+ pinctrl-names = "default";
+ pinctrl-0 = <&sdio_vcc_pin>;
+ regulator-always-on;
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <3300000>;
+ regulator-name = "vcc_sdio";
+ regulator-settling-time-us = <5000>;
+ regulator-type = "voltage";
+ vin-supply = <&vcc_io>;
+ };
+
+ vcc_sys: vcc-sys {
+ compatible = "regulator-fixed";
+ regulator-name = "vcc_sys";
+ regulator-always-on;
+ regulator-boot-on;
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ }; + };
+ +
+ leds { + leds {
+ compatible = "gpio-leds"; + compatible = "gpio-leds";
+ + pinctrl-0 = <&lan_led_pin>, <&sys_led_pin>, <&wan_led_pin>;
+ pinctrl-names = "default"; + pinctrl-names = "default";
+ pinctrl-0 = <&led_pins>;
+ +
+ sys { + lan_led: led-0 {
+ gpios = <&gpio0 RK_PA2 GPIO_ACTIVE_HIGH>;
+ label = "nanopi-r2s:red:sys";
+ };
+
+ lan {
+ gpios = <&gpio2 RK_PB7 GPIO_ACTIVE_HIGH>; + gpios = <&gpio2 RK_PB7 GPIO_ACTIVE_HIGH>;
+ label = "nanopi-r2s:green:lan"; + label = "nanopi-r2s:green:lan";
+ }; + };
+ +
+ wan { + sys_led: led-1 {
+ gpios = <&gpio0 RK_PA2 GPIO_ACTIVE_HIGH>;
+ label = "nanopi-r2s:red:sys";
+ };
+
+ wan_led: led-2 {
+ gpios = <&gpio2 RK_PC2 GPIO_ACTIVE_HIGH>; + gpios = <&gpio2 RK_PC2 GPIO_ACTIVE_HIGH>;
+ label = "nanopi-r2s:green:wan"; + label = "nanopi-r2s:green:wan";
+ }; + };
+ }; + };
+ +
+ gpio_keys { + vcc_io_sdio: sdmmcio-regulator {
+ compatible = "gpio-keys-polled"; + compatible = "regulator-gpio";
+ poll-interval = <100>; + enable-active-high;
+ + gpios = <&gpio1 RK_PD4 GPIO_ACTIVE_HIGH>;
+ pinctrl-0 = <&sdio_vcc_pin>;
+ pinctrl-names = "default"; + pinctrl-names = "default";
+ pinctrl-0 = <&button_pins>; + regulator-name = "vcc_io_sdio";
+ regulator-always-on;
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <3300000>;
+ regulator-settling-time-us = <5000>;
+ regulator-type = "voltage";
+ startup-delay-us = <2000>;
+ states = <1800000 0x1
+ 3300000 0x0>;
+ vin-supply = <&vcc_io_33>;
+ };
+ +
+ reset { + vcc_sd: sdmmc-regulator {
+ label = "Reset Button"; + compatible = "regulator-fixed";
+ gpios = <&gpio0 RK_PA0 GPIO_ACTIVE_LOW>; + gpio = <&gpio0 RK_PD6 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>; + pinctrl-0 = <&sdmmc0m1_gpio>;
+ debounce-interval = <50>; + pinctrl-names = "default";
+ }; + regulator-name = "vcc_sd";
+ regulator-boot-on;
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ vin-supply = <&vcc_io_33>;
+ };
+
+ vdd_5v: vdd-5v {
+ compatible = "regulator-fixed";
+ regulator-name = "vdd_5v";
+ regulator-always-on;
+ regulator-boot-on;
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ }; + };
+}; +};
+ +
@ -153,19 +152,16 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ +
+&gmac2io { +&gmac2io {
+ assigned-clocks = <&cru SCLK_MAC2IO>, <&cru SCLK_MAC2IO_EXT>; + assigned-clocks = <&cru SCLK_MAC2IO>, <&cru SCLK_MAC2IO_EXT>;
+ assigned-clock-parents = <&gmac_clkin>, <&gmac_clkin>; + assigned-clock-parents = <&gmac_clk>, <&gmac_clk>;
+ clock_in_out = "input"; + clock_in_out = "input";
+ phy-supply = <&vcc_io>;
+ phy-handle = <&rtl8211e>; + phy-handle = <&rtl8211e>;
+ phy-mode = "rgmii"; + phy-mode = "rgmii";
+ pinctrl-names = "default"; + phy-supply = <&vcc_io_33>;
+ pinctrl-0 = <&rgmiim1_pins>; + pinctrl-0 = <&rgmiim1_pins>;
+ snps,aal; + pinctrl-names = "default";
+ snps,reset-gpio = <&gpio1 RK_PC2 GPIO_ACTIVE_LOW>;
+ snps,reset-active-low;
+ snps,reset-delays-us = <0 10000 50000>;
+ tx_delay = <0x24>;
+ rx_delay = <0x18>; + rx_delay = <0x18>;
+ snps,aal;
+ tx_delay = <0x24>;
+ status = "okay"; + status = "okay";
+ +
+ mdio { + mdio {
@ -173,8 +169,13 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ #address-cells = <1>; + #address-cells = <1>;
+ #size-cells = <0>; + #size-cells = <0>;
+ +
+ rtl8211e: ethernet-phy@0 { + rtl8211e: ethernet-phy@1 {
+ reg = <0>; + reg = <1>;
+ pinctrl-0 = <&eth_phy_reset_pin>;
+ pinctrl-names = "default";
+ reset-assert-us = <10000>;
+ reset-deassert-us = <50000>;
+ reset-gpios = <&gpio1 RK_PC2 GPIO_ACTIVE_LOW>;
+ }; + };
+ }; + };
+}; +};
@ -182,35 +183,36 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+&i2c1 { +&i2c1 {
+ status = "okay"; + status = "okay";
+ +
+ rk805: rk805@18 { + rk805: pmic@18 {
+ compatible = "rockchip,rk805"; + compatible = "rockchip,rk805";
+ reg = <0x18>; + reg = <0x18>;
+ interrupt-parent = <&gpio2>; + interrupt-parent = <&gpio1>;
+ interrupts = <6 IRQ_TYPE_LEVEL_LOW>; + interrupts = <24 IRQ_TYPE_LEVEL_LOW>;
+ #clock-cells = <1>; + #clock-cells = <1>;
+ clock-output-names = "xin32k", "rk805-clkout2"; + clock-output-names = "xin32k", "rk805-clkout2";
+ gpio-controller; + gpio-controller;
+ #gpio-cells = <2>; + #gpio-cells = <2>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&pmic_int_l>; + pinctrl-0 = <&pmic_int_l>;
+ pinctrl-names = "default";
+ rockchip,system-power-controller; + rockchip,system-power-controller;
+ wakeup-source; + wakeup-source;
+ +
+ vcc1-supply = <&vcc_sys>; + vcc1-supply = <&vdd_5v>;
+ vcc2-supply = <&vcc_sys>; + vcc2-supply = <&vdd_5v>;
+ vcc3-supply = <&vcc_sys>; + vcc3-supply = <&vdd_5v>;
+ vcc4-supply = <&vcc_sys>; + vcc4-supply = <&vdd_5v>;
+ vcc5-supply = <&vcc_io>; + vcc5-supply = <&vcc_io_33>;
+ vcc6-supply = <&vcc_sys>; + vcc6-supply = <&vdd_5v>;
+ +
+ regulators { + regulators {
+ vdd_logic: DCDC_REG1 { + vdd_log: DCDC_REG1 {
+ regulator-name = "vdd_logic"; + regulator-name = "vdd_log";
+ regulator-always-on;
+ regulator-boot-on;
+ regulator-min-microvolt = <712500>; + regulator-min-microvolt = <712500>;
+ regulator-max-microvolt = <1450000>; + regulator-max-microvolt = <1450000>;
+ regulator-ramp-delay = <12500>; + regulator-ramp-delay = <12500>;
+ regulator-always-on; +
+ regulator-boot-on;
+ regulator-state-mem { + regulator-state-mem {
+ regulator-on-in-suspend; + regulator-on-in-suspend;
+ regulator-suspend-microvolt = <1000000>; + regulator-suspend-microvolt = <1000000>;
@ -219,11 +221,12 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ +
+ vdd_arm: DCDC_REG2 { + vdd_arm: DCDC_REG2 {
+ regulator-name = "vdd_arm"; + regulator-name = "vdd_arm";
+ regulator-always-on;
+ regulator-boot-on;
+ regulator-min-microvolt = <712500>; + regulator-min-microvolt = <712500>;
+ regulator-max-microvolt = <1450000>; + regulator-max-microvolt = <1450000>;
+ regulator-ramp-delay = <12500>; + regulator-ramp-delay = <12500>;
+ regulator-always-on; +
+ regulator-boot-on;
+ regulator-state-mem { + regulator-state-mem {
+ regulator-on-in-suspend; + regulator-on-in-suspend;
+ regulator-suspend-microvolt = <950000>; + regulator-suspend-microvolt = <950000>;
@ -234,17 +237,19 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ regulator-name = "vcc_ddr"; + regulator-name = "vcc_ddr";
+ regulator-always-on; + regulator-always-on;
+ regulator-boot-on; + regulator-boot-on;
+
+ regulator-state-mem { + regulator-state-mem {
+ regulator-on-in-suspend; + regulator-on-in-suspend;
+ }; + };
+ }; + };
+ +
+ vcc_io: DCDC_REG4 { + vcc_io_33: DCDC_REG4 {
+ regulator-name = "vcc_io"; + regulator-name = "vcc_io_33";
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ regulator-always-on; + regulator-always-on;
+ regulator-boot-on; + regulator-boot-on;
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+
+ regulator-state-mem { + regulator-state-mem {
+ regulator-on-in-suspend; + regulator-on-in-suspend;
+ regulator-suspend-microvolt = <3300000>; + regulator-suspend-microvolt = <3300000>;
@ -253,10 +258,11 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ +
+ vcc_18: LDO_REG1 { + vcc_18: LDO_REG1 {
+ regulator-name = "vcc_18"; + regulator-name = "vcc_18";
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <1800000>;
+ regulator-always-on; + regulator-always-on;
+ regulator-boot-on; + regulator-boot-on;
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <1800000>;
+
+ regulator-state-mem { + regulator-state-mem {
+ regulator-on-in-suspend; + regulator-on-in-suspend;
+ regulator-suspend-microvolt = <1800000>; + regulator-suspend-microvolt = <1800000>;
@ -265,10 +271,11 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ +
+ vcc18_emmc: LDO_REG2 { + vcc18_emmc: LDO_REG2 {
+ regulator-name = "vcc18_emmc"; + regulator-name = "vcc18_emmc";
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <1800000>;
+ regulator-always-on; + regulator-always-on;
+ regulator-boot-on; + regulator-boot-on;
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <1800000>;
+
+ regulator-state-mem { + regulator-state-mem {
+ regulator-on-in-suspend; + regulator-on-in-suspend;
+ regulator-suspend-microvolt = <1800000>; + regulator-suspend-microvolt = <1800000>;
@ -277,10 +284,11 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ +
+ vdd_10: LDO_REG3 { + vdd_10: LDO_REG3 {
+ regulator-name = "vdd_10"; + regulator-name = "vdd_10";
+ regulator-min-microvolt = <1000000>;
+ regulator-max-microvolt = <1000000>;
+ regulator-always-on; + regulator-always-on;
+ regulator-boot-on; + regulator-boot-on;
+ regulator-min-microvolt = <1000000>;
+ regulator-max-microvolt = <1000000>;
+
+ regulator-state-mem { + regulator-state-mem {
+ regulator-on-in-suspend; + regulator-on-in-suspend;
+ regulator-suspend-microvolt = <1000000>; + regulator-suspend-microvolt = <1000000>;
@ -291,35 +299,46 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+}; +};
+ +
+&io_domains { +&io_domains {
+ status = "okay"; + pmuio-supply = <&vcc_io_33>;
+ + vccio1-supply = <&vcc_io_33>;
+ vccio1-supply = <&vcc_io>;
+ vccio2-supply = <&vcc18_emmc>; + vccio2-supply = <&vcc18_emmc>;
+ vccio3-supply = <&vcc_sdio>; + vccio3-supply = <&vcc_io_sdio>;
+ vccio4-supply = <&vcc_18>; + vccio4-supply = <&vcc_18>;
+ vccio5-supply = <&vcc_io>; + vccio5-supply = <&vcc_io_33>;
+ vccio6-supply = <&vcc_io>; + vccio6-supply = <&vcc_io_33>;
+ pmuio-supply = <&vcc_io>; + status = "okay";
+}; +};
+ +
+&pinctrl { +&pinctrl {
+ leds { + button {
+ led_pins: led-pins { + reset_button_pin: reset-button-pin {
+ rockchip,pins = <0 RK_PA2 RK_FUNC_GPIO &pcfg_pull_none>, + rockchip,pins = <0 RK_PA0 RK_FUNC_GPIO &pcfg_pull_none>;
+ <2 RK_PB7 RK_FUNC_GPIO &pcfg_pull_none>,
+ <2 RK_PC2 RK_FUNC_GPIO &pcfg_pull_none>;
+ }; + };
+ }; + };
+ +
+ button { + ethernet-phy {
+ button_pins: button-pins { + eth_phy_reset_pin: eth-phy-reset-pin {
+ rockchip,pins = <0 RK_PA0 RK_FUNC_GPIO &pcfg_pull_none>; + rockchip,pins = <1 RK_PC2 RK_FUNC_GPIO &pcfg_pull_down>;
+ };
+ };
+
+ leds {
+ lan_led_pin: lan-led-pin {
+ rockchip,pins = <2 RK_PB7 RK_FUNC_GPIO &pcfg_pull_none>;
+ };
+
+ sys_led_pin: sys-led-pin {
+ rockchip,pins = <0 RK_PA2 RK_FUNC_GPIO &pcfg_pull_none>;
+ };
+
+ wan_led_pin: wan-led-pin {
+ rockchip,pins = <2 RK_PC2 RK_FUNC_GPIO &pcfg_pull_none>;
+ }; + };
+ }; + };
+ +
+ pmic { + pmic {
+ pmic_int_l: pmic-int-l { + pmic_int_l: pmic-int-l {
+ rockchip,pins = <2 RK_PA6 RK_FUNC_GPIO &pcfg_pull_up>; + rockchip,pins = <1 RK_PD0 RK_FUNC_GPIO &pcfg_pull_up>;
+ }; + };
+ }; + };
+ +
@ -330,16 +349,22 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ }; + };
+}; +};
+ +
+&pwm2 {
+ status = "okay";
+};
+
+&sdmmc { +&sdmmc {
+ bus-width = <4>; + bus-width = <4>;
+ cap-mmc-highspeed;
+ cap-sd-highspeed; + cap-sd-highspeed;
+ disable-wp; + disable-wp;
+ max-frequency = <150000000>; + pinctrl-0 = <&sdmmc0_clk>, <&sdmmc0_cmd>, <&sdmmc0_dectn>, <&sdmmc0_bus4>;
+ pinctrl-names = "default"; + pinctrl-names = "default";
+ pinctrl-0 = <&sdmmc0_clk &sdmmc0_cmd &sdmmc0_dectn &sdmmc0_bus4>; + sd-uhs-sdr12;
+ sd-uhs-sdr25;
+ sd-uhs-sdr50;
+ sd-uhs-sdr104;
+ vmmc-supply = <&vcc_sd>; + vmmc-supply = <&vcc_sd>;
+ vqmmc-supply = <&vcc_sdio>; + vqmmc-supply = <&vcc_io_sdio>;
+ status = "okay"; + status = "okay";
+}; +};
+ +
@ -349,16 +374,25 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ status = "okay"; + status = "okay";
+}; +};
+ +
+&u2phy {
+ status = "okay";
+};
+
+&u2phy_host {
+ status = "okay";
+};
+
+&u2phy_otg {
+ status = "okay";
+};
+
+&uart2 { +&uart2 {
+ status = "okay"; + status = "okay";
+}; +};
+ +
+&u2phy { +&usb20_otg {
+ status = "okay"; + status = "okay";
+ + dr_mode = "host";
+ u2phy_host: host-port {
+ status = "okay";
+ };
+}; +};
+ +
+&usb_host0_ehci { +&usb_host0_ehci {

View File

@ -15,26 +15,17 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
--- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts --- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts +++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
@@ -17,6 +17,13 @@ @@ -13,6 +13,13 @@
stdout-path = "serial2:1500000n8"; model = "FriendlyElec NanoPi R2S";
}; compatible = "friendlyarm,nanopi-r2s", "rockchip,rk3328";
+ aliases { + aliases {
+ led-boot = &led_sys; + led-boot = &sys_led;
+ led-failsafe = &led_sys; + led-failsafe = &sys_led;
+ led-running = &led_sys; + led-running = &sys_led;
+ led-upgrade = &led_sys; + led-upgrade = &sys_led;
+ }; + };
+ +
gmac_clkin: external-gmac-clock { chosen {
compatible = "fixed-clock"; stdout-path = "serial2:1500000n8";
clock-frequency = <125000000>; };
@@ -67,7 +74,7 @@
pinctrl-names = "default";
pinctrl-0 = <&led_pins>;
- sys {
+ led_sys: sys {
gpios = <&gpio0 RK_PA2 GPIO_ACTIVE_HIGH>;
label = "nanopi-r2s:red:sys";
};

View File

@ -13,8 +13,8 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
--- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts --- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts +++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
@@ -68,6 +68,18 @@ @@ -44,6 +44,18 @@
regulator-max-microvolt = <5000000>; };
}; };
+ vcc_rtl8153: vcc-rtl8153-regulator { + vcc_rtl8153: vcc-rtl8153-regulator {
@ -31,9 +31,9 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ +
leds { leds {
compatible = "gpio-leds"; compatible = "gpio-leds";
pinctrl-0 = <&lan_led_pin>, <&sys_led_pin>, <&wan_led_pin>;
@@ -299,6 +311,12 @@ @@ -267,6 +279,12 @@
rockchip,pins = <1 RK_PD4 RK_FUNC_GPIO &pcfg_pull_up>; };
}; };
}; };
+ +
@ -44,8 +44,8 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+ }; + };
}; };
&sdmmc { &io_domains {
@@ -339,3 +357,12 @@ @@ -373,3 +391,12 @@
&usb_host0_ohci { &usb_host0_ohci {
status = "okay"; status = "okay";
}; };

View File

@ -14,7 +14,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
--- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts --- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts +++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
@@ -365,4 +365,11 @@ @@ -399,4 +399,11 @@
&usbdrd_dwc3 { &usbdrd_dwc3 {
dr_mode = "host"; dr_mode = "host";
status = "okay"; status = "okay";