mirror of https://github.com/hak5/openwrt.git
dropbear: bump to 2019.78
Fix dbclient regression in 2019.77. After exiting the terminal would be left in a bad state. Reported by Ryan Woodsmall drop patch applied upstream: 010-tty-modes-werent-reset-for-client.patch Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>openwrt-19.07
parent
310e2764a8
commit
80568e5854
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dropbear
|
||||
PKG_VERSION:=2019.77
|
||||
PKG_VERSION:=2019.78
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:= \
|
||||
http://matt.ucc.asn.au/dropbear/releases/ \
|
||||
https://dropbear.nl/mirror/releases/
|
||||
PKG_HASH:=d91f78ebe633be1d071fd1b7e5535b9693794048b019e9f4bea257e1992b458d
|
||||
PKG_HASH:=525965971272270995364a0eb01f35180d793182e63dd0b0c3eb0292291644a4
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
Hash: 7bc6280613f5ab4ee86c14c779739070e5784dfe
|
||||
From: Matt Johnston <matt@ucc.asn.au>
|
||||
Date: Sun, 24 Mar 2019 20:41:02 +0800
|
||||
Subject: Fix regression where TTY modes weren't reset for client
|
||||
|
||||
--- a/cli-chansession.c
|
||||
+++ b/cli-chansession.c
|
||||
@@ -35,7 +35,7 @@
|
||||
#include "chansession.h"
|
||||
#include "agentfwd.h"
|
||||
|
||||
-static void cli_cleanupchansess(const struct Channel *channel);
|
||||
+static void cli_closechansess(const struct Channel *channel);
|
||||
static int cli_initchansess(struct Channel *channel);
|
||||
static void cli_chansessreq(struct Channel *channel);
|
||||
static void send_chansess_pty_req(const struct Channel *channel);
|
||||
@@ -51,8 +51,8 @@ const struct ChanType clichansess = {
|
||||
cli_initchansess, /* inithandler */
|
||||
NULL, /* checkclosehandler */
|
||||
cli_chansessreq, /* reqhandler */
|
||||
- NULL, /* closehandler */
|
||||
- cli_cleanupchansess, /* cleanup */
|
||||
+ cli_closechansess, /* closehandler */
|
||||
+ NULL, /* cleanup */
|
||||
};
|
||||
|
||||
static void cli_chansessreq(struct Channel *channel) {
|
||||
@@ -84,7 +84,7 @@ out:
|
||||
|
||||
|
||||
/* If the main session goes, we close it up */
|
||||
-static void cli_cleanupchansess(const struct Channel *UNUSED(channel)) {
|
||||
+static void cli_closechansess(const struct Channel *UNUSED(channel)) {
|
||||
cli_tty_cleanup(); /* Restore tty modes etc */
|
||||
|
||||
/* This channel hasn't gone yet, so we have > 1 */
|
||||
@@ -388,8 +388,8 @@ static const struct ChanType cli_chan_ne
|
||||
cli_init_netcat, /* inithandler */
|
||||
NULL,
|
||||
NULL,
|
||||
+ cli_closechansess,
|
||||
NULL,
|
||||
- cli_cleanupchansess
|
||||
};
|
||||
|
||||
void cli_send_netcat_request() {
|
Loading…
Reference in New Issue