mirror of https://github.com/hak5/openwrt.git
2.6.28: add flashmap and image support for the sitecom wl-176. Thanks Daniel Gimpelevich
SVN-Revision: 18300lede-17.01
parent
acfd2f0eb4
commit
7de27db174
|
@ -1,6 +1 @@
|
|||
CONFIG_MTD_RDC3210=y
|
||||
CONFIG_MTD_RDC3210_ALLOW_JFFS2=y
|
||||
CONFIG_MTD_RDC3210_BUSWIDTH=2
|
||||
# CONFIG_MTD_RDC3210_FACTORY_PRESENT is not set
|
||||
CONFIG_MTD_RDC3210_SIZE=0x200000
|
||||
# CONFIG_MTD_RDC3210_STATIC_MAP is not set
|
||||
# CONFIG_BLK_DEV_INITRD is not set
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# Copyright (C) 2006-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -21,6 +21,10 @@ define trxalign/squashfs
|
|||
bs=1024
|
||||
endef
|
||||
|
||||
define Image/Prepare/squashfs
|
||||
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
|
||||
endef
|
||||
|
||||
define Image/Build/ar525w
|
||||
touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
|
||||
touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
|
||||
|
@ -30,15 +34,24 @@ define Image/Build/ar525w
|
|||
$(STAGING_DIR_HOST)/bin/airlink -e -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
|
||||
endef
|
||||
|
||||
define Image/Prepare/wl153/squashfs
|
||||
dd if=/dev/null of=$(KDIR)/root.tmp seek=1 bs=32k
|
||||
echo -n "0123456789abcdef0123" >> $(KDIR)/root.tmp
|
||||
cat $(KDIR)/bzImage $(KDIR)/root.squashfs >> $(KDIR)/root.tmp
|
||||
dd if=$(KDIR)/root.tmp of=$(KDIR)/root2.tmp bs=64k conv=sync
|
||||
dd if=$(KDIR)/root2.tmp of=$(KDIR)/root.squashfs bs=1 skip=$$$$[0x$$$$(cat $(KDIR)/bzSize) + 0x8014]
|
||||
$(call add_jffs2_mark,$(KDIR)/root.squashfs)
|
||||
endef
|
||||
|
||||
define Image/Build/wl153
|
||||
ls -l $(KDIR)/bzImage | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/bzSize
|
||||
gzip -9c $(KDIR)/root.$(1) > $(KDIR)/root.$(1).gz
|
||||
ls -l $(KDIR)/root.$(1).gz | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/rdSize
|
||||
$(call Image/Prepare/wl153/$(1))
|
||||
ls -l $(KDIR)/root.$(1) | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/rdSize
|
||||
echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/bzSize)\x$$$$(cut -c 5,6 < $(KDIR)/bzSize)\x$$$$(cut -c 3,4 < $(KDIR)/bzSize)\x$$$$(cut -c 1,2 < $(KDIR)/bzSize)" > $(KDIR)/bzSize.tmp
|
||||
echo -n 'CSYS' > $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
|
||||
cat $(KDIR)/bzSize.tmp >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
|
||||
echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/rdSize)\x$$$$(cut -c 5,6 < $(KDIR)/rdSize)\x$$$$(cut -c 3,4 < $(KDIR)/rdSize)\x$$$$(cut -c 1,2 < $(KDIR)/rdSize)WRRM" >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
|
||||
cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1).gz >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
|
||||
cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
|
||||
$(RM) $(KDIR)/bzSize.tmp $(KDIR)/bzSize $(KDIR)/rdSize
|
||||
if [ `ls -l $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/'` -gt $$$$((0xffff0000-0xffe08000)) ]; then mv $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img.too_big; echo "#ERR image too big"; fi
|
||||
endef
|
||||
|
@ -51,6 +64,7 @@ define Image/Build/dir450
|
|||
endef
|
||||
|
||||
define Image/Build/g570s
|
||||
$(call Image/Prepare/$(1))
|
||||
mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
|
||||
dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
|
||||
$(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-tftp-$(BOARD)-$(1)-$(2).img
|
||||
|
@ -62,6 +76,7 @@ define Image/Build/g570s
|
|||
endef
|
||||
|
||||
define Image/Build/amit
|
||||
$(call Image/Prepare/$(1))
|
||||
if [ ! -x $(STAGING_DIR_HOST)/bin/amit_makebin ]; then echo "#ERR Please copy the AMIT \"makebin\" tool from http://mgb111.pradnik.net/ as $(STAGING_DIR_HOST)/bin/amit_makebin to build."; fi
|
||||
sh -c "mkdir -p $(KDIR)/amit.tmp/linux_src/arch/i386/boot $(KDIR)/amit.tmp/rom_disk && cd $(KDIR)/amit.tmp && ln -s ../../root.$(1) rom_disk/fs.img && ln -s ../../../../../bzImage linux_src/arch/i386/boot && $(STAGING_DIR_HOST)/bin/amit_makebin && mv upgrade.img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-anas350.bin" || :
|
||||
$(RM) -r $(KDIR)/amit.tmp
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
Index: linux-2.6.28.10/arch/x86/mach-rdc321x/gpio.c
|
||||
===================================================================
|
||||
--- linux-2.6.28.10.orig/arch/x86/mach-rdc321x/gpio.c 2009-05-02 11:54:43.000000000 -0700
|
||||
+++ linux-2.6.28.10/arch/x86/mach-rdc321x/gpio.c 2009-10-30 22:24:23.779705091 -0700
|
||||
--- linux-2.6.28.10.orig/arch/x86/mach-rdc321x/gpio.c 2009-11-03 21:01:29.800401126 -0800
|
||||
+++ linux-2.6.28.10/arch/x86/mach-rdc321x/gpio.c 2009-11-03 21:01:32.164401226 -0800
|
||||
@@ -26,7 +26,7 @@
|
||||
#include <linux/types.h>
|
||||
#include <linux/module.h>
|
||||
|
@ -39,8 +39,8 @@ Index: linux-2.6.28.10/arch/x86/mach-rdc321x/gpio.c
|
|||
+arch_initcall(rdc321x_gpio_setup);
|
||||
Index: linux-2.6.28.10/arch/x86/mach-rdc321x/platform.c
|
||||
===================================================================
|
||||
--- linux-2.6.28.10.orig/arch/x86/mach-rdc321x/platform.c 2009-05-02 11:54:43.000000000 -0700
|
||||
+++ linux-2.6.28.10/arch/x86/mach-rdc321x/platform.c 2009-10-30 22:37:01.595670310 -0700
|
||||
--- linux-2.6.28.10.orig/arch/x86/mach-rdc321x/platform.c 2009-11-03 21:01:29.836402559 -0800
|
||||
+++ linux-2.6.28.10/arch/x86/mach-rdc321x/platform.c 2009-11-03 21:13:27.212398945 -0800
|
||||
@@ -1,7 +1,9 @@
|
||||
/*
|
||||
* Generic RDC321x platform devices
|
||||
|
@ -113,7 +113,7 @@ Index: linux-2.6.28.10/arch/x86/mach-rdc321x/platform.c
|
|||
};
|
||||
|
||||
static struct gpio_led_platform_data rdc321x_led_data = {
|
||||
@@ -54,16 +102,163 @@
|
||||
@@ -54,16 +102,189 @@
|
||||
.num_resources = 0,
|
||||
};
|
||||
|
||||
|
@ -174,7 +174,7 @@ Index: linux-2.6.28.10/arch/x86/mach-rdc321x/platform.c
|
|||
- rdc321x_gpio_setup();
|
||||
+#ifndef CONFIG_MTD_RDC3210
|
||||
+ struct map_info rdc_map_info;
|
||||
+ u32 the_header[4];
|
||||
+ u32 the_header[8];
|
||||
|
||||
+ ROOT_DEV = 0;
|
||||
+ rdc_map_info.name = rdc_flash_device.name;
|
||||
|
@ -198,10 +198,36 @@ Index: linux-2.6.28.10/arch/x86/mach-rdc321x/platform.c
|
|||
+ the_header[2] = ((u32 *)rdc_map_info.virt)[2];
|
||||
+ the_header[3] = ((u32 *)rdc_map_info.virt)[3];
|
||||
+ iounmap(rdc_map_info.virt);
|
||||
+ rdc_map_info.virt = ioremap_nocache(rdc_map_info.phys + 0x8000, 0x10);
|
||||
+ if (rdc_map_info.virt == NULL)
|
||||
+ panic("Could not ioremap to read device magic!");
|
||||
+ the_header[4] = ((u32 *)rdc_map_info.virt)[0];
|
||||
+ the_header[5] = ((u32 *)rdc_map_info.virt)[1];
|
||||
+ the_header[6] = ((u32 *)rdc_map_info.virt)[2];
|
||||
+ the_header[7] = ((u32 *)rdc_map_info.virt)[3];
|
||||
+ iounmap(rdc_map_info.virt);
|
||||
+ if (!memcmp(the_header, "GMTK", 4)) { /* Gemtek */
|
||||
+ /* TODO */
|
||||
+ } else if (!memcmp(the_header, "CSYS", 4)) { /* Sitecom */
|
||||
+ /* TODO */
|
||||
+ } else if (!memcmp(the_header + 4, "CSYS", 4)) { /* Sitecom */
|
||||
+ rdc_flash_parts[0].name = "system";
|
||||
+ rdc_flash_parts[0].offset = 0;
|
||||
+ rdc_flash_parts[0].size = rdc_map_info.size - 0x10000;
|
||||
+ rdc_flash_parts[1].name = "config";
|
||||
+ rdc_flash_parts[1].offset = 0;
|
||||
+ rdc_flash_parts[1].size = 0x8000;
|
||||
+ rdc_flash_parts[2].name = "magic";
|
||||
+ rdc_flash_parts[2].offset = 0x8000;
|
||||
+ rdc_flash_parts[2].size = 0x14;
|
||||
+ rdc_flash_parts[3].name = "kernel";
|
||||
+ rdc_flash_parts[3].offset = 0x8014;
|
||||
+ rdc_flash_parts[3].size = the_header[5];
|
||||
+ rdc_flash_parts[4].name = "rootfs";
|
||||
+ rdc_flash_parts[4].offset = 0x8014 + the_header[5];
|
||||
+ rdc_flash_parts[4].size = rdc_flash_parts[0].size - rdc_flash_parts[4].offset;
|
||||
+ rdc_flash_parts[5].name = "bootloader";
|
||||
+ rdc_flash_parts[5].offset = rdc_flash_parts[0].size;
|
||||
+ rdc_flash_parts[5].size = 0x10000;
|
||||
+ rdc_flash_data.nr_parts = 6;
|
||||
+ } else if (!memcmp(((u8 *)the_header) + 14, "Li", 2)) { /* AMIT */
|
||||
+ rdc_flash_parts[0].name = "kernel_parthdr";
|
||||
+ rdc_flash_parts[0].offset = 0;
|
||||
|
@ -281,8 +307,8 @@ Index: linux-2.6.28.10/arch/x86/mach-rdc321x/platform.c
|
|||
+#endif
|
||||
Index: linux-2.6.28.10/arch/x86/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.28.10.orig/arch/x86/Makefile 2009-05-02 11:54:43.000000000 -0700
|
||||
+++ linux-2.6.28.10/arch/x86/Makefile 2009-10-30 22:04:55.444672426 -0700
|
||||
--- linux-2.6.28.10.orig/arch/x86/Makefile 2009-11-03 21:01:29.756400281 -0800
|
||||
+++ linux-2.6.28.10/arch/x86/Makefile 2009-11-03 21:01:32.164401226 -0800
|
||||
@@ -113,6 +113,10 @@
|
||||
mflags-$(CONFIG_X86_VOYAGER) := -Iarch/x86/include/asm/mach-voyager
|
||||
mcore-$(CONFIG_X86_VOYAGER) := arch/x86/mach-voyager/
|
||||
|
@ -296,8 +322,8 @@ Index: linux-2.6.28.10/arch/x86/Makefile
|
|||
fcore-$(CONFIG_X86_GENERICARCH) += arch/x86/mach-generic/
|
||||
Index: linux-2.6.28.10/arch/x86/include/asm/mach-rdc321x/gpio.h
|
||||
===================================================================
|
||||
--- linux-2.6.28.10.orig/arch/x86/include/asm/mach-rdc321x/gpio.h 2009-10-30 22:31:04.680702348 -0700
|
||||
+++ linux-2.6.28.10/arch/x86/include/asm/mach-rdc321x/gpio.h 2009-10-30 22:34:24.024670851 -0700
|
||||
--- linux-2.6.28.10.orig/arch/x86/include/asm/mach-rdc321x/gpio.h 2009-11-03 21:01:29.784401606 -0800
|
||||
+++ linux-2.6.28.10/arch/x86/include/asm/mach-rdc321x/gpio.h 2009-11-03 21:01:32.164401226 -0800
|
||||
@@ -9,7 +9,6 @@
|
||||
extern int rdc_gpio_direction_output(unsigned gpio, int value);
|
||||
extern int rdc_gpio_request(unsigned gpio, const char *label);
|
||||
|
|
Loading…
Reference in New Issue