mirror of https://github.com/hak5/openwrt.git
parent
4f947e034a
commit
6cddb03df2
|
@ -3,9 +3,9 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pptpd
|
PKG_NAME:=pptpd
|
||||||
PKG_VERSION:=1.2.3
|
PKG_VERSION:=1.3.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=2
|
||||||
PKG_MD5SUM:=a521e40ca304b0c125cc25f9b9d03324
|
PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
|
||||||
|
|
||||||
PKG_SOURCE_URL:=@SF/poptop
|
PKG_SOURCE_URL:=@SF/poptop
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
|
@ -9,7 +9,7 @@ PID_F=$RUN_D/$BIN.pid
|
||||||
case $1 in
|
case $1 in
|
||||||
start)
|
start)
|
||||||
mkdir -p $RUN_D
|
mkdir -p $RUN_D
|
||||||
for m in arc4 sha1 slhc ppp_generic ppp_async ppp_mppe_mppc; do
|
for m in arc4 sha1 slhc crc-ccitt ppp_generic ppp_async ppp_mppe_mppc; do
|
||||||
insmod $m >/dev/null 2>&1
|
insmod $m >/dev/null 2>&1
|
||||||
done
|
done
|
||||||
$BIN $OPTIONS
|
$BIN $OPTIONS
|
||||||
|
|
|
@ -0,0 +1,20 @@
|
||||||
|
diff -urN pptpd-1.3.0/pqueue.c.orig pptpd-1.3.0/pqueue.c
|
||||||
|
--- pptpd-1.3.0/pqueue.c.orig 2006-04-17 20:44:28.000000000 -0400
|
||||||
|
+++ pptpd-1.3.0/pqueue.c 2006-04-17 20:44:58.000000000 -0400
|
||||||
|
@@ -6,14 +6,11 @@
|
||||||
|
#include "pqueue.h"
|
||||||
|
|
||||||
|
#ifdef DEBUG_PQUEUE
|
||||||
|
-#define DEBUG_ON 1
|
||||||
|
+#define DEBUG_CMD(_a) { _a }
|
||||||
|
#else
|
||||||
|
-#define DEBUG_ON 0
|
||||||
|
+#define DEBUG_CMD(_a)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define DEBUG_CMD(_a) if (DEBUG_ON) { _a }
|
||||||
|
-
|
||||||
|
-
|
||||||
|
#define MIN_CAPACITY 128 /* min allocated buffer for a packet */
|
||||||
|
|
||||||
|
static int pqueue_alloc (int seq, unsigned char *packet, int packlen, pqueue_t **new);
|
|
@ -0,0 +1,35 @@
|
||||||
|
diff -Nur pptpd-1.3.0/pptpgre.c.orig pptpd-1.3.0/pptpgre.c
|
||||||
|
--- pptpd-1.3.0/pptpgre.c.orig 2006-04-18 02:13:10.000000000 -0400
|
||||||
|
+++ pptpd-1.3.0/pptpgre.c 2006-04-18 02:14:19.000000000 -0400
|
||||||
|
@@ -46,6 +46,9 @@
|
||||||
|
|
||||||
|
#define PACKET_MAX 8196
|
||||||
|
|
||||||
|
+/* Command Line Variable Args */
|
||||||
|
+extern int pptpctrl_debug;
|
||||||
|
+
|
||||||
|
typedef int (*callback_t)(int cl, void *pack, unsigned int len);
|
||||||
|
|
||||||
|
/* test for a 32 bit counter overflow */
|
||||||
|
@@ -319,7 +322,9 @@
|
||||||
|
stats.rx_lost += head->seq - gre.seq_recv - 1;
|
||||||
|
syslog(LOG_DEBUG, "GRE: timeout waiting for %d packets", head->seq - gre.seq_recv - 1);
|
||||||
|
}
|
||||||
|
- syslog(LOG_DEBUG, "GRE: accepting #%d from queue", head->seq);
|
||||||
|
+ if (pptpctrl_debug) {
|
||||||
|
+ syslog(LOG_DEBUG, "GRE: accepting #%d from queue", head->seq);
|
||||||
|
+ }
|
||||||
|
gre.seq_recv = head->seq;
|
||||||
|
status = callback(cl, head->packet, head->packlen);
|
||||||
|
pqueue_del(head);
|
||||||
|
@@ -399,7 +404,9 @@
|
||||||
|
}
|
||||||
|
/* check for out-of-order sequence number */
|
||||||
|
if (seq_greater(seq, gre.seq_recv)) {
|
||||||
|
- syslog(LOG_DEBUG, "GRE: accepting packet #%d", seq);
|
||||||
|
+ if (pptpctrl_debug) {
|
||||||
|
+ syslog(LOG_DEBUG, "GRE: accepting packet #%d", seq);
|
||||||
|
+ }
|
||||||
|
stats.rx_accepted++;
|
||||||
|
gre.seq_recv = seq;
|
||||||
|
return cb(cl, buffer + ip_len + headersize, payload_len);
|
Loading…
Reference in New Issue