mirror of https://github.com/hak5/openwrt.git
kernel: update 3.9 to 3.9.11
Also refresh 3.9 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37501lede-17.01
parent
06a27059bd
commit
6a5b4ec7dc
|
@ -14,8 +14,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.8.13)
|
||||
LINUX_KERNEL_MD5SUM:=2af19d06cd47ec459519159cdd10542d
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.9.10)
|
||||
LINUX_KERNEL_MD5SUM:=2d69615f7074b952cfcb65f1356c0cc9
|
||||
ifeq ($(LINUX_VERSION),3.9.11)
|
||||
LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.10.1)
|
||||
LINUX_KERNEL_MD5SUM:=4c8ed240943c8750a89cc307637bd74d
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs atm
|
|||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
SUBTARGETS:=generic ac49x
|
||||
|
||||
LINUX_VERSION:=3.9.10
|
||||
LINUX_VERSION:=3.9.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm63xx
|
|||
BOARDNAME:=Broadcom BCM63xx
|
||||
SUBTARGETS:=generic smp
|
||||
FEATURES:=squashfs usb atm pci pcmcia
|
||||
LINUX_VERSION:=3.9.10
|
||||
LINUX_VERSION:=3.9.11
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs pci
|
|||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.9.10
|
||||
LINUX_VERSION:=3.9.11
|
||||
|
||||
KERNELNAME:="zImage"
|
||||
|
||||
|
|
|
@ -48,8 +48,8 @@
|
|||
return RX_HANDLER_CONSUMED; /* consumed by filter */
|
||||
} else {
|
||||
@@ -224,7 +224,7 @@ forward:
|
||||
if (!ether_addr_equal(p->br->dev->dev_addr, dest))
|
||||
goto drop;
|
||||
if (ether_addr_equal(p->br->dev->dev_addr, dest))
|
||||
skb->pkt_type = PACKET_HOST;
|
||||
|
||||
- if (NF_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
|
||||
+ if (BR_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
|
||||
|
|
|
@ -276,17 +276,17 @@ Subject: [PATCH 10/22] NET: MIPS: lantiq: update etop driver for devicetree
|
|||
struct ltq_etop_priv *priv = netdev_priv(dev);
|
||||
- int i;
|
||||
+ int mii_mode = priv->mii_mode;
|
||||
+
|
||||
+ clk_enable(priv->clk_ppe);
|
||||
|
||||
- ltq_pmu_enable(PMU_PPE);
|
||||
+ clk_enable(priv->clk_ppe);
|
||||
|
||||
- switch (priv->pldata->mii_mode) {
|
||||
+ if (of_machine_is_compatible("lantiq,ar9")) {
|
||||
+ ltq_etop_gbit_init(dev);
|
||||
+ /* force the etops link to the gbit to MII */
|
||||
+ mii_mode = PHY_INTERFACE_MODE_MII;
|
||||
+ }
|
||||
|
||||
- switch (priv->pldata->mii_mode) {
|
||||
+
|
||||
+ switch (mii_mode) {
|
||||
case PHY_INTERFACE_MODE_RMII:
|
||||
ltq_etop_w32_mask(ETOP_MII_MASK,
|
||||
|
|
Loading…
Reference in New Issue