mirror of https://github.com/hak5/openwrt.git
ar71xx: refresh patches
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 41615lede-17.01
parent
d0ad8c00b6
commit
68871def8d
|
@ -29,13 +29,11 @@
|
|||
- u32 bootstrap;
|
||||
+ void __iomem *phy_reg;
|
||||
+ u32 t;
|
||||
|
||||
- bootstrap = ath79_reset_rr(AR934X_RESET_REG_BOOTSTRAP);
|
||||
- if (bootstrap & AR934X_BOOTSTRAP_USB_MODE_DEVICE)
|
||||
+
|
||||
+ phy_reg = ioremap(base, 4);
|
||||
+ if (!phy_reg)
|
||||
return;
|
||||
|
||||
+ return;
|
||||
+
|
||||
+ t = ioread32(phy_reg);
|
||||
+ t &= ~0xff;
|
||||
+ t |= 0x58;
|
||||
|
@ -43,12 +41,14 @@
|
|||
+
|
||||
+ iounmap(phy_reg);
|
||||
+}
|
||||
+
|
||||
|
||||
- bootstrap = ath79_reset_rr(AR934X_RESET_REG_BOOTSTRAP);
|
||||
- if (bootstrap & AR934X_BOOTSTRAP_USB_MODE_DEVICE)
|
||||
+static void ar934x_usb_reset_notifier(struct platform_device *pdev)
|
||||
+{
|
||||
+ if (pdev->id != -1)
|
||||
+ return;
|
||||
+
|
||||
return;
|
||||
|
||||
+ enable_tx_tx_idp_violation_fix(0x18116c94);
|
||||
+ dev_info(&pdev->dev, "TX-TX IDP fix enabled\n");
|
||||
+}
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/arch/mips/ath79/Kconfig 2014-05-21 20:25:24.801106234 +0000
|
||||
+++ b/arch/mips/ath79/Kconfig 2014-05-21 20:28:20.489109814 +0000
|
||||
--- a/arch/mips/ath79/Kconfig
|
||||
+++ b/arch/mips/ath79/Kconfig
|
||||
@@ -462,6 +462,14 @@ config ATH79_MACH_RB2011
|
||||
select ATH79_ROUTERBOOT
|
||||
select RLE_DECOMPRESS
|
||||
|
@ -15,8 +15,8 @@
|
|||
config ATH79_MACH_WNDAP360
|
||||
bool "NETGEAR WNDAP360 board support"
|
||||
select SOC_AR71XX
|
||||
--- a/arch/mips/ath79/machtypes.h 2014-05-21 20:25:24.801106234 +0000
|
||||
+++ b/arch/mips/ath79/machtypes.h 2014-05-21 20:30:04.829111865 +0000
|
||||
--- a/arch/mips/ath79/machtypes.h
|
||||
+++ b/arch/mips/ath79/machtypes.h
|
||||
@@ -93,6 +93,8 @@ enum ath79_mach_type {
|
||||
ATH79_MACH_RB_2011G, /* Mikrotik RouterBOARD 2011UAS-2HnD */
|
||||
ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
|
||||
|
@ -26,8 +26,8 @@
|
|||
ATH79_MACH_RW2458N, /* Redwave RW2458N */
|
||||
ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
|
||||
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
|
||||
--- a/arch/mips/ath79/Makefile 2014-05-21 20:25:24.801106234 +0000
|
||||
+++ b/arch/mips/ath79/Makefile 2014-05-21 20:31:37.169113830 +0000
|
||||
--- a/arch/mips/ath79/Makefile
|
||||
+++ b/arch/mips/ath79/Makefile
|
||||
@@ -85,6 +85,7 @@ obj-$(CONFIG_ATH79_MACH_RB750) += mach-
|
||||
obj-$(CONFIG_ATH79_MACH_RB91X) += mach-rb91x.o
|
||||
obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
--- a/arch/mips/ath79/Kconfig
|
||||
+++ b/arch/mips/ath79/Kconfig
|
||||
@@ -647,7 +647,17 @@ config ATH79_MACH_TL_WAX50RE
|
||||
select ATH79_DEV_LEDS_GPIO
|
||||
@@ -656,6 +656,16 @@ config ATH79_MACH_TL_WAX50RE
|
||||
select ATH79_DEV_M25P80
|
||||
select ATH79_DEV_WMAC
|
||||
-
|
||||
+
|
||||
|
||||
+config ATH79_MACH_TL_WA830RE_V2
|
||||
+ bool "TP-LINK TL-WA830RE v2 support"
|
||||
+ select SOC_AR934X
|
||||
|
@ -21,7 +19,7 @@
|
|||
select SOC_AR724X
|
||||
--- a/arch/mips/ath79/Makefile
|
||||
+++ b/arch/mips/ath79/Makefile
|
||||
@@ -95,6 +95,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mac
|
||||
@@ -96,6 +96,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mac
|
||||
obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o
|
||||
obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
|
||||
obj-$(CONFIG_ATH79_MACH_TL_WAX50RE) += mach-tl-wax50re.o
|
||||
|
@ -31,12 +29,11 @@
|
|||
obj-$(CONFIG_ATH79_MACH_TL_WDR3500) += mach-tl-wdr3500.o
|
||||
--- a/arch/mips/ath79/machtypes.h
|
||||
+++ b/arch/mips/ath79/machtypes.h
|
||||
@@ -112,6 +112,7 @@ enum ath79_mach_type {
|
||||
@@ -114,6 +114,7 @@ enum ath79_mach_type {
|
||||
ATH79_MACH_TL_WA7510N_V1, /* TP-LINK TL-WA7510N v1*/
|
||||
ATH79_MACH_TL_WA850RE, /* TP-LINK TL-WA850RE */
|
||||
ATH79_MACH_TL_WA801ND_V2, /* TP-LINK TL-WA801ND v2 */
|
||||
+ ATH79_MACH_TL_WA830RE_V2, /* TP-LINK TL-WA830RE v2 */
|
||||
ATH79_MACH_TL_WA901ND, /* TP-LINK TL-WA901ND */
|
||||
ATH79_MACH_TL_WA901ND_V2, /* TP-LINK TL-WA901ND v2 */
|
||||
ATH79_MACH_TL_WA901ND_V3, /* TP-LINK TL-WA901ND v3
|
||||
|
||||
ATH79_MACH_TL_WA901ND_V3, /* TP-LINK TL-WA901ND v3 */
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/ath79/machtypes.h 2014-07-13 10:00:11.952353943 +0200
|
||||
+++ b/arch/mips/ath79/machtypes.h 2014-07-13 10:00:25.312354497 +0200
|
||||
@@ -113,6 +113,7 @@
|
||||
--- a/arch/mips/ath79/machtypes.h
|
||||
+++ b/arch/mips/ath79/machtypes.h
|
||||
@@ -113,6 +113,7 @@ enum ath79_mach_type {
|
||||
ATH79_MACH_TL_WA750RE, /* TP-LINK TL-WA750RE */
|
||||
ATH79_MACH_TL_WA7510N_V1, /* TP-LINK TL-WA7510N v1*/
|
||||
ATH79_MACH_TL_WA850RE, /* TP-LINK TL-WA850RE */
|
||||
|
|
Loading…
Reference in New Issue