fix elinks, add MD5SUM, explicitely disable what seems not required, standardize.

SVN-Revision: 3511
lede-17.01
Nicolas Thill 2006-03-27 21:18:37 +00:00
parent 5b89a1ff7d
commit 668483e721
2 changed files with 58 additions and 20 deletions

View File

@ -5,6 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elinks PKG_NAME:=elinks
PKG_VERSION:=0.11.1 PKG_VERSION:=0.11.1
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_MD5SUM:=c09d726075e4b5810fa07f8654088755
PKG_SOURCE_URL:=http://elinks.or.cz/download/ PKG_SOURCE_URL:=http://elinks.or.cz/download/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@ -19,28 +20,54 @@ $(eval $(call PKG_template,ELINKS,elinks,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $${x}=yes && \ x=`echo ac_cv_file_./features.conf | tr [:blank:]-/. _` && export $${x}=yes && \
x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $${x}=yes && \
$(TARGET_CONFIGURE_OPTS) \ $(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \ CFLAGS="$(TARGET_CFLAGS)" \
ac_cv_c_bigendian=no \ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
ac_cv_sizeof_off_t=8 \ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
ac_cv_file___features_conf=yes \
./configure \ ./configure \
--target=$(GNU_TARGET_NAME) \ --target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \ --host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \ --build=$(GNU_HOST_NAME) \
--disable-largefile\ --program-prefix="" \
--disable-formhist\ --program-suffix="" \
--disable-mailcap\ --prefix=/usr \
--disable-data\ --exec-prefix=/usr \
--disable-uri-rewrite\ --bindir=/usr/bin \
--enable-256-colors\ --datadir=/usr/share \
--disable-backtrace\ --includedir=/usr/include \
--enable-small\ --infodir=/usr/share/info \
--without-spidermonkey\ --libdir=/usr/lib \
--without-x\ --libexecdir=/usr/lib \
--disable-ipv6 \ --localstatedir=/var \
$(DISABLE_NLS) \ --mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
--enable-small\
--enable-256-colors\
--disable-backtrace\
--disable-data\
--disable-formhist\
--disable-leds \
--disable-mailcap\
--disable-mouse \
--disable-smb \
--disable-uri-rewrite\
--disable-xbel \
--without-bzlib \
--without-gpm \
--without-idn \
--without-gnutls \
--without-libiconv \
--without-lua \
--with-openssl="$(STAGING_DIR)/usr" \
--without-spidermonkey\
--without-x\
--without-zlib \
--disable-ipv6 \
); );
touch $@ touch $@

View File

@ -0,0 +1,11 @@
diff -ruN elinks-0.11.1-old/src/util/time.h elinks-0.11.1-new/src/util/time.h
--- elinks-0.11.1-old/src/util/time.h 2006-01-29 14:10:39.000000000 +0100
+++ elinks-0.11.1-new/src/util/time.h 2006-03-27 23:09:08.000000000 +0200
@@ -1,6 +1,7 @@
#ifndef EL__UTIL_TIME_H
#define EL__UTIL_TIME_H
+#include <sys/types.h>
#ifdef HAVE_SYS_TIME_H
#include <sys/time.h>
#endif