mirror of https://github.com/hak5/openwrt.git
Create iptraf directories Build mod_webdav for lighttpd Fix libtool patch
SVN-Revision: 3661lede-17.01
parent
965f68dcac
commit
624bba95de
|
@ -42,7 +42,7 @@ libnids-compile: libnet-compile
|
|||
libvorbis-compile: libogg-compile
|
||||
libxml2-compile: zlib-compile
|
||||
libxslt-compile: libxml2-compile
|
||||
lighttpd-compile: openssl-compile pcre-compile
|
||||
lighttpd-compile: openssl-compile pcre-compile libxml2-compile sqlite-compile
|
||||
logrotate-compile: popt-compile
|
||||
madplay-compile: libid3tag-compile libmad-compile
|
||||
miax-compile: bluez-libs-compile
|
||||
|
|
|
@ -36,7 +36,9 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
|
|||
touch $@
|
||||
|
||||
$(IPKG_IPTRAF):
|
||||
install -d -m0755 $(IDIR_IPTRAF)/usr/bin
|
||||
install -d -m0755 $(IDIR_IPTRAF)/usr/bin \
|
||||
$(IDIR_IPTRAF)/var/run/iptraf \
|
||||
$(IDIR_IPTRAF)/var/lib/iptraf
|
||||
install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(IDIR_IPTRAF)/usr/bin/
|
||||
$(RSTRIP) $(IDIR_IPTRAF)
|
||||
$(IPKG_BUILD) $(IDIR_IPTRAF) $(PACKAGE_DIR)
|
||||
|
|
|
@ -0,0 +1,15 @@
|
|||
diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
|
||||
--- libtool-1.5.14/libltdl/acinclude.m4 2005-02-12 13:20:02.000000000 +0100
|
||||
+++ libtool-1.5.14.new/libltdl/acinclude.m4 2006-04-16 11:22:03.000000000 +0200
|
||||
@@ -6228,10 +6228,9 @@
|
||||
;;
|
||||
esac
|
||||
])
|
||||
-if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
|
||||
+AC_DEFUN([AC_LTDL_SYS_DLOPEN_DEPLIBS],
|
||||
AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
|
||||
[Define if the OS needs help to load dependent libraries for dlopen().])
|
||||
-fi
|
||||
])# AC_LTDL_SYS_DLOPEN_DEPLIBS
|
||||
|
||||
|
|
@ -42,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_SIMPLE_VHOST,lighttpd-mod-simple-vhost,$
|
|||
$(eval $(call PKG_template,LIGHTTPD_MOD_SSI,lighttpd-mod-ssi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,LIGHTTPD_MOD_WEBDAV,lighttpd-mod-webdav,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
|
||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
|
||||
|
@ -58,6 +59,7 @@ $(eval $(call PKG_mod_template,LIGHTTPD_MOD_SIMPLE_VHOST,simple_vhost))
|
|||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_SSI,ssi))
|
||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_STATUS,status))
|
||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_USERTRACK,usertrack))
|
||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_WEBDAV,webdav))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
|
@ -101,7 +103,7 @@ $(PKG_BUILD_DIR)/.configured:
|
|||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-pcre \
|
||||
--without-valgrind \
|
||||
--without-webdav-props \
|
||||
--with-webdav-props \
|
||||
)
|
||||
touch $@
|
||||
|
||||
|
@ -109,6 +111,7 @@ $(PKG_BUILD_DIR)/.built:
|
|||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
STAGING_DIR=$(STAGING_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
touch $@
|
||||
|
|
|
@ -0,0 +1,5 @@
|
|||
Package: lighttpd-mod-webdav
|
||||
Priority: optional
|
||||
Section: net
|
||||
Description: a webdav module for lighttpd
|
||||
Depends: lighttpd, libxml2, sqlite
|
|
@ -0,0 +1,12 @@
|
|||
diff -urN lighttpd-1.4.11/src/Makefile.in lighttpd-1.4.11.new/src/Makefile.in
|
||||
--- lighttpd-1.4.11/src/Makefile.in 2006-03-07 13:21:02.000000000 +0100
|
||||
+++ lighttpd-1.4.11.new/src/Makefile.in 2006-04-17 00:16:12.000000000 +0200
|
||||
@@ -409,7 +409,7 @@
|
||||
STRIP = @STRIP@
|
||||
U = @U@
|
||||
VERSION = @VERSION@
|
||||
-XML_CFLAGS = @XML_CFLAGS@
|
||||
+XML_CFLAGS = -I$(STAGING_DIR)/usr/include/libxml2
|
||||
XML_LIBS = @XML_LIBS@
|
||||
Z_LIB = @Z_LIB@
|
||||
ac_ct_AR = @ac_ct_AR@
|
Loading…
Reference in New Issue