mirror of https://github.com/hak5/openwrt.git
binutils: update to version 2.34
Fixes perf on aarch64 Signed-off-by: Felix Fietkau <nbd@nbd.name>master
parent
bab0d1c33c
commit
60f595daab
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=binutils
|
PKG_NAME:=binutils
|
||||||
PKG_VERSION:=2.27
|
PKG_VERSION:=2.34
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=@GNU/binutils
|
PKG_SOURCE_URL:=@GNU/binutils
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_VERSION:=$(PKG_VERSION)
|
PKG_VERSION:=$(PKG_VERSION)
|
||||||
PKG_HASH:=369737ce51587f92466041a97ab7d2358c6d9e1b6490b3940eb09fb0a9a6ac88
|
PKG_HASH:=f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld libiberty gold intl
|
PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld libiberty gold intl
|
||||||
|
@ -37,10 +37,17 @@ define Package/libbfd
|
||||||
DEPENDS:=+zlib $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
DEPENDS:=+zlib $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/libctf
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
TITLE:=libctf
|
||||||
|
DEPENDS:=+libbfd
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/libopcodes
|
define Package/libopcodes
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=libbfd
|
TITLE:=libopcodes
|
||||||
DEPENDS:=+libbfd
|
DEPENDS:=+libbfd
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -56,7 +63,7 @@ define Package/objdump
|
||||||
SECTION:=devel
|
SECTION:=devel
|
||||||
CATEGORY:=Development
|
CATEGORY:=Development
|
||||||
TITLE:=objdump
|
TITLE:=objdump
|
||||||
DEPENDS:=+libopcodes
|
DEPENDS:=+libopcodes +libctf
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/ar
|
define Package/ar
|
||||||
|
@ -94,7 +101,12 @@ endef
|
||||||
|
|
||||||
define Package/libbfd/install
|
define Package/libbfd/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so* $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libctf/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf.so* $(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libopcodes/install
|
define Package/libopcodes/install
|
||||||
|
@ -121,6 +133,7 @@ define Package/binutils/install
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libbfd))
|
$(eval $(call BuildPackage,libbfd))
|
||||||
|
$(eval $(call BuildPackage,libctf))
|
||||||
$(eval $(call BuildPackage,libopcodes))
|
$(eval $(call BuildPackage,libopcodes))
|
||||||
$(eval $(call BuildPackage,binutils))
|
$(eval $(call BuildPackage,binutils))
|
||||||
$(eval $(call BuildPackage,objdump))
|
$(eval $(call BuildPackage,objdump))
|
||||||
|
|
|
@ -1,65 +0,0 @@
|
||||||
From 183eb37e25d903ccd68cc2d8f8a37e75872c03d2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Nick Clifton <nickc@redhat.com>
|
|
||||||
Date: Tue, 6 Sep 2016 17:35:35 +0100
|
|
||||||
Subject: [PATCH 1/2] Do not pass host compiler sanitization flags on to linker
|
|
||||||
testsuite.
|
|
||||||
|
|
||||||
* Makefile.am (CFLAGS_FOR_TARGET): Define as a copy of CFLAGS but
|
|
||||||
without any sanitization options.
|
|
||||||
(CXXFLAGS_FOR_TARGET): Define as a copy of CXXFLAGS but without
|
|
||||||
any sanitization options.
|
|
||||||
(check-DEJAGNU): Pass CFLAGS_FOR_TARGET and CXXFLAGS_FOR_TARGET
|
|
||||||
as CFLAGS and CXXFLAGS respectively.
|
|
||||||
---
|
|
||||||
ld/Makefile.am | 8 ++++++--
|
|
||||||
ld/Makefile.in | 8 ++++++--
|
|
||||||
2 files changed, 12 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
--- a/ld/Makefile.am
|
|
||||||
+++ b/ld/Makefile.am
|
|
||||||
@@ -136,6 +136,10 @@ CXX_FOR_TARGET = ` \
|
|
||||||
fi; \
|
|
||||||
fi`
|
|
||||||
|
|
||||||
+# Strip out sanitization options as we want to test building binaries without any extra paraphernalia
|
|
||||||
+CFLAGS_FOR_TARGET = `echo $(CFLAGS) | sed -e 's/-fsanitize=address//g' -e 's/-fsanitize=undefined//g'`
|
|
||||||
+CXXFLAGS_FOR_TARGET = `echo $(CXXFLAGS) | sed -e 's/-fsanitize=address//g' -e 's/-fsanitize=undefined//g'`
|
|
||||||
+
|
|
||||||
transform = s/^ld-new$$/$(installed_linker)/;@program_transform_name@
|
|
||||||
bin_PROGRAMS = ld-new
|
|
||||||
info_TEXINFOS = ld.texinfo
|
|
||||||
@@ -2075,8 +2079,8 @@ check-DEJAGNU: site.exp
|
|
||||||
runtest=$(RUNTEST); \
|
|
||||||
if $(SHELL) -c "$$runtest --version" > /dev/null 2>&1; then \
|
|
||||||
$$runtest --tool $(DEJATOOL) --srcdir $${srcroot}/testsuite \
|
|
||||||
- CC="$(CC_FOR_TARGET)" CFLAGS="$(CFLAGS)" \
|
|
||||||
- CXX="$(CXX_FOR_TARGET)" CXXFLAGS="$(CXXFLAGS)" \
|
|
||||||
+ CC="$(CC_FOR_TARGET)" CFLAGS="$(CFLAGS_FOR_TARGET)" \
|
|
||||||
+ CXX="$(CXX_FOR_TARGET)" CXXFLAGS="$(CXXFLAGS_FOR_TARGET)" \
|
|
||||||
CC_FOR_HOST="$(CC)" CFLAGS_FOR_HOST="$(CFLAGS)" \
|
|
||||||
OFILES="$(OFILES)" BFDLIB="$(TESTBFDLIB)" \
|
|
||||||
LIBIBERTY="$(LIBIBERTY) $(LIBINTL)" LIBS="$(LIBS)" \
|
|
||||||
--- a/ld/Makefile.in
|
|
||||||
+++ b/ld/Makefile.in
|
|
||||||
@@ -507,6 +507,10 @@ CXX_FOR_TARGET = ` \
|
|
||||||
fi; \
|
|
||||||
fi`
|
|
||||||
|
|
||||||
+
|
|
||||||
+# Strip out sanitization options as they require special host libraries.
|
|
||||||
+CFLAGS_FOR_TARGET = `echo $(CFLAGS) | sed -e 's/-fsanitize=address//g' -e 's/-fsanitize=undefined//g'`
|
|
||||||
+CXXFLAGS_FOR_TARGET = `echo $(CXXFLAGS) | sed -e 's/-fsanitize=address//g' -e 's/-fsanitize=undefined//g'`
|
|
||||||
info_TEXINFOS = ld.texinfo
|
|
||||||
ld_TEXINFOS = configdoc.texi
|
|
||||||
noinst_TEXINFOS = ldint.texinfo
|
|
||||||
@@ -3644,8 +3648,8 @@ check-DEJAGNU: site.exp
|
|
||||||
runtest=$(RUNTEST); \
|
|
||||||
if $(SHELL) -c "$$runtest --version" > /dev/null 2>&1; then \
|
|
||||||
$$runtest --tool $(DEJATOOL) --srcdir $${srcroot}/testsuite \
|
|
||||||
- CC="$(CC_FOR_TARGET)" CFLAGS="$(CFLAGS)" \
|
|
||||||
- CXX="$(CXX_FOR_TARGET)" CXXFLAGS="$(CXXFLAGS)" \
|
|
||||||
+ CC="$(CC_FOR_TARGET)" CFLAGS="$(CFLAGS_FOR_TARGET)" \
|
|
||||||
+ CXX="$(CXX_FOR_TARGET)" CXXFLAGS="$(CXXFLAGS_FOR_TARGET)" \
|
|
||||||
CC_FOR_HOST="$(CC)" CFLAGS_FOR_HOST="$(CFLAGS)" \
|
|
||||||
OFILES="$(OFILES)" BFDLIB="$(TESTBFDLIB)" \
|
|
||||||
LIBIBERTY="$(LIBIBERTY) $(LIBINTL)" LIBS="$(LIBS)" \
|
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue