mirror of https://github.com/hak5/openwrt.git
parent
923008ecc8
commit
5fd9e811c6
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.42
|
PKG_VERSION:=2.43
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||||
PKG_MD5SUM:=78a23a31a35b8427a8589b76c1ae3ff6
|
PKG_MD5SUM:=3222690c6f1f919bcefcf01a632508af
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,8 @@
|
||||||
diff -ur dnsmasq-2.42.orig/src/config.h dnsmasq-2.42/src/config.h
|
Index: dnsmasq-2.43/src/config.h
|
||||||
--- dnsmasq-2.42.orig/src/config.h 2008-06-03 16:38:25.000000000 +0200
|
===================================================================
|
||||||
+++ dnsmasq-2.42/src/config.h 2008-06-03 16:38:43.000000000 +0200
|
--- dnsmasq-2.43.orig/src/config.h 2008-07-18 16:36:53.000000000 +0200
|
||||||
@@ -322,8 +322,9 @@
|
+++ dnsmasq-2.43/src/config.h 2008-07-18 16:37:40.000000000 +0200
|
||||||
|
@@ -288,8 +288,9 @@
|
||||||
/* We assume that systems which don't have IPv6
|
/* We assume that systems which don't have IPv6
|
||||||
headers don't have ntop and pton either */
|
headers don't have ntop and pton either */
|
||||||
|
|
||||||
|
|
|
@ -1,30 +0,0 @@
|
||||||
Index: dnsmasq-2.42/src/dnsmasq.c
|
|
||||||
===================================================================
|
|
||||||
--- dnsmasq-2.42.orig/src/dnsmasq.c 2008-06-28 23:37:18.000000000 +0200
|
|
||||||
+++ dnsmasq-2.42/src/dnsmasq.c 2008-06-28 23:37:20.000000000 +0200
|
|
||||||
@@ -297,8 +297,11 @@
|
|
||||||
capget(hdr, NULL);
|
|
||||||
if (hdr->version != LINUX_CAPABILITY_VERSION_1)
|
|
||||||
{
|
|
||||||
- /* if not version 1, use version 2 */
|
|
||||||
- hdr->version = LINUX_CAPABILITY_VERSION_2;
|
|
||||||
+ /* if unknown version, use largest supported version (3)
|
|
||||||
+ * backported fix from 2.43 to suppress kernel warning
|
|
||||||
+ */
|
|
||||||
+ if (hdr->version != LINUX_CAPABILITY_VERSION_2)
|
|
||||||
+ hdr->version = LINUX_CAPABILITY_VERSION_3;
|
|
||||||
capsize = 2;
|
|
||||||
}
|
|
||||||
hdr->pid = 0; /* this process */
|
|
||||||
Index: dnsmasq-2.42/src/dnsmasq.h
|
|
||||||
===================================================================
|
|
||||||
--- dnsmasq-2.42.orig/src/dnsmasq.h 2008-06-28 23:37:48.000000000 +0200
|
|
||||||
+++ dnsmasq-2.42/src/dnsmasq.h 2008-06-28 23:37:55.000000000 +0200
|
|
||||||
@@ -100,6 +100,7 @@
|
|
||||||
extern int capget(cap_user_header_t header, cap_user_data_t data);
|
|
||||||
#define LINUX_CAPABILITY_VERSION_1 0x19980330
|
|
||||||
#define LINUX_CAPABILITY_VERSION_2 0x20071026
|
|
||||||
+#define LINUX_CAPABILITY_VERSION_3 0x20080522
|
|
||||||
|
|
||||||
#include <sys/prctl.h>
|
|
||||||
#elif defined(HAVE_SOLARIS_PRIVS)
|
|
Loading…
Reference in New Issue