mt76: update to the latest version

Fixes a tx locking error and adds a pci id

Signed-off-by: Felix Fietkau <nbd@nbd.name>
lede-17.01
Felix Fietkau 2016-05-05 19:42:43 +01:00
parent 6259583ef3
commit 5b64e3532a
2 changed files with 2 additions and 13 deletions

View File

@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mt76
PKG_VERSION:=2016-03-04
PKG_VERSION:=2016-04-27
PKG_RELEASE=1
PKG_LICENSE:=GPLv2
@ -10,7 +10,7 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=7059cc27df894a4b845b6deb7c51425ffb4b7c5c
PKG_SOURCE_VERSION:=7605d326e6f6dcc3cf0cceea9779f3fd15e1eca7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>

View File

@ -1,11 +0,0 @@
--- a/mt7603_mac.c
+++ b/mt7603_mac.c
@@ -474,7 +474,7 @@
bool stbc = false;
int n_rates = sta->n_rates;
u8 bw, bw_prev, bw_idx = 0;
- u16 val[8];
+ u16 val[8] = { 0 };
u32 w9 = mt76_rr(dev, addr + 9 * 4);
int count;
int i;